Actualización de Joomla 1.6.6 a Joomla 1.7  

 
neilense
 neilense
Usuario activo

Hola, muy buenas a todos.

Mi problema es el siguiente:

Me descargué la plantilla JA Portfolio de la Web Joomlart.com. Esta venia con un pack completo de instalación de Joomla 1.6.6, el cual instale sin problemas. Al venir en inglés le aplique el pack de idioma en español para la versión 1.6.6 de JoomlaSpanish y todo funciona correctamente. Ahora he visto que ya está disponible la actualización en español a la versión 1.7. Me descargo el pack de actualización 1.6.5 a 1.7 ya que no existe otro disponible y lo intento instalar mediante el gestor de extensiones del administrador de Joomla. Me da el siguiente error:

Se ha producido un error al subir el archivo al servidor.

He probado con otros módulos, complementos, etc. y se suben e instalan correctamente. También he intentado instalar el pack de actualización en inglés dándome el mismo error.

Otra cosa que he intentado es actualizarlo mediante el Gestor de extensiones - Actualizar, borrando primero la caché y pulsando en Buscar actualizaciones" dándome el siguiente error:

Actualización: :Collection: No se pudo abrir http://update.joomla.org/core/list.xml
Actualización: :Collection: No se pudo abrir http://update.joomla.org/jed/list.xml
Actualización: :Collection: No se pudo abrir http://update.joomlart.com/service/tracking/list.xml

La verdad que no se donde puede estar el problema y no se que más intentar. ¿Podría ser por la plantilla? Agradecería vuestra colaboración.

Muchas gracias.

Saludos.

Citar
Respondido : 15/08/2011 10:31 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Diego Gil Gaitán,

El pack que descargaste es un pack completo, o sea que no upgradea sino que sirve para instalar limpio, de cero en un espacio no ocupado por otro Joomla!.

La migración de 1.6.6 a 1.70. desde el backend es automática "solo" para el core de Joomla! no para la plantilla, ya que dicha plantilla aún no ha sido portada al 1.7 por sus desarrolladores.

Toca esperar a que la liberen para Joomla! 1.7. En otros post de este Foro hemos hablado de ese mismo problema y de lo que JoomlArt dice al respecto, y es que a partir de agosto y "progresivamente" irán liberando sus plantillas para la nueva rama.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/08/2011 10:36 pm

Cursos Gratuitos WordPress

neilense
 neilense
Usuario activo

Muchísimas gracias por la rápida respuesta, pero no me queda del todo claro.

Primeramente, como indico en mi anterior consulta, me descargué el pack completo de Joomla 1.6.6 con la plantilla incluida de la página Joomlart.com y lo instale en limpio.

Luego instale el pack de idiomas en español para 1.6.6 de JoomlaSpanish y todo perfecto.

Ahora me he descargado el pack de actualización "Joomla_1.6.5_a_1.7.0_Pack_Spanish.zip" ya que según dice la página JoomlaSpanish sirve tanto para actualizar de 1.6.5 a 7 como de 1.6.6 a 7. He seguido las instrucciones de instalación que se dictan en la Web, es decir subiendo el archivo con el gestor de extensiones, dándome el siguiente error: "Se ha producido un error al subir el archivo al servidor." Todo esto también lo he intentado con el pack de actualización en inglés de Joomla.org, dándome el mismo error. Tengo entendido que la actualización de Joomla 1.6 a 1.7 no es agresiva y no supone migraciones, etc. También tengo entendido que las plantillas de Joomla 1.6 son perfectamente válidas para 1.7, hay mucha gente que les funcionan. Yo me imagino, pero no lo se, que el núcleo de Joomla es el mismo en todos tenga la plantilla que tenga.

No entiendo muy bien este tema, ¿una actualización manual se podría realizar?

Tampoco me queda muy claro que no funcione el tema de las actualizaciones automáticas, los errores que muestran parecen debidos a otras causas:

Actualización: :Collection: No se pudo abrir update.joomla.org/core/list.xml
Actualización: :Collection: No se pudo abrir update.joomla.org/jed/list.xml
Actualización: :Collection: No se pudo abrir update.joomlart.com/service/tracking/list.xml

Si no queda más remedio pues esperare a que saquen la versión de la plantilla para 1.7, pero ¿esto quiere decir que toda actualización de Joomla tengo que descargarla de Joomlart? Me parece raro eso.

Muchas gracias.

ResponderCitar
Respondido : 15/08/2011 11:16 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Diego Gil Gaitán,

Los errores que muestras:

Actualización: :Collection: No se pudo abrir update.joomla.org/core/list.xml
Actualización:: Collection: No se pudo abrir update.joomla.org/jed/list.xml
Actualización:: Collection: No se pudo abrir update.joomlart.com/service/tracking/list.xml

Son derivados de la configuración de los repositorios de actualización que necesitan que la variable fopen de PHP este habilitada en el servidor.

Normalmente se deshabilita por razones obvias de seguridad.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/08/2011 11:27 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

neilense
 neilense
Usuario activo

Bien, entonces no es problema de la plantilla si no del servidor. Resumiendo, mi pregunta sigue siendo ¿cómo podría actualizar a Joomla 1.7 desde Joomla 1.6.6.

Gracias.

Saludos.

ResponderCitar
Respondido : 15/08/2011 11:30 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Diego Gil Gaitán,

Resumiendo: utilizando el sistema interno que trae Joomla! 1.6.6 para realizar dicho proceso. Logicamente realizar una copia de seguridad, preferible con Akeeba Backup antes de realizar dicho proceso.

Para que los técnicos revisen el problema de fopen debes poner un ticket a soporte.

Te adjuntamos unos vídeos para poder copiar y restaurar un Joomla!:

Como copiar tu Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_copiadeseguridad/akeeba_copiadeseguridad.html

Como restaurar tu Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_restauracion/akeeba_restauracion.html

En el caso que pongas una contraseña al realizar un backup apúntala para luego introducirla en la restauración.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/08/2011 11:35 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

neilense
 neilense
Usuario activo

Gracias por los enlaces, muy útiles. Supongo que siendo una política de seguridad no me interesa que estén habilitadas esas variables, de hecho, lo mismo ni me las activan. Mi pregunta sigue siendo que, teniendo en cuenta los problemas anteriormente expuestos, ¿habría alguna forma de actualizar a 1.7?. Ya sea de forma manual o automática, que no sea siempre dependiendo de lo que hagan en Joomlart. El error también me da al intentar subirlo mediante el gestor de extensiones como se dice en JoomlaSpanish:

También puedes descargar el paquete de actualización si ya utilizas una versión 1.6.5 o 1.6.6. de Joomla! Spanish:
Descarga el paquete de actualización, la forma de actualizar este pack es desde nuestra Administración de Joomla! Extensiones/Gestor de extensiones/Instalar/Archivo empaquetado.

Hacer esto me da el error:

Se ha producido un error al subir el archivo al servidor.

Con módulos, complementos y otras extensiones si funciona.

Gracias.

ResponderCitar
Respondido : 15/08/2011 11:43 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Diego Gil Gaitán,

Como entiendo que tienes acceso al club de JoomlArt, podrías probar a instalar un pack de Joomla! 1.7.0 limpio y luego desde el mismo instalar la plantilla y así verificar que realmente esta adaptada para ser migrada.

De lo que si estoy seguro es que el método de migración desarrollado por Joomla.org funciona, sino no se habría implementado, eso si, funciona con el core no con las extensiones de terceros y eso incluye las plantillas.

Nosotros haremos las pruebas pertinentes para descartar si es problema de la migración, la plantilla, el servidor u otras causas y procuraremos comentarlas por aquí.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/08/2011 12:08 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

neilense
 neilense
Usuario activo

Bien, muchas gracias, creo que ya me voy aclarando entonces. La verdad que, en un principio, instalé el 1.7 limpio y luego no pude instalarle la plantilla de JoomlArt. Por eso me decidí a bajar todo el pack con la plantilla incluida del 1.6.6.

Entonces, deduzco, que el core de Joomla con la plantilla de JoomlArt ha sido modificado y por eso no puedo instalar las actualizaciones de Joomla.org, haga lo que haga.

No me queda más remedio que esperar a que saquen la actualización de la plantilla, si no he entendido mal.

Gracias de nuevo.

ResponderCitar
Respondido : 16/08/2011 12:18 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Diego Gil Gaitán,

Nosotros haremos las pruebas pertinentes para descartar si es problema de la migración, la plantilla, el servidor u otras causas y procuraremos comentarlas por aquí.

Espero que tengamos conclusiones antes de que JoomlArt saque la versión para la 1.7 porque sino no avanzamos. 🙂

Lo que si es cierto es que no esperes trabajar en Joomla! 1.7.0 tal como lo haces en Joomla! 1.5, sobre todo si consideras que hay 8000 extensiones en el JED (o más) y solo 1600 para Joomla! 1.6 y de esas pon que menos de la mitad funcionan "correctamente" en 1.7

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/08/2011 1:09 am

Cursos Gratuitos WordPress

neilense
 neilense
Usuario activo

Muchas gracias. Un gran trabajo. Todo claro.

Saludos.

ResponderCitar
Respondido : 16/08/2011 1:16 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Diego Gil Gaitán,

¿Podrías facilitar la url en la que te pasa?

Tal como te dije anteriormente, envía un ticket a soporte para que le habiliten el allow_url_fopen.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/08/2011 2:14 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

neilense
 neilense
Usuario activo

Hola buenos días, la URL es la siguiente: http://www.turismoesvida.es/

Bien, enviaré un Ticket de soporte.

Muchas gracias.

ResponderCitar
Respondido : 16/08/2011 10:26 am
neilense
 neilense
Usuario activo

Hola buenos días, la URL es la siguiente: http://www.turismoesvida.es/

Bien, enviaré un Ticket de soporte.

Muchas gracias.

Ya he recibido respuesta y ha sido activada la directiva. Procedo a buscar actualizaciones, efectivamente ya no dan los errores, pero me dice que no encuentra ninguna :woohoo:

Yo creo que voy a trabajar con lo que tengo y olvidarme de actualizar a 1.7 de momento.

ResponderCitar
Respondido : 16/08/2011 10:46 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro