Error 404 cuando cambio de idioma pero funciona si borro las www de la url  

 
Nuria
 Nuria
Estimable Member

Hola, he visto que mi web da error al entrar las url antes no ocurria y no se a que es debido. Veo que todas funcionan si escribo https:// pero si por ejemplo escribo https://www.sucrechic.com/index.php/de/cupcakes-01 funciona y al cambiar de idioma da el error 404 pero me he dado cuenta que si borro www entonces funiciona la verdad no se como solucionarlo os envio una captura a ver si teneis alguna solucion porque antes funionaba...

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 21/06/2014 4:42 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Nuria,

No se hasta que punto el problema está relacionado con multiidiomas o VirtueMart pues en productos como el que cito se ve igual con o sin protocolo https://

Contenido solo visible a usuarios registrados

Veo exactamente lo mismo, por lo que tendrías que revisar aquellos productos que fallan con protocolo https:// para ver si la causa es otra.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/06/2014 10:39 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Nuria
 Nuria
Estimable Member

Hola Luis, si se ve igual pero no pongo www delante, tenia links que ahora no funcionan dan error porque cuando los comparti en facebook por ejemplo eran asi https://www o http://www ahora las 3 w no funcionan en ingles y aleman solo en español y cuando cambio el idioma da error.
Alguna idea de porque ocurre?
Gracias 🙂

ResponderCitar
Respondido : 21/06/2014 11:39 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Nuria,

¿Puedes indicarnos que códigos de redirección tienes aplicados en tu archivo .htaccess? de la instalación Contenido solo visible a usuarios registrados

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/06/2014 1:06 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Nuria
 Nuria
Estimable Member

Hola Luis, ha hecho dos capturas de lo que tengo en htacces....
Gracias,

ResponderCitar
Respondido : 22/06/2014 8:42 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Nuria

En tu captura aparentemente no veo ninguna redirección que te pueda causar el problema, puedes probar deshabilitando temporalmente las urls amigables y verificar si te sucede lo mismo?

Tienes algún plugins SEO o de urls amigables adicional ?, o has configurado en algún lotro ugar el tema de redirección con www?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/06/2014 6:10 pm

Cursos Gratuitos WordPress

Nuria
 Nuria
Estimable Member

Hola Jhon ya he desconectado lo de las url amigables, te mando una captura. De todas maneras antes funcionaba con las url amigables.
Otra cosa que te queria comentar es que en public_html/sucrechic.com he visto 2 htacces uno que se llama .thacces y el otro htacces.txt esto es correcto? Te mando las capturas de este archivo htacces.txt
He visto que en mi url siempre aparece la palabra index php es posible eliminarla?
Muchas gracias,
Nuria

ResponderCitar
Respondido : 22/06/2014 7:00 pm
Nuria
 Nuria
Estimable Member

Hola de nuevo, ahora me he fijado que si desconecto las url amigables la url que antes era asi:
sucrechic.com/index.php/es/informacion-general/noticias ahora es esta:
sucrechic.com/index.php?option=com_content&view=category&layout=blog&id=79&Itemid=545&lang=es

asi que he vuelto a conectar las url amigables, pero el problema persiste si desaparecen las www y si estan por ejemplo en español en sucrechic.com/index.php/es/catering-1 (el 1 es el numero que uso en el alias para el idioma español) cuando cambio al idioma aleman sucrechic.com/index.php/de/catering-2 aparece de nuevo el error 404 funciona sin www
Estoy como al principio... las url amigables quiero conservarlas pero este error no se como solucionarlo.
Saludos,
Nuria

ResponderCitar
Respondido : 22/06/2014 7:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Nuria
 Nuria
Estimable Member

Gracias a Jhon y Luis, ya esta solucionado
Saludos

ResponderCitar
Respondido : 23/06/2014 11:43 am

Por favor Iniciar Sesión o Registro