Error bucle del sistema al publicar plugin "Sistemas - Filtrar idiomas"  

 
Tony
 Tony
Usuario experto

Buenas,

estaba empezando a poner la web en multi idioma (Español y Portugués de Brasil), con la guía del vídeo que tenéis en vídeosjoomla 1ª parte de Multi idiomas pero en el momento que paso a "habilitar el plugin de Sistema - Filtrar idiomas" y voy a cualquier parte de la web en el front, a cualquier sección o apartado de la misma, me sale el error "Esta página tiene un bucle de redireccionamiento" y hasta que no vuelvo a deshabilitar el plugin "Sistema - Filtrar idiomas", no deja de dar dicho error.

Dejo varias capturas para un mejor entendimiento. También he mirado antes en el foro y se da un error parecido expuesto por Irene, pero que no me ha servido para poder arreglarlo.

Paso a dejaros los pantallazos:

p-0: Gestor de idiomas: idiomas instalados

p-1: Estado de parámetros multilingüe

p-2: Gestor de plugins: Sistema - Filtrar Idiomas

p-3: Error que da al ir a cualquier apartado de la web con el plug "Sistema - Filtrar Idiomas" habilitado

p-4: Gestor de idiomas: Idiomas del contenido

p-5: Gestor de Módulos: Módulo selector de Idioma

Gracias por adelantado por cualquier orientación al respecto que podáis darme.

Versión Joomla 2.5.8
Idioma Español 2.5.8.1
Idioma Portugúés de Brasil 2.5.7.1
Idioma Inglés 2.5.5
Community Builder 1.8.1

URL del sitio: Contenido solo visible a usuarios registrados

No se cansará de esperarte, aquel que no se canse de mirarte.

www.komplices.es

Citar
Respondido : 15/12/2012 8:19 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Tony,

¿Puedes facilitar una captura del ítem de menú "Inicio"?

No se si anteriormente te hemos dado esta indicación, en caso de que no lo hayamos hecho, revisa los siguientes enlaces por si te son de utilidad:

- Módulo Estatus Multilenguaje (1ª parte de multi-idiomas en Joomla! 2.5): https://www.webempresa.com/blog/modulo-estatus-multilenguaje-1-parte-de-multi-idiomas-en-joomla-25.html

- Artículos, menús y módulos en multilenguaje (2ª parte de multi-idiomas en Joomla! 2.5):

- Plantillas en un Joomla! con varios idiomas (3ª parte de multi-idiomas en Joomla! 2.5): https://www.webempresa.com/blog/plantillas-en-un-joomla-con-varios-idiomas-3-parte-de-multi-idiomas-en-joomla-25.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/12/2012 9:45 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Tony
 Tony
Usuario experto

Hola Luis Méndez Alejo,

los enlaces que me pasas de los vídeos multi lenguaje, son los que exactamente estoy siguiendo para poner el sitio en ambos idiomas, vamos, el vídeo de la primera parte que es en donde en el paso de habilitar el plugin "Sistema - Filtrar Idiomas" ya me da ese error en la web.

Te dejo las capturas del ítem de inicio.

Gracias por mirarlo.

No se cansará de esperarte, aquel que no se canse de mirarte.

www.komplices.es

ResponderCitar
Respondido : 15/12/2012 10:08 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Tony,

Ok veo que el ítem Inicio apunta a Community Builder, al listado de usuarios.

Lo que no veo es como cambiar de idiomas en la página ¿lo has deshabilitado?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/12/2012 11:06 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Tony
 Tony
Usuario experto

Sí deshabilité el módulo "cambiar idioma" que es en donde el usuario podría elegir en qué idioma quería tener la web, porque es un módulo vacío ya que el problema es que en cuanto habilite el plugin de "Sitemas - Filtrar idiomas" la web ya crea esos bucles y sin tener ese plugin activado, no podré hacer nada.

Es habilitar ése plug Filtrar idiomas y dar el erro del bucle, de todas formas habilito el módulo donde debería ir los dos idiomas para que elijan los usuarios, pero claro, salen vacíos pues no puedo activar el plugin.

La pescadilla que se muerde la cola, vamos...

No se cansará de esperarte, aquel que no se canse de mirarte.

www.komplices.es

ResponderCitar
Respondido : 15/12/2012 11:23 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Tony

Tienes un menú por idioma? ya que una de las pantallas que envías muestra este error:

Envía una captura en donde se pueda ver que tienes varios ítems princiaples por idioma, debería aparecerte la bandera del idioma.

Por otro lado la url que se genera al activar el pluging es extraña, puedes desactivar temporalmente las urls amigables y enviar el error de redireccionamiento de esta manera.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/12/2012 6:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Tony
 Tony
Usuario experto

Hola Jhon Marreros Guzmán,

no había empezado aún a crear los menús para cada idioma, seguía los pasos del vídeo tutorial parte 1 de webempresa www.webempresa.com/blog/item/924-m%C3%B3dulo-estatus-multilenguaje-1%C2%AA-parte-de-multi-idiomas-en-joomla-25.html y aún ni había llegado a ese paso, simplemente al de habilitar el plugin "Sistemas - Filtrar Idiomas" que es uno de los primeros para poder seguir.

Acaabo de hacer la prueba de desactivar las urls amigables y habilitar el plugin, sigue dando el error, pero de forma diferente:

Con URLs amigable desactivado:

Con URLs amigables activado:

No se cansará de esperarte, aquel que no se canse de mirarte.

www.komplices.es

ResponderCitar
Respondido : 15/12/2012 11:24 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Tony

Los menús son importantes, deberías realizar todos los pasos.

Es posible que debido a las diferentes versiones de Joomla el plugin puede funcionar antes o despues de ciertos pasos, pero de seguro debería funcionar si completas toda la configuración.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/12/2012 3:23 pm

Cursos Gratuitos WordPress

Tony
 Tony
Usuario experto

Pues no sé, miraré el dejar sin servicio la web alguna noche mientras hago todos los pasos al menos en 1 menú como prueba.

Gracias.

No se cansará de esperarte, aquel que no se canse de mirarte.

www.komplices.es

ResponderCitar
Respondido : 16/12/2012 4:15 pm
Tony
 Tony
Usuario experto

Buenas,

pues después de muchas vueltas, hallé el motivo que causaba dicho error, lo dejo expuesto aquí por si a alguien le puede servir de ayuda en un futuro.

El problema era que al ir a Extensiones>Gestor de Idiomas>Contenido que es donde nos muestra los idiomas que vamos a instalar en nuestra web, yo el idioma español lo renombré. Originalmente estaba puesto como viene en la captura que adjunto Español (Formal Internacional) (ES) y yo lo cambié a simplemente Español.

Entrando ya en el campo de las suposiciones, pues pasé de investigar más, supuse que ese nombre entraría en conflicto con algún elemento de la web que llevara ya ese mismo nombre, pero vamos, esto ya es de mi cosecha propia, no sé si si así o no, lo que sí sé, es que el error lo generó al cambiar el nombre que venía por defecto.

Pues nada, gracias por la ayuda, lamento la pérdida de tiempo por un error mío y espero que al menos esto le pueda servir a alguien en un futuro.

Saludos.

No se cansará de esperarte, aquel que no se canse de mirarte.

www.komplices.es

ResponderCitar
Respondido : 17/12/2012 8:58 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Tony,

Gracias por aportar la solución a este tema al resto de los usuarios del foro.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 17/12/2012 9:03 am

Por favor Iniciar Sesión o Registro