Avisos
Vaciar todo

Modificar URL  

 
Joaquín
 Joaquín
Usuario experto

Hola tengo un problema a la hora de utilizar dentro de mi sitio web el módulo news pro gk4 y es el siguiente.

Cuando añado los artículos para mostrarlos por pantalla y despues accedo a ellos pinchando en sus enlaces me salen de la siguiente manera:

http://ociogrup-cp6.webjoomla.es/ociogrupo/index.php/component/k2/item/173-cocina-con-susi-diaz

No quiero que salga así ya que aparte de dar pistas sobre mi sitio web de con que herramienta lo he realizado no es nada SEO.

Mi intención es que hubiera salido de esta forma:
http://ociogrup-cp6.webjoomla.es/ociogrupo/index.php/cocina-con-susi-diaz

Dentro del Módulo en cuestión no puedo solucionar este problema y la única solución que se me ha ocurrido es mediante un ".htaccess" y reescribiendo las rutas que no quiero que aparezcan y sustituyendola por otra.
Esta solución no me parece factible ya que mi sitio web va a crecer mucho y no es viable.

¿Habría otra solución?

Un saludo y gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/10/2014 11:26 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Joaquin,

No tienes las URLs amigables correctamente activadas, ya que muestran un index.php en el medio.
URLs amigables en Joomla! --> https://www.webempresa.com/blog/item/317-urls-amigables-en-joomla.html

Respecto a K2 --> http://getk2.org/blog/1159-k2-v264-release-introduces-new-cool-sef-url-options

Una opción sencilla es:
http://www.youtube.com/watch?v=7vxb7nuNoK0

Crear un menú oculto en Joomla! 2.5 --> https://www.webempresa.com/blog/crear-un-menu-oculto-en-joomla-25.html

Saludos

ResponderCitar
Respondido : 22/10/2014 12:00 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Joaquín
 Joaquín
Usuario experto

Muchas gracias Jordi, me ha funcionado todo a la perfección.

Un saludo

ResponderCitar
Respondido : 23/10/2014 1:55 pm