Avisos
Vaciar todo

Pantallla blanca al actualizar de 2.5.28 a 3.5.1  

Página 2 / 2
 
José Luis
 José Luis
Usuario activo

Hola a todos: ante todo dar las gracias por este foro, que resulta impresionante por su calidad.

Pues esto, que al actualizar de 2.5.28 a 3.5.1 obtengo la pantalla blanca de la muerte en el admin ( http://a21granada-cp57.webjoomla.es/red-gramas/administrator/) y en en front sólo funciona la página principal; todo lo demás da un error de SQL ( http://a21granada-cp57.webjoomla.es/red-gramas/la-red).

He seguido todos los pasos a rajatabla ( https://docs.joomla.org/Joomla_2.5_to_3.x_Step_by_Step_Migration/es) , y estoy perdido pues no sé que pasa.

Lo único que he notado, y que debe ser el origen del problema, es que el actualizador, cuando iba por el 83%, ha parado... y ahí es donde ha aparecido la indesable blanquedad de la página admin.

He consultado por todos lados y nada lo soluciona... no puedo acceder a nada del admin...

¿Alguna sugerencia? Adjunto capruras del proceso!
GRACIAS a todos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 10/05/2017 6:40 pm
José Luis
 José Luis
Usuario activo

a ver... parece que algo ha avanzado ahora puedo ver el admin, PERO sólo algunas partes. Desgraciadamente, la parte para reparar la base de datos o instalar otro update no es visible...
¿alguna idea?
GRACIAS

ResponderCitar
Respondido : 12/05/2017 10:56 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Podrías probar a realizar la actualización de forma diferente. Para ello tendrías que descargar.

Por una parte, tendrías que probar a actualizar a Joomla 3.7.0, que es la última versión disponible (no tiene sentido actualizar a Joomla 3.5, ya que luego tendrías que seguir actualizando).

En primer lugar, tendrías que descargar el archivo de actualización desde el siguiente enlace:

https://downloads.joomla.org/cms/joomla3/3-7-0/joomla_3-7-0-stable-update_package-zip?format=zip

Una vez que lo tengas, desactiva todos los plugins que hayas añadido a tu Joomla, ya que se pueden producir problemas de compatibilidad con la última versión de Joomla.

Después vete a Extensiones->Gestor de extensiones e instalar la actualización como si de una extensión se tratase.

Recuerda hacer una copia de seguridad antes de actualizar, o haz la prueba desde un clon.

ResponderCitar
Respondido : 12/05/2017 2:01 pm
José Luis
 José Luis
Usuario activo

Hola Pablo gracias por tu respesta.

En el manual (forum.joomla.org/viewtopic.php?f=710&t=793171) pone que Joomla 2.5.28 can only be migrated in 2-steps at the moment. First migrate to 3.5.1 . You then need to upgrade from 3.5.1 to the latest 3.x through the one click installer

¿Has tenido eso en cuenta?
Gracias

ResponderCitar
Respondido : 12/05/2017 2:16 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El enlace que te he pasado lo he sacado de esta página:

https://downloads.joomla.org/cms/joomla3/3-7-0

Aquí se indica lo siguiente:

This package is for performing updates from Joomla! 2.5 and previous 3.x releases to 3.7.0

Como ves pone que sirve para hacer actualizaciones desde Joomla! 2.5, por lo que es posible que te funcione.

En todo caso, recuerda hacer una copia de seguridad antes de la actualización.

ResponderCitar
Respondido : 12/05/2017 6:39 pm
José Luis
 José Luis
Usuario activo

Hola Pablo... el mensaje que me da es: "JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración."

Lo he intentado con la actualización de
J3.6.5
J3.6.4
J3.6.3
Con el mismo mensaje.

Todo esto con Chrome.

Luego he intentado con el archivo "Joomla_3.7.0-Stable-Update_Package.tar.gz" en Firefox y se ha quedado en blanco la pantalla, pero no ha roto el sitio.

Tengo la sospecha de que puede deberse a algo local.

ResponderCitar
Respondido : 15/05/2017 11:38 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola José Luis.

Este mensaje aparece cuando el instalador de Joomla no encuentra el fichero XML necesario para la instalación. Suele pasar cuando un fichero necesita descomprimirse antes de ser instalado.

Prueba a subir el paquete a la carpeta tmp y lo descomprimes en esa carpeta, una vez descomprimido intenta instalarlo con la opción Instalar desde una carpeta

¿ Estas actualizándolo en local ? comprueba si el servidor que tienes en local tiene instalada la versión 7 de PHP.

Un saludo

ResponderCitar
Respondido : 15/05/2017 1:10 pm
José Luis
 José Luis
Usuario activo

Hola Pepe, gracias por tu respuesta.
Parece que ha habido algún avance, pero aún no tengo noticias del motivo... os cuento en cuanto sepa!
GRACIAS

ResponderCitar
Respondido : 15/05/2017 1:16 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola José Luis.

ok, dejo el hilo en espera de tus indicaciones 😉

un saludo

ResponderCitar
Respondido : 15/05/2017 1:35 pm
José Luis
 José Luis
Usuario activo

qué va... otra vez roto... he ido activando los componentes y ha vuelto a romer... maldita página en blanco

ResponderCitar
Respondido : 15/05/2017 2:02 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jose Luis.

Ok, lo que tienes que revisar que componente es el que te provoco eso, esta claro que si al principio te funciono y al activar los componentes se rompió es por que uno de esos componentes no esta bien y te esta provocando es error.

la solución es que actives los componentes uno a uno y revisando la web hasta comprobar cual es.
Una vez identificado comprueba si ese componente tiene actualizaciones para joomal 3x y de no ser así habría que buscar alguna alternativa.

un saludo

ResponderCitar
Respondido : 15/05/2017 2:15 pm
José Luis
 José Luis
Usuario activo

bueno chicos, gracias a los técnicos de Webempresa parece que esto marcha! GRACIAS a webempresa de veras... muy profesionales, ayudan en cosas que no tienen por qué. GRACIAS

Había mogollón de cosas mal, pero en resumen... componentes que no son compatibles me tiraban todo. Aunque la descripción fuera que sí lo son, y aunque los desactivaba... me rompían la web.

Ahora funciona, aunque tengo que restaurar unas cuantas cosas, pero parece que va mejor.

ResponderCitar
Respondido : 15/05/2017 6:18 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Que bueno que pudiste solucionarlo.

Saludos.

ResponderCitar
Respondido : 15/05/2017 10:20 pm
Página 2 / 2