Problema al migrar de 1.7.2 a 2.5.X  

 
Joaquín C.
 Joaquín C.
Usuario experto

He intentado migrar de 1.7.2. a 2.5 utilizando Admintools. He descargado la versión estable disponible para Joomla 1.7, que es la Core 2.1.14. Lo que ocurre es que cuando entro en el componente me indica "No se pudo descargar información sobre versión actualizada de Joomla!. Por favor, visite http://www.joomla.org/download.html para asegurarse que tiene la última versión instalada en su sitio" De esta forma no puedo continuar con la migración. ¿Alguna propuesta?.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 09/03/2013 11:43 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Joaquín,

Este tema está bastante documentado en el Foro.

1. Para migrar a Joomla 2.5 tienes que estar en Joomla 1.7.5 algo que creo que ya se ha realizado y de forma correcta.

2. No puedes pasar de Joomal 1.7.5 a 3.0, en primer lugar porque tendrías que pasar si o si por Joomla 2.5 y segundo porque NO te recomiendo aún pasar a Joomla 3.0, ya que el cambio es importante y no hay toda la disponibilidad de extensiones que seria de desear, además la rama estable será la 3.5 y no la 3.0.

3. No podrás migrar con Admin Tools de Joomla 1.7.5 a Joomla 2.5 porque el equipo de desarrollo de Admin Tools ya no da soporte para Joomal 1.7 y no te funcionará, sencillamente, te cuenten lo que te cuenten, no funcionara. (Es bueno seguir nuestro Blog, solemos hablar de estas cosas).

4. Tendrás que migrar de Joomla 1.7.5 a 2.5.0 de forma manual y luego actualizar de Joomla 2.5.0 a 2.5.9 de forma automática, ya que de la 2.5.0 a la 2.5.2 se producen cambios importantes en las tablas de la base de datos y otros que hacen menos viable la migración directa a la versión 2.5.9.

Analiza todo esto que te comento y si quieres seguimos comentando.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/03/2013 12:09 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Joaquín C.
 Joaquín C.
Usuario experto

Hola

Me dices en el punto 1 que ya se ha realizado y de forma correcta la migración a 1.7.5. ¿Es así? En Ayuda de Joomla del backend, en la opción de comprobación de última versión me aparece que es la 1.7.2.

Necesitaría que me indicaras los pasos a seguir.

Gracias

ResponderCitar
Respondido : 10/03/2013 8:23 am
Hicham
 Hicham
Miembro Admin

Hola Joaquín,

Revisa el siguiente enlace donde se explica los pasos :

http://docs.joomla.org/Upgrading_from_Joomla_1.7_to_Joomla_2.5

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/03/2013 10:46 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Joaquín C.
 Joaquín C.
Usuario experto

Gracias por vuestras indicaciones. Realicé la actualización tal y como me indicasteis y de momento todo bien. Al fin estoy andando en 2.5.9. El problema me ha surgido al actualizar Akeeba Backup a la versión 3.7.2 (Estable). Me ha salido lo siguiente:

500 - Ha ocurrido error un.
La instalación de Akeeba Backup está roto, por favor, vuelva a instalarlo. Alternativamente, extraer el archivo de instalación y copiar el directorio dentro del directorio fof su sitio bibliotecas.

¿Alguna recomendación? Mil gracias.

ResponderCitar
Respondido : 11/03/2013 12:09 pm
Hicham
 Hicham
Miembro Admin

Hola Joaquín,

¿ Has vuelto a instalar Akeeba como indica el error ?

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/03/2013 12:21 pm

Cursos Gratuitos WordPress

Joaquín C.
 Joaquín C.
Usuario experto

Sí y me sale lo mismo. Descargué el pack desde la página y me sale lo mismo. Gracias.

ResponderCitar
Respondido : 11/03/2013 12:32 pm
Joaquín C.
 Joaquín C.
Usuario experto

Lo desintalé y opté por la versión 3.6.12-core que es menos nueva y que he visto en foros que habéis recomendado en ocasiones. La instalo, hago la configuración pos-instalación y cuando voy a utilizarlo:

Error del servidor
El sitio web ha detectado un error al recuperar la http://cuadernosruaj.es/administrator/index.php?option=com_akeeba http://cuadernosruaj.es/administrator/index.php?option=com_akeeba. Es posible que esta esté inactiva debido a tareas de mantenimiento o que se haya configurado de forma incorrecta.
A continuación se detallan algunas sugerencias:
Vuelve a cargar esta página más tarde.
Error de HTTP 500 (Internal Server Error): Se ha detectado una condición inesperada cuando el servidor intentaba atender la solicitud.

Gracias por vuestra ayuda

ResponderCitar
Respondido : 11/03/2013 3:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Hicham
 Hicham
Miembro Admin

Hola Joaquín,

Parece que el problema está en tu página, a nivel servidor no hay incidencias.

El error tiene que ser por los permisos de alguna carpeta o fichero, recuerda que en nuestro Hosting todos los ficheros tienen que estar a 644 o 755, no puede tener fichero con 666 o 777.

Otra opción es que hayas modificado algo, por lo que recomendamos revises el fichero que encontrarás en /public_html/error_log y veas las últimas entradas porque normalmente ahí podrás ver el error.

Este archivo lo encuentras al acceder a tu cPanel, Administrador de Archivos, en la carpeta raíz de tu Joomla! /public_html para errores que se muestren en el frontend (página) o en /administrator/error_log para errores que tengan que ver con la administración de tu Joomla!.

Revisa también las últimas extensiones instaladas, plugins, módulos o componentes y deshabilita uno a uno los últimos instalados y recarga la página hasta localizar y aislar aquel que pueda ser el causante del conflicto.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/03/2013 6:02 pm
Joaquín C.
 Joaquín C.
Usuario experto

Hola

Un montón de errores como éste en el error_log de la administración de joomla:

[11-Mar-2013 17:18:39] PHP Fatal error: Call to undefined method AkeebaToolbar::appendLink() in /home/cuaderno/public_html/administrator/components/com_akeeba/toolbar.php on line 265

ResponderCitar
Respondido : 11/03/2013 6:16 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Joaquin,

Si instalas una versión anterior te sucede lo mismo?: https://www.akeebabackup.com/download/akeeba-backup/3-7-1.html , puedes utilizar como alternativa XCloner:

Copias de Seguridad con XCloner-Backup en Joomla 1.5, 2.5 y 3.0
https://www.webempresa.com/blog/copias-de-seguridad-con-xcloner-backup-en-joomla-15-25-y-30.html

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/03/2013 4:54 am
Joaquín C.
 Joaquín C.
Usuario experto

Hola... Te ruego me disculpéis por no comentároslo. Finalmente instalé la versión que tenía antes, la 3.3.13 y parece ir todo bien. No obstante, hice un respaldo desde c-panel que fue correcto. ¿Es esta opción válida y aconsejable?. También estudiaré vuestra propuesta de xcloner. Gracias.

ResponderCitar
Respondido : 12/03/2013 9:26 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Hicham
 Hicham
Miembro Admin

Hola Joaquín,

Hacer respaldos desde cpanel es aconsejable.

Puede descargarse una copia de seguridad desde su cPanel, Respaldos, Respaldo Completo:

Una copia de seguridad completa incluye todos los archivos en su directorio de inicio, sus bases de datos MySQL, y sus reenviadores y filtros de e-mail. Puede copiar su cuenta para preservar sus datos, o para mover su cuenta a otro servidor cPanel.

"Descargar o Generar un Respaldo Completo"

Le llegará un correo avisándole cuando haya finalizado y accediendo de nuevo a su cpanel, Respaldos, "Descargar o Generar un Respaldo Completo", podrá descargar el archivo generado. En su interior encontrará en la carpeta /mysql la base de datos correspondiente y en el archivo "homedir.tar" (tras descomprimirlo fuera de la carpeta que lo contiene, de lo contrario le dará error) podrá encontrar la carpeta /public_html con los archivos de su instalación.

Cualquier duda, consúltenos.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/03/2013 12:59 pm

Por favor Iniciar Sesión o Registro