Problemas con Syndicación RSS y K2  

 
Vettusta
 Vettusta
Estimable Member

Buenos días.

He experimentado hace unos días, que la syndicación RSS de mi sitio no funcionaba, ya que al subscribirme en algún sitio y hacer clic sobre el icono RSS, me cargaba de nuevo la página y no el archivo XML como antes.

Entré en la configuración global del sitio y puse la opción "Agregar el sufijo a la URL" en NO, y ya volvía a funcionar correctamente, ¡pero! cuando lo dejo de esta forma, luego en los artículos de K2 me aparece el error 500

Entonces aquí me encuentro, que no se que tengo que modificar, para que vuelva a funcionar todo correctamente.

URL del sitio: Contenido solo visible a usuarios registrados

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

Citar
Respondido : 26/11/2012 11:24 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Vettusta,

¿Nos puedes indicar los pasos exactos para reproducir el problema?, he navegado por el sitio web y no visualizó ninguna sindicación RSS.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 26/11/2012 11:32 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Vettusta
 Vettusta
Estimable Member

Hola Vettusta,

¿Nos puedes indicar los pasos exactos para reproducir el problema?, he navegado por el sitio web y no visualizó ninguna sindicación RSS.

Saludos

Si accedes a este enlace y abres un artículo te llevará a un error:

http://www.vettusta.es/es/blog

Ahora mismo tengo la configuración SEO de la siguiente manera:

Y si activo en SI la opción: "Agregar el sufijo a la URL" entonces me deja de funcionar el RSS.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 26/11/2012 11:46 am
David Noguera
 David Noguera
Miembro Admin

Hola Vettusta, comprueba que el fichero .htaccess de la raíz de tu web es el original de la versión de Joomla que estés usando...

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/11/2012 5:03 pm

Cursos Gratuitos WordPress

Vettusta
 Vettusta
Estimable Member

Hola Vettusta, comprueba que el fichero .htaccess de la raíz de tu web es el original de la versión de Joomla que estés usando...

Saludos!

El fichero lo vengo arrastrando desde Joomla 1.5. ¿es que tendría que ser otro distinto??
Como puedo comprobar eso??
Gracias de antemano.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 26/11/2012 5:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si hay ligeras diferencias entre el htaccess de Joomla 1.5 y Joomla 2.5, te sugiero descargar el archivo htaccess.txt desde una instalación de la misma versión de Joomla y reemplazarlo
http://www.vettusta.es/administrator

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/11/2012 9:29 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Vettusta
 Vettusta
Estimable Member

Hola

Si hay ligeras diferencias entre el htaccess de Joomla 1.5 y Joomla 2.5, te sugiero descargar el archivo htaccess.txt desde una instalación de la misma versión de Joomla y reemplazarlo
http://www.vettusta.es/administrator

Saludos

Buenos días Jhon.
Entiendo lo que me dices, he visto mi "htaccess.txt" y mi ".htaccess" y veo que hay diferencia entre los dos, pero mi duda es que yo tengo mi ".htaccess" personalizado, y entonces no se si se perdería todo eso.
Os mando mis dos archivos por si sois tan amables de echarles un vistazo.
Gracias de antemano.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 27/11/2012 9:07 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Vettusta,

El .htaccess lo tienes personalizado, está claro que sustituirlo no puede ser.

Puedes comparar el código del mismo, con programas tipo Beyond Compare:

Lo que si puedes es hacer una prueba de renombrarlo, y utilizar el otro, y ver si te funciona la sindicación correctamente. Con esa prueba se podrá saber si es un tema de .htaccess u otro motivo por el cual no funciona correctamente.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 27/11/2012 9:17 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Vettusta
 Vettusta
Estimable Member

He probado a renombrar el archivo htaccess.txt de joomla 2.5 con su código original a .htaccess y sigo teniendo el mismo problema, así que supongo que tendrá que ser de algún otro lado.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 27/11/2012 10:00 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Vettusta,

He accedido al blog Contenido solo visible a usuarios registrados si se muestra el artículo completo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 27/11/2012 10:07 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Vettusta
 Vettusta
Estimable Member

Efectivamente Jordi.

Tengo hecho una redirección para usuarios no registrados.

Los archivos modificados que tengo son:

/public_html/templates/yoo_sync/html/com_users/login/default_login.php

El código insertado en default_login.php es el que se ve a continuación:

<?php
/**
* @package   yoo_sync
* @author    YOOtheme  http://www.yootheme.com 
* @copyright Copyright (C) YOOtheme GmbH
* @license    http://www.gnu.org/licenses/gpl.html  GNU/GPL
*/

echo '
Tienes que ingresar primero, para leer el articulo completo.
'; // include config and layout $base = dirname(dirname(dirname(__FILE__))); include($base.'/config.php'); include($warp['path']->path('layouts:'.preg_replace('/'.preg_quote($base, '/').'/', '', __FILE__, 1)));

Por otra parte el siguiente archivo modificado para restringir las categorías es:

/public_html/templates/yoo_sync/html/com_k2/default/item.php

El código insertado en item.php es el siguiente:

?>
get('guest') && ($this->item->category->id==18 || $this->item->category->id==14 || $this->item->category->id==13 || $this->item->category->id==12 || $this->item->category->id==11 || $this->item->category->id==10 || $this->item->category->id==9)) {
  header('Location: index.php?option=com_users&view=login');
}

?>

Estos son los únicos cambios que tengo realizado.

Joomla! Versión: ...... 3.0.3 Stable
PHP Version: ............ 5.3.8
K2 Versión: ............... 2.6.5

ResponderCitar
Respondido : 27/11/2012 10:59 am
David Noguera
 David Noguera
Miembro Admin

Hola Vettusta, el último cambio podría estar dando problemas, ya que no pueden enviarse cabeceras con la función header si la salida por pantalla ya ha empezado.

Prueba a quitar esas modificaciones y dejar esos ficheros tal y como estaban originalmente a ver si te funciona bien..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/11/2012 11:38 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro