Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

Se ha producido un error cargando el componente: com_joomlaupdate, 1  

Página 2 / 3
 
fjobeltran
 fjobeltran
Usuario experto

Se produce este error al entrar en el módulo de actualización de Joomla, para colocar actualizaciones a corto plazo.
He encontrado esto en la web: http://www.lapizcorto.com/solucionar-errores-com_installer-com_joomlaupdate-tras-actualizar-joomla-a-2-5-4/
con el siguiente texto:
Al parecer “algo” ha borrado los registros com_installer & com_joomlaupdate de la tabla #__extensions. Tras obtener los registros de un Joomla 2.5.4 recién instalado y restaurarlos en la base de datos que daba error desaparecen los mensajes de error.
Es así y se pueden haber borrado los registros?
Cómo puedo restaurarlos?, porque ya no tengo copias de seguridad tan antiguas.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/05/2015 6:55 pm
fjobeltran
 fjobeltran
Usuario experto

Seguí ese tutorial paso a paso; lo conozco, hasta llegar al punto 10 "Ve a Componentes, Actualización de Joomla y en Opciones, Servidor de actualizaciones, selecciona STS.", que no puedo realizar precisamente, porque tengo el error de origen en el componente : com_joomlaupdate, 1, pero todo lo demás se realizó con precisión.
Solucioné el tema con lo que leí en este foro: http://forum.joomla.org/viewtopic.php?t=770567 --> http://forum.joomla.org/viewtopic.php?t=770567#p3007061, pero sigo teniendo errores de PHP.
De hecho he restaurado desde CPremote, tanto files como database a fecha 01/05 y también tengo error de PHP para entrar como administrator, pero eso no me preocupa, porque puedo borrar las tablas desde PHPMyAdmin y volver a restaurar, o pedir mediante un ticket una copia anterior.
Creo que todo el problema viene de arreglar el tema de este componente: com_joomlaupdate, 1, porque también he comprobado la compatibilidad tanto de la plantilla como del resto de los componentes y o están actualizados, o directamente desinstalados, como el caso de xmap.
Es el sexto intento.

ResponderCitar
Respondido : 26/05/2015 8:00 pm

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

En la actualización entiendo que haz realizado el intento mediante el componente Update. Haz realizado la prueba a instalar el paquete directamente? Es decir retornar a Joomla 2.5 y luego actualizar descargando el paquete Joomla_3.4.1-Stable-Update_Package.zip del siguiente enlace: https://github.com/joomla/joomla-cms/releases/tag/3.4.1 ,tendrías que instalarlo desde el gestor de extensiones de Joomla como si fuera un componente.

ResponderCitar
Respondido : 27/05/2015 1:51 am
fjobeltran
 fjobeltran
Usuario experto

Si, también he intentado instalarlo directamente desde el gestor de extensiones a Joomla 3.3.6 y tampoco he podido.
Este error de com_joomlaupdate, 1, me aparece también en este otro subdominio que os muestro de asam.org.es, pero no en el dominio principal, donde lo que me aparece son las extensiones que tengo que actualizar o desinstalar que también os envío y eso me tiene perdido.
De momento voy a intentar recuperar la web a la que no puedo acceder, eliminando las tablas de PHP y recuperándolas de nuevo desde CPanel y voy a intentar esta solución:
http://www.lapizcorto.com/solucionar-errores-com_installer-com_joomlaupdate-tras-actualizar-joomla-a-2-5-4/
Aunque entiendo que eso implica entrar en PHP y me da un poco de respeto

ResponderCitar
Respondido : 27/05/2015 1:18 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

fjobeltran
 fjobeltran
Usuario experto

Bien; pues tampoco puedo recuperar desde CPremote, ni siquiera borrando las tablas previamente.
Voy a escribir un nuevo ticket, pero esto me parece mas que preocupante.

ResponderCitar
Respondido : 27/05/2015 2:57 pm
Lorena
 Lorena
Miembro Moderator

Hola,

Veo que es un problema común, documentado en los foros de Joomla:

http://forum.joomla.org/viewtopic.php?f=710&t=811267

http://forum.joomla.org/viewtopic.php?f=708&t=820254

Renombra la carpeta de tu web /libraries/cms/controller a otra cosa, como /libraries/cms/controller_OFF y comprueba si se soluciona.

Un saludo.

ResponderCitar
Respondido : 27/05/2015 6:04 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

fjobeltran
 fjobeltran
Usuario experto

Pues muchas gracias porque efectivamente, este problema se ha solucionado.
Ahora quedan otros, pero por lo menos puedo operar con joomla 3.
Voy a subir Joomla 3.3.6 mediante el gestor de extensiones e informo.

ResponderCitar
Respondido : 27/05/2015 6:23 pm
fjobeltran
 fjobeltran
Usuario experto

He conseguido subir a Joomla 3.3.6 automáticamente y sin necesidad de realizar una instalación mediante el Gestor de Extensiones, aunque ante la duda respecto a si se había instalado correctamente lo he intentado, pero no he podido porque el servidor me da error 504 Gateway Time-Out.
Es lo primero que probé, porque tengo muchos errores PHP.
El primero es para loguearme como administrador, peor lo soluciono fácilmente eliminando /index.php en la url.
Otro problema que tengo, está en el gestor de plantillas.
No tengo información sobre que plantilla es la predeterminada y cuando intento editar cualquiera de ellas, me da este otro error PHP, en cualquiera de ellas.
Tampoco puedo eliminar la que quiero eliminar para actualizarla, ni desde el gestor de plantillas, ni desde el gestor de extensiones, pero entiendo que eso es porque está como predeterminada.
Tampoco puedo editar las plantillas ni modificarlas, porque no funciona.

ResponderCitar
Respondido : 02/06/2015 12:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por los errores que se muestran da la sensación de que no estás actualizando tu Joomla de forma correcta o esta actualización ha fallado, ya que se producen errores en archivos del núcleo de Joomla.

La forma de actualizar Joomla tiene que ser desde la opción de actualizaciones automáticas o desde el gestor de extensiones, no se pueden subir los archivos de forma directa, ya que las actualizaciones pueden incluir cambios en la base de datos que no se aplicarían si solo se suben los archivos.

Previa copia de seguridad, podrías probar a actualizar a la última versión de Joomla disponible (3.4.1) que puedes descargar desde el siguiente enlace:

https://github.com/joomla/joomla-cms/releases/download/3.4.1/Joomla_3.4.1-Stable-Update_Package.zip

Una vez que la tengas, la puedes instalar desde el gestor de extensiones como si de una extensión de Joomla se tratase.

ResponderCitar
Respondido : 02/06/2015 4:34 pm
fjobeltran
 fjobeltran
Usuario experto

OK Pablo, pues muchas gracias y esa misma sensación tenía yo respecto al núcleo de Joomla y por eso intenté volver a instalar la versión 3.6.6,.
Tengo copia de seguridad, pero tendríamos que ver si el servidor deja de darme errores 504

ResponderCitar
Respondido : 02/06/2015 5:19 pm

Cursos Gratuitos WordPress

fjobeltran
 fjobeltran
Usuario experto

Pues este es el resultado del intento de actualización a Joomla 3.4.1.

ResponderCitar
Respondido : 02/06/2015 5:28 pm
fjobeltran
 fjobeltran
Usuario experto

Se ha instalado la versión 3.4.1, a pesar del error anterior que os he enviado, pero no ha corregido ningún problema.
Os envío impresiones de pantalla.
He limpiado la caché, lógicamente.

ResponderCitar
Respondido : 02/06/2015 5:39 pm

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Dudo que se haya completado la instalación correctamente ya que al enviarte el error de Cant' Drop ..., siemplemente la actualización se ha cortado en un determinado punto

Recupera nuevamente, tendrías que reparar la BD desde Gestor de Extensioens => Extensiones => BD , y verificar si se corrigen algunos campos, tendrías que asegurarte que el campo que indica el error exista en la tabla users , el campo usertype , luego de esto puedes probar actualizar

Saludos.

ResponderCitar
Respondido : 02/06/2015 7:51 pm
fjobeltran
 fjobeltran
Usuario experto

He comprobado los errores en la BD y me aparecen los errores que os envío.
He intentado repararlos y el resultado es el que os envío en el segundo png.

ResponderCitar
Respondido : 03/06/2015 12:03 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que el error en la administración esté en la plantilla de administración de Joomla que tengas activa por defecto, ya que, por las capturas de pantalla que envías, da la sensación de que no es correcta.

Vete a Extensiones->Gestor de Plantillas y marca la casilla que se encuentra a la izquierda de isis - Default. A continuación pulsa en el botón Establecer por defecto. Comprueba si así se carga correctamente la administración.

ResponderCitar
Respondido : 03/06/2015 4:11 pm
fjobeltran
 fjobeltran
Usuario experto

Con esta plantilla de administrador, la verdad es que se ve todo mas claro, pero sigo teniendo errores PHP.
He desinstalado la plantilla anterior y he instalado la nueva actualizada y no funciona en el front.
Me he puesto a repasar los parámetros, empezando por los menús y me aparece el error que envío y que creo que ya es recurrente, por lo que recuerdo de la línea donde aparece el error.
Y los errores que aparecen en Gestor de extensiones Bases de datos, siguen igual.

ResponderCitar
Respondido : 03/06/2015 6:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Página 2 / 3