Se ha producido un error cargando el componente: com_joomlaupdate, 1  

Página 1 / 3
 
fjobeltran
 fjobeltran
Usuario experto

Se produce este error al entrar en el módulo de actualización de Joomla, para colocar actualizaciones a corto plazo.
He encontrado esto en la web: http://www.lapizcorto.com/solucionar-errores-com_installer-com_joomlaupdate-tras-actualizar-joomla-a-2-5-4/
con el siguiente texto:
Al parecer “algo” ha borrado los registros com_installer & com_joomlaupdate de la tabla #__extensions. Tras obtener los registros de un Joomla 2.5.4 recién instalado y restaurarlos en la base de datos que daba error desaparecen los mensajes de error.
Es así y se pueden haber borrado los registros?
Cómo puedo restaurarlos?, porque ya no tengo copias de seguridad tan antiguas.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/05/2015 6:55 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

La pregunta sería por que quieres actualizaciones a corto plazo?

Actualmente actualizar de Joomla 2.5 a Joomla 3 ya es un paquete de actualización oficial y no es necesario usar la de STS o corto plazo.

Tendrias que indicarnos que verisión de joomla tienes y a que versión quieres pasar

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/05/2015 8:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

fjobeltran
 fjobeltran
Usuario experto

La versión que tengo es la 2.5.28 y quisiera pasar a la versión 3.3.6.
Tengo 3 webs alojadas con vosotros y 2 de ellas me dan el mismo error; las dos corresponden a subdominios.
He intentado realizar actualizaciones directas y he tenido errores de PHP que he achacado a componentes que no estaban actualizados, pero voy a volver a intentarlo.
Lo que desconozco es si este problema, puede afectarme en la actualización.

ResponderCitar
Respondido : 20/05/2015 12:57 pm
fjobeltran
 fjobeltran
Usuario experto

He realizado una instalación directa desde el gestor de extensiones a Jommla 3.3.6 y aunque me ha dado un error que no he grabado, parece que se ha instalado la versión, pero ahora me da errores como el que os envío.

ResponderCitar
Respondido : 20/05/2015 1:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tal vez sea por la versión de PHP, prueba instalarte en una carpeta un pack con Joomla 3 y verificia si te sale algún error, esto es para comprobar que la cuenta que tienes cumple con los requisitios para Joomla 3

Luego el error que te sale es posible que no se haya realizado correctamente la actualización, tendrías que intententarlo nuevamente, recupera una copia de tu sitio con cpremote y luego raliza nuevamente el proceso, si te sale algún error realiza alguna captura de pantalla para verlo

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2015 6:10 pm
fjobeltran
 fjobeltran
Usuario experto

He realizado una copia con Akeeba, antes de hacer el intento de subir a Joomla 3.0.6 y siguiendo este tutorial, la he restaurando: https://www.webempresa.com/blog/realiza-copias-de-seguridad-y-restauraciones-en-joomla-3-con-akeeba-backup.html pero el resto de los dominios, me dan este error: Database connection error (2): Could not connect to MySQL.
En realidad solo debería haber restaurando el dominio pintadadeextremadura.es, que si se restauró correctamente, pero algo ha afectado al resto, incluida la home.
Ante eso he restaurado el home a 17/05 con CP remote y ahora los 3 dominios, me dan el mismo error.
También he revisado el foro: https://www.webempresa.com/foro/18-Pack-Empresa/94030-error-Database-connection-error-(2)-Could-not-connect-to-MySQL.html, pero no encuentro la solución.
Creo que hay algo mal en PHP, no sé si corresponde enviar un ticket, porque la copia desde CPremote, debería haber funcionado.

ResponderCitar
Respondido : 20/05/2015 6:38 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Julen
 Julen
Miembro Admin

Hola,

Puedes enviar un ticket a soporte desde tu área de cliente, para que revisen los problemas que estas teniendo, al parecer puede tratarse de un problema con la versión de PHP y con la configuración de la base de datos.

Puedes acceder al área de clientes mediante: www.webempresa.com/areacliente.php

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/05/2015 6:45 pm
fjobeltran
 fjobeltran
Usuario experto

Mandé un ticket a soporte y se ha verificado la versión de P:H:P. 5.3.29
En este foro, http://forum.joomla.org/viewtopic.php?t=770567 he leído la primera solución al problema, que además me indica cuando hay alguna aplicación que no está para Joomla 3 y están todas actualizadas o desinstaladas, como xmap, pero me sigue dando errores con la versión de caché cleaner, aunque está actualizada y he subido el pack Joomla 3.3.6
Sigo con el mismo problema recurrente, que entiendo que está vinculado a este error y es que subo a 3.3.6, me aparece el panel de control, pero tengo errores de PHP en extensiones, en sistema...pero no en componentes.
He seguido también este manual vuestro, https://www.webempresa.com/blog/item/1752-pasos-para-actualizar-a-joomla-3-4.html, hasta el punto 10, en el que no puedo colocar actualizaciones STS, porque me da error en el componente com_joomlaupdate, 1
Esto me pasa con los dos subdominios, pero no con el dominio principal.

ResponderCitar
Respondido : 25/05/2015 6:55 pm

Cursos Gratuitos WordPress

fjobeltran
 fjobeltran
Usuario experto

Supongo que estáis trabajando sobre el tema y me preocupa que al parecer, solo me haya pasado a mi, con dos plantillas de diferentes empresas, por lo que ese tema parece descartable. (sin anticipar nada)
Puede que el problema como indica Jhon Marreros, es que alguna actualización de Joomla 2.5, se ha realizado mal, aunque he sido muy respetuoso con eso y lo procedente sea volver atrás y volver a instalarla.
Lo paradogico, es que que los componentes como JCE, Abeeba o Brezzing Forms o K2, funcionan correctamente, así como la plantilla (aparentemente), lo que no funciona es Joomla 3.0.4 y parece que es un problema de enlace con la base de datos SQL.
Estos componentes por lo menos abren su administrador, pero todo lo que corresponde al sistema Joomla, no.
Supongo en cualquier caso que esto que envío, es puntual.

ResponderCitar
Respondido : 25/05/2015 10:22 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Vete a la ruta: /administrator/components/com_login y renombra el directorio a com_login_old, verifica si el problema persiste.

De no funcionar prueba a descargar el paquete de la ultima versión de Joomla, descomprime el paquete y sube los ficheros en directorio com_login para reemplazarlos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/05/2015 6:59 am

wpdoctor-revisa-la-salud-de-tu-wordpress

fjobeltran
 fjobeltran
Usuario experto

He renombrado /administrator/components/com_login, por com_login_old y me da error 404 que os envío.
No ha funcionado y he subido el componente com_login desde Joomla 3.3.6 y tengo el error de PHP que os envío en el segundo archivo.
Tal vez se me ocurre, hacer esto mismo con el componente joomla_update desde 2.5.28, recuperando una copia de seguridad y volver a empezar de nuevo.

ResponderCitar
Respondido : 26/05/2015 12:02 pm
fjobeltran
 fjobeltran
Usuario experto

Acabo de revisar mi cuenta con Stephan y localizo estos errores después de revisar datos del foro sobre este error de com_login:

Revisión LVE limits reached:

Vemos que se han superado los límites de recursos de servidor asignados a su cuenta

[Fri May 22 03:16:55 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417135) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:55 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417140) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:55 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417135) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:55 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417140) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:55 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417135) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:55 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417140) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:56 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417140) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:56 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417135) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:56 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417135) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG
[Fri May 22 03:16:56 2015] [error] mod_hostinglimits:Error on LVE enter: LVE(914) HANDLER(application/x-httpd-php5) HOSTNAME(www.fundacionasamfamilia.org) URL(/index.php) TID(417143) errno (7) Read more: http://e.cloudlinux.com/MHL-E2BIG

ResponderCitar
Respondido : 26/05/2015 12:15 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Julen
 Julen
Miembro Admin

Hola,

Los errores que nos has mandado son de días anteriores, por lo que entendemos que ya se han solucionado, por lo tanto puedes ignorarlos.

Me comunica un técnico que ven que hay logs de errores que podrian generar un error 500 en el servidor

[25-May-2015 17:58:41 Europe/Berlin] PHP Fatal error: Call to a member function get() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_content/controller.php on line 39
[25-May-2015 17:58:46 Europe/Berlin] PHP Fatal error: Call to a member function get() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_media/controller.php on line 33
[25-May-2015 17:59:07 Europe/Berlin] PHP Fatal error: Call to a member function get() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_weblinks/controller.php on line 35
[25-May-2015 18:00:21 Europe/Berlin] PHP Fatal error: Call to a member function get() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_installer/controller.php on line 39
[25-May-2015 21:02:12 Europe/Berlin] PHP Fatal error: Call to a member function set() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_login/controller.php on line 38
[26-May-2015 05:51:16 Europe/Berlin] PHP Fatal error: Call to a member function set() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_login/controller.php on line 38
[26-May-2015 10:50:11 Europe/Berlin] PHP Fatal error: Call to a member function set() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/administrator/components/com_login/controller.php on line 38
[25-May-2015 20:34:07 Europe/Berlin] PHP Fatal error: Call to a member function getCmd() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/components/com_users/controller.php on line 36
[25-May-2015 21:57:28 Europe/Berlin] PHP Fatal error: Call to a member function getCmd() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/components/com_users/controller.php on line 36
[26-May-2015 00:36:14 Europe/Berlin] PHP Fatal error: Call to a member function getCmd() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/components/com_users/controller.php on line 36
[26-May-2015 12:18:26 Europe/Berlin] PHP Fatal error: Call to a member function getCmd() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/components/com_users/controller.php on line 36
[26-May-2015 12:19:42 Europe/Berlin] PHP Fatal error: Call to a member function getCmd() on a non-object in /home/fundaci8/public_html/pintadadeextremadura.es/components/com_users/controller.php on line 36

Antes de proceder a la actualización, soluciona dichos errores.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/05/2015 2:05 pm
fjobeltran
 fjobeltran
Usuario experto

Claro, yo también he visto estos errores con Stephan y emití un ticket en el que me han confirmado que la versión de PHP es correcta.
Son errores con la actualización ya realizada y son errores con Joomla 3; en Joomla 2.5, tenía únicamente el error en el componente de joomla_update, 1.
Por eso creo que tal vez lo procedente es volver atrás, a Joomla 2.5, corregir este error y volver a intentar actualizar, pero estos errores que me envías y que yo también he visto, son en Joomla 3

ResponderCitar
Respondido : 26/05/2015 2:31 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafael
 Rafael
Miembro Moderator

¡Hola!

En el caso que nos presentas, te recomendaría aplicar una restauración al sitio afectado para volver a 2.5 y resolver los conflictos antes de actualizar.

Para ello, https://www.webempresa.com/blog/item/1718-restaura-tu-hosting-completo-con-cpremote-backup-management-en-cpanel.html

Sobre todo, haz hincapié en el tema de los componentes que no se queden obsoletos, que estén desactivados antes de proceder a actualizar, que la plantilla sea compatible etc.

Te recomiendo que leas detenidamente:

https://www.webempresa.com/blog/item/1752-pasos-para-actualizar-a-joomla-3-4.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/05/2015 5:27 pm
Página 1 / 3

Por favor Iniciar Sesión o Registro