Avisos
Vaciar todo

url's cortas  

 
Jonatan
 Jonatan
Usuario experto

Saludos a todos en este nuevo año.

Quisiera hacer una consulta sobre acortar las url's.

Estoy usando k2mart y cuando entro a un producto o a una categoría la url que genera es tal como http://www.motosjuancortes.com/component/k2/item/35-razer-ii-r.html.

Es una url muy larga y fea porque no decirlo. ¿Podria ser http://www.motosjuancortes.com/razer-ii-r.html?

Las url's amigables están activas al igual que la reescritura url y agragar sufijo a la url.

En el resto de menús la url se muestra así http://www.motosjuancortes.com/contacto-2.html

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 09/01/2013 11:26 am
David Noguera
 David Noguera
Miembro Admin

Hola Jonatan, revisa esta extensión, parece que hace justo lo que necesitas:

http://www.sakic.net/products/sef_advance/

http://www.sakic.net/forum/sef-advance/sef-advance-extension-for-k2/

También JoomSef debería de servirte:

http://www.artio.net/joomla-extensions/joomsef

Veo que tiene soporte para K2:

http://www.artio.net/joomsef/extensions

ResponderCitar
Respondido : 09/01/2013 1:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jonatan
 Jonatan
Usuario experto

Gracias David.

He instalado joomsef en su versión gratis pero no consigo que funcione con el sitio multilenguaje.

He probado las opciones que hay en la pestaña Language de la configuración de joomsef y también he probado habilitando y deshabilitando las opciones de url's amigables de joomla.

Si alguien sabe esactamente como se configura esto muchas gracias.

También estoy tratando de informarme sobre el otro que me has dicho el SEF Advance pero ese es de pago y en ese caso quiero estar seguro de que funcionara correctamente y no me pase como con joomsef.

ResponderCitar
Respondido : 09/01/2013 5:41 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jonatan

Es posible que tengas activo el plugin de multiidioma de Joomla, debes desactivarlo para que estas extensiones de urls amigables trabajen correctamente.

Desde el gestor de plugins desactiva :

System - Language Filter Plugin

Saludos.

ResponderCitar
Respondido : 09/01/2013 8:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jonatan
 Jonatan
Usuario experto

Lo desactivé jhon porque el propio joomsef ya me avisaba de que tenía que hacerlo.

ResponderCitar
Respondido : 10/01/2013 9:58 am
David Noguera
 David Noguera
Miembro Admin

Hola Jonatan, pon toda la información de acerca de la configuración que tienes en tu JoomSef.

Has instalado el plugin de K2 para JoomSEF?

Pon capturas de pantalla de toda la configuración que tienes en tu JoomSEF.

Después te recomiendo que este mismo post, con las mismas capturas de pantalla, lo pongas en el foro de JomSEF, para ver si de allí obtienes una respuesta.

Quizás haciendo una consulta preventa a la gente de JomSEF indicándoles el post del foro que has puesto sepan darte una respuesta también...

Saludos!

ResponderCitar
Respondido : 10/01/2013 11:46 am

Cursos Gratuitos WordPress

Jonatan
 Jonatan
Usuario experto

No he instalado el plugin de k2, solo el joomsef en su version gratuita para probarlo primero y nada mas empezar me he encontrado con esto.

Me explico mejor, cuando he dicho que no funciona en el sitio multilenguaje quiero decir que me da un error 404 en toda la página.

Esta es la url que me genera http://www.motosjuancortes.com/es.html

En cuanto a la configuración de joomsef no he tocado a nada salvo habilitar el Language management y especificar el Main language como español (también lo he probado con english y es igual).

Te adjunto capturas de la pestaña de joomsef del language (que como te digo es el único sitio que he tocado), del filtro de idioma desactivado, de los menús y de las plantillas asignados a cada idioma.

Por si alguien me lo va a sugerir ya digo de antemano que la configuración multilenguaje de joomla estaba correctamente configurada y funcionando. Ahora puede que haya que tocar algo para que funcione joomsef eso no lo se.

También he hecho la consulta en joomsef como sugieres.

Gracias.

ResponderCitar
Respondido : 10/01/2013 5:01 pm
Hicham
 Hicham
Miembro Admin

Hola Jonatan

Veo en la configuración del dominio, la ruta del dominio en inglés es igual a la ruta del españole.
prueba por ejemplo de poner :
http://motosjuancortes.com/?lang=es en la versión de inglés y http://motosjuancortes.com/?lang=en en la versión en españole.

Saludos

ResponderCitar
Respondido : 10/01/2013 5:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jonatan
 Jonatan
Usuario experto

He probado esto que me dices Hicham pero sigue igual.

ResponderCitar
Respondido : 10/01/2013 5:34 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jonatan,

El Joomsef tiene una opción para purgar las url, realiza esta operación y verifica si se resuelve.

Saludos.

ResponderCitar
Respondido : 11/01/2013 3:04 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jonatan
 Jonatan
Usuario experto

Las url's están purgadas.

Si desactivo el Language management the joomsef entonces la página se muestra pero muestra todos los modulos, menus, etc.

ResponderCitar
Respondido : 11/01/2013 10:24 am
Jonatan
 Jonatan
Usuario experto

Finalmente la solución ha sido desactivar la opción de joomla "Agregar sufijo a las URL".

Habia estado haciendo pruebas con esas opciones pero no se, supongo que la pasé por alto o alguna otra cosa no hice bien. No obstante la configuración correcta (al menos en mi caso) es:

En Joomla!
- Extensiones- Gestor de plugings. Deshabilitar el filtro de idioma.
- Configuración Global- Sitio- Configuración SEO. Motor de búsqueda para URLs amigables "Si". Usar la reescritura URL "Si". Agrega sufijo a la URL "No"

En joomsef
- Configuration- Basic. JoomSEF Enabled? "Si"
- Configuration- Language. Habilitar "Language management" y configurar "Main language" al idioma principal de la página.

ResponderCitar
Respondido : 11/01/2013 5:49 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación