Avisos
Vaciar todo

Usar la reescritura URLs  

 
Ignacio
 Ignacio
Usuario experto

Hola

Si tengo activado "Usar la reescritura URLs" al ir a un artículo creado con Joomla! da error 404.
En cambio sí funciona si vas a un artículo creado con K2.
He visto otros posts del foro y ya he subido el fichero .htaccess que proporcionáis vosotros, pero sigue dando error.

¿Alguna pista?

Os envío una captura de la configuración global.

Muchas gracias

Un saludo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 01/11/2012 10:53 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ignacio,

Tu archivo .htaccess me comenta un técnico que no es correcto del todo, que la redirección que tienes al final, debe estar al principio del archivo.

Facilitanos algún enlace de los que no te funcionan con urls amigables activadas.

Saludos

ResponderCitar
Respondido : 01/11/2012 3:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ignacio
 Ignacio
Usuario experto

Hola Luis

He vuelto a copiar el .htaccess que recomendáis vosotros. El que había ha debido ser actualizado por el componente MijoSEF. El error sigue produciéndose.

Solo hay un artículo de joomla! cuyo link "amigable" es: http://www.nwtrips.com/quienes-somos y como verás da error.

El link dinámico sería: index.php?option=com_content&view=article&id=56. Este también da error.

El htaccess. es:
##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a tag in URL
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /

########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Gracias

Un saludo

ResponderCitar
Respondido : 01/11/2012 4:16 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ignacio,

¿Puedes facilitar una captura de la configuración del ítem de menú "Quienes Somos"?

Mira la captura:

Saludos

ResponderCitar
Respondido : 01/11/2012 9:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ignacio
 Ignacio
Usuario experto

Hola Luis

Perdona pero la captura que me has enviado es las del artículo del k2, que funciona bien.

He cambiado el item de menú para que vaya a un artículo de Jommla! que es cuando da error.

Te envío captura del item de menú

Gracias

Un saludo

ResponderCitar
Respondido : 01/11/2012 9:19 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Ignacio,

Puedes crear una categoría para ese articulo y asignarla para verificar si se genera la url correctamente.

Saludos.

ResponderCitar
Respondido : 01/11/2012 11:21 pm

Cursos Gratuitos WordPress

Ignacio
 Ignacio
Usuario experto

Hola Johnny

Ahora funciona bien. Lo tenía asignado a una categoría que no estaba publicada. ¡Hay que ver!

Muchas gracias

Un saludo

ResponderCitar
Respondido : 01/11/2012 11:41 pm