Avisos
Vaciar todo

2 errores de php  

 
Mediterrania
 Mediterrania
Reputable Member

Buenas,

Tras pasar el "asistente stephan" me indica que tengo dos errores 500. Uno en una web y otra en el directorio principal.

PHP Fatal error: require_once(): Failed opening required '/home/xxx/public_html/xxx/libraries/joomla/factory.php' (include_path='.:/opt/alt/php74/usr/share/pear') in /home/xxx/public_html/xxx/plugins/system/plugin_googlemap3/plugin_googlemap3.css.php on line 50

PHP Fatal error: require_once(): Failed opening required '/home/totcampi/public_html/includes/defines.php' (include_path='.:/opt/alt/php73/usr/share/pear') in /home/totcampi/public_html/index.php on line 37

 

¿Me podéis echar una mano para resolverlos? Gracias

Contenido solo visible a usuarios registrados

Citar
Respondido : 23/05/2022 5:54 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola, 

Actualmente puede ver estos errores, pero veo que están relacionados con el plugin de plugin_googlemap3

[21-May-2022 12:11:12 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required '/home/totcampi/public_html/todoalianzas.es/libraries/joomla/factory.php' (include_path='.:/opt/alt/php74/usr/share/pear') in /home/totcampi/public_html/todoalianzas.es/plugins/system/plugin_googlemap3/plugin_googlemap3.css.php on line 50

En este caso revisa bajar la versión de PHP a 7.3 y comprueba si el error se ha solucionado, si no es así prueba desactivar este complemento y verifica si foto funciona de forma correcta, puedes verificar como cambiar la versión de PHP en el siguiente enlace -> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/#cpanel

Un Saludo 

 
ResponderCitar
Respondido : 23/05/2022 6:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mediterrania
 Mediterrania
Reputable Member

Esperaba otro tipo de respuesta ya que no me interesa bajar a php 73, cuando cada vez vamos a versiones más actuales. Si bajase a 7.3 me comenzarían a saltar avisos de que he de estar en 7.4 como mínimo...

Tampoco me interesa prescindir del plugin que me ofrece visionar googlemaps en mi web.

ResponderCitar
Respondido : 23/05/2022 7:00 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Mediterrania,

Lamentamos que la respuesta no sea la que esperabas sin embargo coincido con lo comentado por mi compañera en las posibles soluciones a los errores encontrados

Recuerda que desde el foro no podemos revisar a detalle que sucede en cada caso sin embargo pese a lo limitados, estamos en la total disposicion de apoyar en lo posible con el problema que se presente.

Las sugerencias son concretas 

-El plugin de Google maps es el responsable de los errores referenciados actualmente, vale la pena validar si al desactivarlo dichos errores cesan
-El cambiar la version de PHP pese a que tu acotación es totalmente valida hay plugins que o aun no están optimizados para una version en especifico o en definitiva no son compatibles y dejan de funcionar

Por ultimo si aun no quedas del todo convencida con lo que te podemos sugerir por aca, siempre estarán a disposicion nuestros colaboradores que con gusto podrán ver a detalle tu solicitud https://www.webempresa.com/directorio- colaboradores.html

Saludos!

ResponderCitar
Respondido : 23/05/2022 7:13 pm

Cursos Gratuitos WordPress

Mediterrania
 Mediterrania
Reputable Member

Para el segundo error véis alguna solución?

ResponderCitar
Respondido : 23/05/2022 7:59 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola, 

Es muy difícil comprobarlo sin realizar prueba entre ellas bajar de forma temporal la versión del PHP, también puedes revisar si hay algún otro complemento causando el conflicto ya sea con tu sitio web, el plugin o el core de joomla. 

En este caso puedes probar desactivar de tomar temporal algunos no nativos de joomla y revisar si alguno de ellos causa el conflicto; sin embargo, como te indico debes comprobar primero estas dos opciones para revisar si estos son los que pueden estar causando este error en tu sitio web. 

Un Saludo 

ResponderCitar
Respondido : 23/05/2022 8:05 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress