[Resuelto] Cambiar web de subdirectorio para publicar mientras desarrollo.  

 
Mauricio
 Mauricio
Usuario eminente

Buenas tardes.

En el directorio raíz he direccionado para que al entrar a inascal.es pase a inascal.es/es donde tengo una página el aviso "en construcción".

Simultáneamente, estoy desarrollando la nueva web en inascal.es/bg.

Ahora que he terminado la primera parte quiero copia el contenido de inascal.es/bg a inascal.es/es para que el visitante vea una versión de la nueva página mientras desarrollo el resto en inascal.es/bg y en su momento actualizarla copiando al director /es...

El problema es que una vez copiado el contenido de /bg a /es al modificar la versión privada (/bg) el visitante de /es no ve la versión pública sino la versión en desarrollo privada.

He buscado un tema similar sin éxito.

Saludos.

Maus

Respondido : 26/09/2020 11:54 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mauricio,

No logro comprender que te refieres con privada, hablas de la portada de mantenimiento? nos puedes especificar este detalle.

Un saludo 🖐️ 

Respondido : 26/09/2020 1:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mauricio
 Mauricio
Usuario eminente

Tienes razón. Fui poco claro. Con privado quería decir el subdirectorio al que se tiene acceso sólo si se conoce la url en el que desarrollo la nueva página y sólo los involucrados en el desarrollo conocen. Por pública me refería al subdirectorio al que accedes al poner el dominio en el navegador y accede todo el mundo.

Dicho de otra forma, cualquiera que escriba en su navegador inascal.com accede a la url www.inascal.com/es y ahí se aloja la web ya publicada, mientras que nosotros accederemos con a la url inascal.com/bg para ver la web en desarrollo.

La pregunta es cómo hacer para pasar el contenido de /bg al /es sin que se presente el problema con el que nos hemos encontrado: que los cambios en /bg donde estamos desarrollando se ven en /es. seguramente porque algún archivo apunta al subdirectorio de desarrollo.

Saludos.

This post was modified hace 2 semanas por Mauricio

Maus

Respondido : 28/09/2020 9:14 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Mauricio,

Disculpa cuando ingreso a el dominio principal de Contenido solo visible a usuarios registrados puedo ver que tienes tu sitio web en mantenimiento

imagen

Haz logrado modificar lo que necesitabas? de manera general deseas copiar un contenido de una web a otra puedes usar algún complemento que te permita hacerlo como ALL IN ONE, te comparto esta guía donde se explica como usarlo -> https://www.webempresa.com/blog/all-in-one-wp-migration.html

Un Saludo

Respondido : 28/09/2020 1:36 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mauricio
 Mauricio
Usuario eminente

Hola Caren.

 

Errata es inascal.es

la página es en joomla y para clonarla prodía utililzar akeeba, supongo.

el problema debe ser algún archivo que no he redireccionado.

 

Saludos

Maus

Respondido : 28/09/2020 3:07 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Mauricio,

Disculpa si no logro darte la información precisa que buscas con mi comentario.

Una opción como lo mencionas es usa Akeeba Backup, te comparto este articulo donde mencionan como realizar copias y restauración -> https://www.webempresa.com/blog/realiza-copias-de-seguridad-y-restauraciones-en-joomla-3-con-akeeba-backup.html

Sin embargo cuando ingreso a tus sitios web veo la información igual, tanto para el dominio Contenido solo visible a usuarios registrados

Un Saludo

Respondido : 28/09/2020 5:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mauricio
 Mauricio
Usuario eminente

Buenos días.

Entre otras cosas mis disculpas, el exceso de trabajo no me permitió responder antes y en general no me he explicado bien.

Al redireccionar los subdirectorios en el .htcaccess la página tomaba valores del subdirectorio anterior. Eso se debía a que no cambié el nombre de la base de datos y, por lo tanto, al entrar se redireccionaba correctamente pero al llamar a la base de datos lo enviaba donde la base anterior.

He cambiado la base de datos y todo OK.

 

Gracias nuevamente.

 

Mauricio

Maus

Respondido : 05/10/2020 8:42 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Muricio.

Ok Gracias por informarnos, por lo que veo conseguiste solucionarlo 😉 

 

Cerramos el tema.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

Respondido : 05/10/2020 9:51 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro