Error 500 Sobipro en Web de desarrollo  

 
e-Commerce 360º
 e-Commerce 360º
Usuario experto

Hola,
Estamos desarrollando una Web nueva en un directorio itnerno al de la Web antigua (siguiendo las instrucciones que proponeis para desarrollo de nuevas Webs dentro de un mismo dominio).

En la Web "antigua" tenemos Sobipro instalado pero para la nueva Web lógicamente lo vamos a querer también instalarla.
Estamos probando y nos da error 500 aunque parece que el componente se instala correctamente. Hemos mirado el Error Log y nos dice lo siguiente: [18-Jan-2016 10:05:16 Europe/Berlin] PHP Fatal error: Class 'Sobi' not found in /home/solmicro/public_html/nuevo/components/com_sobipro/lib/cms/joomla_common/base/database.php on line 148

¿Que debemos hacer? no podemos instalarlo dentro de un directorio?

Gracias,

URL del sitio: Contenido solo visible a usuarios registrados

Marketing e Internet de Resultados

Citar
Respondido : 18/01/2016 10:23 am
Rafael
 Rafael
Miembro Moderator

Buenos días,

Te recomendaría revisar si tu Hosting está utilizando una versión PHP superior a la 5.3 ya que si el sitio Joomla es nuevo es posible que necesite como mínimo una versión 5.4

Esto lo puedes solicitar mediante tickets.

Por otro lado, ten en cuenta que tendrá que usar el módulo sobipro actualizado a la versión compatible con tu Joomla, no sirve directamente el antiguo.

En caso de dudas, te recomendamos contactar con el desarrollador para que te facilite la extensión adaptada a la versión de Joomla que utilizas.

Por otro lado, prueba a instalar la última versión de Sobipro en el sitio y verifica si funciona correctamente.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/01/2016 11:08 am

Cursos Gratuitos WordPress

e-Commerce 360º
 e-Commerce 360º
Usuario experto

Buenos dias,

Si, todo esto que indicas ya esta comprobado y revisado antes de haber puesto el tema en el foro y encaja con las especificaciones de Joomla y de Sobipro así que en ese sentido lo que indicas ya esta validado.

Respecto a lo que indico, nos podéis decir donde puede estar el fallo?

Gracias,

Marketing e Internet de Resultados

ResponderCitar
Respondido : 18/01/2016 11:11 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Cuando te sale este error :

Europe/Berlin] PHP Fatal error: Class 'Sobi' not found in /home/solmicro/public_html/nuevo/components/com_sobipro/lib/cms/joomla_common/base/database.php

Es como si faltara un archivo que tiene precisamente la clase sobi, cuando instalas sobi en este nuevo sitio web, te sale algún error al momento de instalar ?, este error 500 entiendo se produce una vez instalado cuando quieres ingresar a la extensión

Verifica si tienes espacio suficiente en tu cuenta de hosting, pasa una revisión con la herramienta Stephan en caso tengas algunos archivos con permisos incorrectos, esta herramienta te cambiará los permisos

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/01/2016 5:16 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

e-Commerce 360º
 e-Commerce 360º
Usuario experto

Buenos dias,

Efectivamente no sale ningún error en la instalación, sí tenemos espacio suficiente y el error 500 sale al querer ingresas en la aplicación desde el menú del administrador.

Stephan no nos indica nada sobre los permisos y por mas que lo hayamos pasado sigue saliendo el error 500....

Mas ideas?

Marketing e Internet de Resultados

ResponderCitar
Respondido : 19/01/2016 8:53 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tal como te indica Jhon, da la sensación de que se ha producido algún tipo de error durante la instalación, de forma que no se han instalado todos los archivos de forma correcta. Prueba a descargar de nuevo el instalador del Sobipro, desinstala el que has puesto en la nueva web y prueba a volver a instalarlo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/01/2016 2:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

e-Commerce 360º
 e-Commerce 360º
Usuario experto

Si, lo hemos hecho unas 4 veces lo de instalar y desinstalar, antes incluso de poner el tema en el foro.

Sigo pensando que el tema puede ser por el motivo que en el primer post os ponia, que la nueva Web la estamos desarrollando dentro de un directorio de una web que esta en funcionamiento.... y sobipro puede que necesite tenerlo instalado en raiz? no se...es la manera que indicais siempre que se utiliza para crear nuevos diseños de una web antigua no?

No se.... sigue siendo el mismo error....

Marketing e Internet de Resultados

ResponderCitar
Respondido : 19/01/2016 4:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No debería tener nada que ver el hecho de que tu sitio este en un directorio

Para descartar el problema del directorio y de tu cuenta, instala un nuevo pack Joomla en una carpeta y prueba descargando e instalando nuevamente sobipro y verifica si te aparecen errores
http://extensions.joomla.org/extension/directory-a-documentation/directory/sobipro/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/01/2016 8:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

e-Commerce 360º
 e-Commerce 360º
Usuario experto

Ya hemos realizado esta nueva isntalacion en una nueva ruta con un nuevo pack ( http://www.solmicro.com/Prueba_Sobripo) y aun asi sale el error 500 al acceder al componente despues de uqe la isntalacion no haya dado ningun eror y en el archivo error log ahora ya nos sale otro error que tal vez podais ahora ver mejor la luz sobre el tema.

El error de ahora es: [20-Jan-2016 10:44:01 Europe/Berlin] PHP Warning: ini_set() has been disabled for security reasons in /home/solmicro/public_html/components/com_sobipro/lib/ctrl/sobipro.php on line 483

Marketing e Internet de Resultados

ResponderCitar
Respondido : 20/01/2016 10:48 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que el problema esté causado por tener la función ini_set desacitvada en tu cuenta de alojamiento. Envía un ticket a soporte desde tu área de cliente de Webempresa solicitando que te habiliten esta función, para ver si así se soluciona el problema.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/01/2016 2:24 pm

Cursos Gratuitos WordPress

e-Commerce 360º
 e-Commerce 360º
Usuario experto

Perfecto! al hacer este cambio ya no da error 500 así que debía ser algun parámetro del Hosting.

Gracias,

Marketing e Internet de Resultados

ResponderCitar
Respondido : 21/01/2016 12:01 pm

Por favor Iniciar Sesión o Registro