Migas de pan se construyen defectuosamente  

 
Juan
 Juan
Reputable Member

Hola,
Tengo migas de pan en mi web. Desde el ítem de menú "Indicadores", hijo del menú "Datos", apunto a un artículo. En este artículo muestro unos contenidos, entre los que figuran enlaces a otros artículos dentro de la misma categoría. Cuando clicko en cualquiera de éstos, la miga se me construye añadiendo a la ruta correcta (Está aquí: Inicio - Datos - Indicadores) los nombres de la categoría a la que pertenecen los artículos que vinculo desde el texto, quedando construida de esta forma:
Está aquí: Inicio - Datos - Indicadores - Datos - Indicadores - Penetración de la banda ancha

y además añadiendo el título del artículo, que lo tengo configurado a NO.
Penetración de la banda ancha es el título del artículo en este ejemplo.
¿alguna idea?

Gracias de antemano,
Juan

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 02/07/2014 6:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Verifica primero si dentro de los archivos de tu plantilla tienes un overrdies del módulo, busca la carpeta

/templates/TU_PLANTILLA_ACTUAL/html/mod_breadcrumbs

Si tienes esto prueba renombrando esta carpeta mod_breadcrumbs por ejemplo por back_mod_breadcrumbs. Luego verifica si te funciona.

Si esto no funciona , indícanos que versión de Joomla estas usando, verifica si tienes actualizaciones.

A que categoría corresponde el artículo : Penetración de la banda ancha?
Verifica si se duplica el breadcrubm cuando defines un item de menú específico para este artículo

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/07/2014 7:21 pm

Cursos Gratuitos WordPress

Juan
 Juan
Reputable Member

Hola Jhon,
Gracias por tu respuesta.
Dentro de la carpeta que me indicas no tengo ese módulo. Sólo tengo mod_menu y un modules.php
El artículo "Penetración de la banda ancha" corresponde a la categoría Datos / Indicadores.
He probado crear un ítem de menú específico para al artículo y las migas se construyen correctamente si accedo al artículo desde el menú. Aunque no si accedo a éste desde un link de contenido dentro de un artículo.
¿Alguna pista adicional?
Gracias de antemano,
Juan

ResponderCitar
Respondido : 02/07/2014 8:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Al ingresa a la siguiente
Contenido solo visible a usuarios registrados

El problema es que se repite desde el link, por lo tanto el módulo de ruta lo interpreta mal
/observatorio/datos/indicadores/73-datos/indicadores/126-penetracion-de-la-banda-ancha

Cómo has construído estos links?, sería mejor que evalues construirlos adecuadamente.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/07/2014 8:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Reputable Member

Hola Jhon,
Uso el JCE para editar mis artículos y construyo los links usando la herramienta Insertar/Editar enlace que viene en el editor. Observo que cuando creo un enlace, efectívamente se me construye la url mal en el propio editor, generándose, por ejemplo, lo siguiente:
index.php?option=com_content&view=article&id=126:penetracion-de-la-banda-ancha&catid=73:indicadores&Itemid=249.
No sé si será algún error del JCE o alguna mala configuración de éste por mi parte.
Saludos,
Juan

ResponderCitar
Respondido : 02/07/2014 9:14 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Si, parece que no es correcto el link sólo debería contener :

index.php?option=com_content&view=article&id=126&catid=73&Itemid=249

Es decir debes borrar los textos entre ":" y "&", como :
:penetracion-de-la-banda-ancha&

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/07/2014 10:19 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Reputable Member

Hola Jhon,
¿Sabes a qué puede ser debido?
He probado a incluir un link en otro artítulo y el JCE me crea la url también errónea.
Saludos,
Juan

ResponderCitar
Respondido : 02/07/2014 10:22 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Entiendo que se trata de Joomla 3.3.1 ¿correcto?

Me comenta un técnico de soporte que para esa instalación debes revisar lo siguiente:

Contenido solo visible a usuarios registrados

La causa:

En Webempresa tu web esta alojada en un disco SSD de alto rendimiento, estos discos son pequeños todavía y caros, nuestro hosting está pensado para ofrecer velocidad de carga de tu web (algo que es primordial para un buen posicionamiento), no está pensado como almacenamiento masivo sino como hosting optimizado.

En nuestros servidores, al usar discos SSD, que son más rápidos, no es necesario el uso de Memcache para que tu web cargue a mayor velocidad.

Los discos SSD son discos de memoria FLASH en estado sólido, los típicos lapices usb de memoria pero en formato disco duro, son mucho más rápidos y tienen muy poca incidencia de fallos al no tener partes mecánicas.

Por tanto, lo correcto en nuestro alojamiento sería que habilites la caché de ficheros de Joomla, lo que debería de darte un buen rendimiento.

Sobre JCE ¿Puedes indicar la versión exacta que tienes en esa web?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/07/2014 11:55 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Reputable Member

Hola Luis,
Gracias por tu respuesta.
He comentado las líneas de código en el configuration.php según me indicas y habilitado la caché sobre fichero.
El comportamiento de las migas parece ahora menos caótico, aunque sigue siendo incorrecto.
Si clicko en cualquiera de los primeros cinco enlaces del artículo en cuestión (todos ellos apuntando a otros artículos de la web) ahora en las migas sólo se muestra "Inicio", ignorándose el resto de elementos que deberían aparecer (> Datos > Indicadores).
Observo también que ahora si clicko en cualquier artículo de, por ejemplo, la sección Actualidad, se me genera una ruta en la migas que incluye también el nombre del artículo (tengo configuradas las migas para no mostrar el último elemento) y que luego la miga se mantiene persistente, sin cambiar mientras navego.

Respecto a los enlaces que genero con el JCE se me construyen con una doble referencia al destino, cuando éste se trata de un artículo en la propia web.
Por ejemplo: index.php?option=com_content&view=article&id=125:estadisticas-oficiales&catid=72:fuentes-estadisticas-oficiales&Itemid=217.

La versión de Joomla es 3.3.1 y la de JCE es la 2.3.4.4

Gracias de antemano,
Juan

ResponderCitar
Respondido : 03/07/2014 12:45 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Verifica cuando esté creando el enlace al artículo de que estás seleccionando el elemento de menú que carga el artículo que quieres enlazar y comprueba si así funciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/07/2014 3:37 pm

Cursos Gratuitos WordPress

Juan
 Juan
Reputable Member

Hola Pablo,
Gracias por tu respuesta.
Si lo que vinculo es un ítem de menú no hay problema. El asunto es que pocos artículos en mi web tiene un ítem de menú que los llame directamente. Generalmente uso los ítems de menú para presentar categorías en formato blog o componentes.
He probado crear el vínculo a un artículo usando el botón "Artículo" que viene al pie del editor de JCE, en lugar de la cadenita de la botonera del editor.
De esta forma el link se construye correctamente pero, sin embargo, cuando voy al artículo que contiene los enlaces a otros artículos desde el frontend observo que la url se me sigue construyendo mal, pese a haber borrado la caché del joomla y del navegador.
¿Alguna pista?
Saludos,
Juan

ResponderCitar
Respondido : 03/07/2014 5:13 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Una opción es que enlaces a tu artículo de manera manual y verificar si te sucede lo mismo, es decir crear un enlace al artículo, no debería cambiarse

Sin embargo una mejor opcion que tienes es que crees un menú oculto en donde vayan todos estos artículos, de esta forma desde JCE enlazas al item de menú en lugar de al artículo directamente
https://www.webempresa.com/blog/crear-un-menu-oculto-en-joomla-25.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/07/2014 6:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro