og:image para una home  

 
Juan Marcos
 Juan Marcos
Estimable Member

Hola, como puedo establecer que al acceder a la home del sitio, y compartir esa url en redes sociales, tome con la etiqueta og:image una imagen fija definida por mi y no salga o en blanco, o imágenes que no deseo que aparezcan.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 01/07/2015 2:53 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a editar algún módulo de tipo Personalizar HTML que solo se cargue en la página de inicio y añádele el siguiente código HTML:

reemplazando "ruta completa a la imagen" por la ruta de la imagen que quieras cargar. Es posible que esto funcione.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/07/2015 4:03 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan Marcos
 Juan Marcos
Estimable Member

Gracias Pablo, no se me había ocurrido, pero lo he probado y no funciona, primero al guardar el modulo me borraba el contenido, así que he deshabitado el editor desde la configuración, ya no me lo ha vuelto a borrar, pero no funciona ni aparece la etiqueta. ¿Conoces alguna componente que ayude a gestionar esto?

ResponderCitar
Respondido : 01/07/2015 4:37 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

La etiqueta debería aparecer si lo has colocado en un módulo. De no ser así, es posible que Joomla esté aplicando algún filtro al código que añades.

Para quitar el filtrado (entiendo que accedes a la administración con un usuario con privilegios de Super Usuario) vete a Sistema->Configuración global y pulsa en la pestaña Filtro de texto. Para el grupo "Super Usuario" selecciona la opción Sin filtrado y guarda los cambios.

Prueba ahora a volver a colocar la etiqueta que te había comentado (tienes que tener el editor desactivado) y comprueba si ahora no la borra.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/07/2015 4:43 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan Marcos
 Juan Marcos
Estimable Member

Si Pablo, cuando deshabilite el editor ya no lo borraba, pero no funcionaba, veo la etiqueta en el código fuente, pero en la linea quinientos y pico, y no funciona, cuando pego enlace a FB sigue igual.

ResponderCitar
Respondido : 01/07/2015 11:42 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifico que si funciona:

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/07/2015 12:39 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Marcos
 Juan Marcos
Estimable Member

Hola Johny, en realidad, he estado haciendo pruebas con este plugin Global Open Graph y ahora si funciona, también es cierto, que al principio tampoco funcionaba, hasta que he descubierto que en la plantilla había una opción para deshabilitar la gestión interna de open graph y una vez la he deshabilitado, con el plugin ha funcionado bien.

Es posible (no lo he comprobado) que esta opción del theme que he deshabilidtado para evitar el conflicto, fuese la que impedía que la solución de Pablo también funcionase 🙁

La verdad es que el plugin, ademas de gratuito es muy completo, te permite establecer imágenes, datos de contacto, fb, twitter, etc.

Muchas gracias chicos por vuestra ayuda

ResponderCitar
Respondido : 02/07/2015 1:08 am

Por favor Iniciar Sesión o Registro