Avisos
Vaciar todo

Problemas con la herramienta multi idioma  

 
Carlos
 Carlos
Usuario experto

Hola:

A ver si me podéis echar una mano.

Tengo un problema con la configuración Multi Idioma en la plantilla Dafne, he visto todos los vídeos y creo que todo está correctamente configurado.

El problema es que el cambio de idioma no es correcto en las pestañas relacionadas con un módulo, por ejemplo "Carta" o "Donde Estamos". Sin embargo el resto de pestañas que está relacionadas a un artículo funcionan correctamente.

Gracias de antemano.
Carlos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/08/2015 5:35 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

No veo como cambiar de idioma en tu sitio, el ítem de menú donde estamos lleva a una ancla de la página de inicio, tendrías que explicar exactamente como reproducir el problema que comentas, envía algunas capturas de pantalla

Saludos.

ResponderCitar
Respondido : 03/08/2015 6:24 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Carlos
 Carlos
Usuario experto

Gracias John, a ver si me puedo explicar un poco mejor.

Si te mueves por la web en Español y en las pestañas que te indico (problema) cambias a Inglés, me lleva al inicio del idioma Inglés en vez de dejarme en el módulo concreto desde el que cambio.

Si desde la pantalla donde aparece "antojitos" le cambio a Inglés, me lleva al inicio en Inglés, en lugar de dejarme en "antojitos" en Inglés.

Saludos.
Carlos

ResponderCitar
Respondido : 03/08/2015 6:44 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Desde la configuración de tu ítem de menú puedes definir una asociación, ingresa a la configuración de tu ítem de menú luego busca Asociaciones y asocia al ítem de menú del idioma principal

Saludos.

ResponderCitar
Respondido : 03/08/2015 10:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Carlos
 Carlos
Usuario experto

John:

Creo que tengo bien hechas las asociaciones. Te mando un ejemplo.

Saludos.
Carlos

ResponderCitar
Respondido : 03/08/2015 11:08 pm
Carlos
 Carlos
Usuario experto

John:

Te remito algunas pantallas más a ver si os ayuda a localizar el problema.

El problema no se produce en las pestañas de artículos, solo se produce en aquellos que están "llamando" a un módulo, del tipo "Crear una URL", que el tipo de enlaces que utiliza la plantilla.

Saludos.
Carlos

ResponderCitar
Respondido : 03/08/2015 11:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Primero para que te funcione sin recargar habilita correctamente las urls amigables de tu Joomla, no deberías tener un index.php como parte de la url.

Luego con respecto al tema del cambio de idioma automático, lamentablemente puesto que se trata de un anchor o ancla, esta apunta a la página de inicio simpre, por lo que si te diriges a antojitos en español y luego cambias a inglés se recargará la página de inicio pero no conservará el ancla

Sin embargo lo que te recomiendo es que para el idioma inglés los enlaces de anclas de la página de inicio deberían incluir el idioma, por ejemplo en la url del la configuración del ítem de menú tendrías que poner algo como : /en/#antojitos

Saludos.

ResponderCitar
Respondido : 03/08/2015 11:36 pm
Carlos
 Carlos
Usuario experto

Muchas gracias John, funciona!!"

ResponderCitar
Respondido : 04/08/2015 12:28 am

Cursos Gratuitos WordPress