Avisos
Vaciar todo

[Resuelto] Un clon de la web  

 
Responsable
 Responsable
Usuario experto

Hola.

Queremos comprobar si nuestros plugins funcionan bien con Joomla4 y PHP8 y queremos hacer desde un clon.  He clonado nuestro base de datos para usar con el clon de la web.

He creado un subdominio sin usar el dominio propio nuestro que es "test.instituc-cp17.webjoomla.es". He copiado todas carpetas y ficheros en nuestro web en producción. Luego, he pegado en la carpeta que corresponde al subdominio.

En la configuration.php, he cambiado los nombres de bbdd, usuario y contraseñas.  Cuando probé acceder el clon, no funciona.

¿Me podrías dar pistas como hago el clon?

Gracias y un saludo,

May

Contenido solo visible a usuarios registrados

Respondido : 11/10/2022 11:16 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Intenta crear el clon con el dominio no utilices la URL Temporal, por ejemplo clon.instituto........

En esta entrada del blog tienes los pasos, aunque es para versiones antiguas los paso son los mismos.

-> https://www.webempresa.com/blog/clonar-joomla-desde-el-panel-de-administracion-del-hosting.html

 

Un saludo

 

Respondido : 11/10/2022 11:59 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Responsable
 Responsable
Usuario experto

@pepesoler Gracias... ya lo he hecho y sí, ha funcionado.

De momento he probado actualizar a PHP 8 y 8.1 (sin cambiar a Joomla 4 pero con Joomla 3.10.11) y los plugins han funcionado bien. Pero cuando intenté editar un articulo, me sale este error:

error PHP 8 Y 8.1

Entonces, he vuelto a PHP 7.4.  No usamos un plugin para añadir articulos, usamos lo que hay en Joomla.

No sé porque me sale el error esto.

 

Respondido : 11/10/2022 3:36 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Joomla 3 no te funciona con la version 8 de PHP incluso si vas a actualizar directamente la plantilla tendras que desactivarla primero y ver si hay actualizaciones de la plantilla para la version 4 de Joomla, lo mismo para los plugins, componentes y modulos.

 

El error sale con la versión 8 de PHP o la version 7.4 ?

 

Si el error lo tienes en al version 7.4 puede ser de algún componente como pueda ser JCE o algún problema con el htaccess pero me decanto mas de alguna extension que tengas instalada.

 

Un saludo

 

 

 

 

 

Respondido : 11/10/2022 4:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Responsable
 Responsable
Usuario experto

@pepesoler he actualizado de Joomla 3.10.10 a 3.10.11 y probé actualizar de PHP 7.4 a PHP 8 y 8.1.  Y me sale el error con los PHP actualizados.  Con 7.4 funciona bien el editor.

Entonces, de momento puedo dejar nuestro versión de Joomla 3.10.11 y PHP 7.4 mientras los plugins instalados no tienen versiones para PHP 8. ¿Tendremos problema cuando termina el soporte para PHP 7.4? Digo si no cambiamos a Joomla 4.

Gracias.

Respondido : 11/10/2022 4:13 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal,

La version de 7.4 de PHP es un estándar aun en la actualidad por lo que no debes de preocuparte por que deje de tener soporte, lo ideal es mantener el sitio en una version compatible que no traiga errores.

Nos comentas si podemos dar el tema por resuelto

Saludos!

Respondido : 11/10/2022 4:32 pm

Responsable
 Responsable
Usuario experto

@bruno-vichetti Hola... es que nos sale en el backend aviso sobre el PHP 8 y luego Joomla 3 tambien hasta 2023 dice por eso queremos comprobar antes de hacer los cambios.

Sí, el tema está resuelto... gracias...

Respondido : 11/10/2022 4:44 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola,

Vale entiendo pero la alerta es en base al soporte de la version de Joomla 3 no la del PHP como tal

Daremos el tema por resuelto pero de tener cualquier otra consulta estaremos atentos

Saludos!

Respondido : 11/10/2022 5:39 pm

Cursos Gratuitos WordPress