Avisos
Vaciar todo

un link dentro de un artículo en idioma inglés me muestra el libro pero me cambia el menú a español  

 
Araceli
 Araceli
Usuario experto

Buenos días,
he creado un sitio en dos idiomas en la plantilla zenith II, he tenido que colocar todos los menus (en los dos idiomas) en el menú principal para que se visualicen en la misma posición (top 2) tal y como me manda la plantilla. Todo funciona bien, en el idioma español, pero en inglés, dentro del apartado catalogue>50 eyewitnesses of history, tengo un artículo con un y cuando clic sobre el me muestra bien el catálogo pero me dirige al idioma español.
LO MISMO ME PASA CUANDO CLIC sobre [ +BOOK INFORMATION] dentro de catalogue
Necesito que me siga mostrando el idioma ingles.
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 12/11/2015 7:26 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Araceli,

Sucede en Joomla! que si un artículo o elemento de menú no le has realizado una asociación a otro idioma, entonces se muestra en el idioma que tengas predeterminado.

La URL que muestra el 404 contiene:
article&id=1&Itemid=196

Revisa los artículos y los menús en busca de esa Id e Itemid.

Saludos

ResponderCitar
Respondido : 12/11/2015 9:14 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Araceli
 Araceli
Usuario experto

Gracias Pablo,
lo tengo todo asociado y ahora me da un error 404, en ambos casos:
[ + information book] y 🙁

ResponderCitar
Respondido : 12/11/2015 9:53 am
Araceli
 Araceli
Usuario experto

perdona.... Jordi!!

ResponderCitar
Respondido : 12/11/2015 10:12 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He realizado una prueba con el enlace "View complete book" que comentas y veo que, además de abrir el libro, mantiene el idioma inglés (al menos el menú se muestra en inglés). Entiendo que ya has solucionado el problema.

ResponderCitar
Respondido : 12/11/2015 1:47 pm
Araceli
 Araceli
Usuario experto

Hola,

si gracias, he solucionado el problema, simplemente en el panel de control, configuracion global, he puexto si en URLs amigables y.... todo linka bien.
Gracias!!!!!

ResponderCitar
Respondido : 13/11/2015 7:04 am

Cursos Gratuitos WordPress

Julen
 Julen
Miembro Admin

Hola,

Perfecto, tema solucionado 🙂

Gracias a ti por compartir la solución. Será de utilidad para otros usuarios del foro.

Agradecemos tu colaboración.

Saludos

ResponderCitar
Respondido : 13/11/2015 9:37 am