Avisos
Vaciar todo

Error de captcha al acceder al foro  

Página 1 / 2
 
Juan
 Juan
Reputable Member

Buenas tardes, tengo una consulta. He instalado el componente de Kunena para gestionar un foro dentro de una de las web del dominio. Lo he estado revisando y todo parece estar correcto. Además, tengo activado un ítem de menú de "Acceso" para que los usuarios se registren y entren en la web como usuario registrado. Dicho menú, tiene un captcha para completar el acceso y evitar spam.

Sin embargo, tengo un problema. El ítem del Foro es "Público", cualquier persona puede visualizarlo en mi web. Pero cuando quiero acceder como usuario registrado me surge el siguiente aviso: "ReCAPTCHA Text Error". Supongo que será un problema con el captcha ya que lo tengo activado para acceder a la web y el acceso al foro Kunena no tiene captcha. ¿Qué podría hacer para eliminar este aviso? ¿Tendría que deshabilitar el captcha para poder acceder directamente al foro? Saludos y Gracias.

Citar
Respondido : 03/02/2012 6:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Juan

Debes enviar tu url para verificar lo que comentas, ayudaría también algunas capturas indicando el problema que comentas.

Saludos.

ResponderCitar
Respondido : 03/02/2012 8:18 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Reputable Member

Perfecto: me ocurre en esta web: http://www.voluntariadoalcores.org/escueladeformacionsefed/ Cuando se intenta acceder al foro, sin loguearse previamente, aparece este error:

¿Qué podría hacer? Saludos y Gracias.

ResponderCitar
Respondido : 03/02/2012 8:28 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Es posible que hayas configurado alguna opción como acceso restringido para usuarios registrados.

Veo que actualmente no presenta ese problema, supongo que ya lo solucionaste, me aparece tal como la imagen adjunta.

Saludos.

ResponderCitar
Respondido : 04/02/2012 1:34 pm

Cursos Gratuitos WordPress

Juan
 Juan
Reputable Member

No, quizás no me he explicado bien. El problema persiste. Cuando un usuario registrado en mi web, intenta acceder al foro directamente (sin acceder antes por el ítem de menú de Joomla "Acceso") salta el problema del captcha.

La pestaña de foro aparece bien, sin problemas, tal y como adjuntas. El problema es cuando quieres entrar al foro como usuario registrado. No te permite, salvo que hayas entrado previamente por el acceso de Joomla. Yo quiero evitar esto pero no sé cómo. ¿Qué podría hacer?

ResponderCitar
Respondido : 04/02/2012 6:00 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

¿Puedes indicarnos que sistema de CAPTCHA está utilizando? y si utilizas el aceso nativo de Joomla! para usuarios o el de Kunena independiente para el Foro.

Saludos

ResponderCitar
Respondido : 04/02/2012 6:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Reputable Member

Estoy utilizando el plugin Joo Recaptcha con estos parámetros:

No sé si Kunena tiene especificaciones concretas para el acceso, no las he visto. Pero por si acaso, he activado en Sí la casilla de "Soporte para Plugines de Contenido Joomla" que trae la pestaña de Frontal de Kunena. Aún así, persiste el problema. ¿Qué puedo hacer? Saludos y Gracias.

ResponderCitar
Respondido : 04/02/2012 6:15 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Creo que hay una confusión de base pues Joo reCAPTCHA no gestiona CAPTCHA para Kunena, solo para formularios nativos de Joomla! y para VirtueMart y K2 la versión PRO (de pago).

- http://joomla.stefysoft.com/jootools-extensions/jootools-plugins/59-joo-recaptcha-pro-plugin.html

Facilitanos una captura donde veamos donde tratas de gestionar reCAPTCHA en Kunena.

Saludos

ResponderCitar
Respondido : 04/02/2012 7:27 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Reputable Member

No, es que para Kunena no gestiono en principio ningún captcha. Creo que el problema es que el foro toma el captcha del acceso nativo de Joomla. Yo lo que quiero quitar precisamente es eso, el supuesto captcha de Kunena, pero no sé cómo porque en la gestión del foro no aparece. Y en el plugin de Joo Recaptcha no me aparece la posibilidad de deshabilitarlo sólo para el ítem de foro. ¿Qué podría hacer? Saludos y Gracias.

ResponderCitar
Respondido : 04/02/2012 7:31 pm
Juan
 Juan
Reputable Member

Añado una cosa más: si deshabilito el plugin de Joo Recaptcha, el problema se acaba y cualquier usuario registrado puede acceder directamente al foro. Pero no me gustaría eliminarlo porque ya hemos tenido otras veces problemas con los bots. Creo que la solución estaría en deshabilitar el plugin de recaptcha para el foro, pero no sé si eso se podría hacer ni cómo. ¿Qué podría hacer?

Saludos y Gracias.

ResponderCitar
Respondido : 04/02/2012 7:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

El problema es que si Kunena utiliza el acceso y registro de usuaros nativos de Joomla! siempre que un usuario se logee o registre desde Kunena tendra que pasar forzosamente por el formulario nativo de Joomla! que no tendra reCAPTCHA quizás en primera instancia y que tras logearse dará un error y si cargará el formulario de acceso ya con reCAPTCHA.

Lo propio seria gestionar los acceso con reCAPTCHA o CAPTCHA desde Kunena pero no podrás hacerlo con Joo reCAPTCHA.

Saludos

ResponderCitar
Respondido : 04/02/2012 8:36 pm
Juan
 Juan
Reputable Member

Y ¿cómo lo podría hacer? ¿Hay algún plugin o módulo que permita hacer esto? Saludos y Gracias.

ResponderCitar
Respondido : 05/02/2012 12:39 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

En principio debería ser suficiente con habilitar el CAPTCHA que trae por defecto Kunena a partir de su versión 1.7

Saludos

ResponderCitar
Respondido : 05/02/2012 1:03 am
Juan
 Juan
Reputable Member

Pues lo he activado tal y como indicas introduciendo las claves de captcha que utiliza el Joo Recaptcha pero no me sale ningún captcha cuando intento acceder al foro. Es decir, que estoy igual que antes. ¿Qué puede pasar? Saludos y gracias.

ResponderCitar
Respondido : 05/02/2012 1:21 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan,

Pues lo he activado tal y como indicas introduciendo las claves de captcha que utiliza el Joo Recaptcha pero no me sale ningún captcha cuando intento acceder al foro

Debes generar nuevas claves desde la url siguiente:

- http://www.google.com/recaptcha

Saludos

ResponderCitar
Respondido : 05/02/2012 2:23 am
Página 1 / 2