Analytics prestashop 1.7.5  

 
Violeta
 Violeta
Usuario experto

Hola, tenía analytics en el prestashop 1.7.5 con el módulo de analytics pero estaba causando un error en el carrito... así que he tenido que desactivarlo.
He intentado añadir el código manualmente pero me ha sido imposible, buscando en internet en inglés encontré este tutorial: https://www.matthieu-jalbert.fr/installer-google-analytics-sur-prestashop-1-7-sans-module/
Pero tampoco me ha servido ni tampoco añadiendo la etiqueta en header.tpl ni en head.tpl (he terminado probando con todos) y tambien con las etiqueta literal
¿Sabéis porque puede ser que no consigo activar la etiqueta? gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 07/09/2019 9:59 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Violeta,

Es extraño que te causara errores el analitycs en el carrito, ¿Podrías explicarnos brevemente qué error te causaba? ¿Podrías mostrar cómo integraste o intentaste integrar lo que se explica en el tutorial del enlace que nos compartiste en tu sitio? ¿Cuál es el tema que estás utilizando?

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 07/09/2019 10:52 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Violeta
 Violeta
Usuario experto

El tema es este: https://addons.prestashop.com/es/temas-arte-cultura/39981-furniture-home-decor.html

No solo me da error en la tienda en.hardpeach.com que tiene prestashop 1.7.5 sino tambien en la otra tienda hardpeach.com que tiene prestashop 1.6.1

No me da el mismo error, que conste! pero en ambos casos me provoca un error en el carrito. En el prestashop 1.7.5 lo que provoca es que no se añaden los productos al carrito, sale un mensaje de error, si recargas la página a veces se añade y otra no, y si consigues añadirlo con esfuerzo no se aplican los descuentos o da error en el pago. Según lo pilles.
No sé que pasa con el módulo que me tiene manía o algo porque luego veo foros y a todos les va genial...

Al desactivar el modulo de analytics todos los problemas desaparecen y funciona todo.

Lo de añadir el código, seguí el tutorial en el archivo layout que especifica de classic, y colocando el código de analytics entre los dos literal. Pero no sé si hice algo mal porque no detectaba tráfico...

ResponderCitar
Respondido : 08/09/2019 11:34 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Violeta,

Accediendo a la web del template se especifica que es compatible con las versiones de Prestashop 1.7.6 - 1.7.6.1, eso podría explicar por qué tienes estas complicaciones. Puedes optar por insertar el código de analytics en el archivo header.tpl, si ya lo intentaste y no te funcionó vuelve a hacerlo, prueba y si sucede lo mismo por favor compártenos el header.tpl de tu tema y lo revisamos.

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 08/09/2019 5:45 pm

Cursos Gratuitos WordPress

Violeta
 Violeta
Usuario experto

El tema si es compatible hablé en ese momento con el desarrollador.
Creo que he dado con lo que es... desactivando módulos

Parece ser que no son compatibles los módulos de estadísticas de prestashop nativas con el módulo de analytics. Hay que tener uno o el otro, pero los dos a la vez no.
Desactive todos los módulos de estadísticas de prestashop y active analytics y parece que ya funciona todo. Si veo que presenta algún problema de nuevo escribo de nuevo

ResponderCitar
Respondido : 09/09/2019 12:14 pm

Por favor Iniciar Sesión o Registro