Avisos
Vaciar todo

Modulo AliExpress No funciona (SOLUCIONADO)  

 
Yongwei
 Yongwei
Usuario experto

Buenos días.
Estoy vendiendo en AliExpress y estoy buscando un módulo con el que poder importar productos de mi web a AliExpress para vender mas comodamente y despues pasar los pedidos de AliExpess a mi Prestashop.

He revisado el modulo de AliExpress y quería ver como funciona.
Cual ha sido mi sorpresa cuando he subido el módulo de AliExpress y he comprobado que el Blackoffice no cargaba los modulos. No lo he llegado a instalar porque los modulos salen en blanco. Solo lo he subido a mi prestashop en .zip

La web funciona bien, y el backoffice tambien funcionaba bien.
El problema reside en que si lo instalo la seccion de "Modulos" del prestashop no carga. En su lugar se carga una página en blanco y no sale nada. Por lo que no puedo Instalar, configurar o desintalar ningun modulo. Para que se solucionara el problema he tenido que borrar mediante ftp la carpeta de Aliexpress que se habia creado.

¿Saben si hay algún módulo que pueda utilizar?¿Saben si este modulo que adjunto funciona bien?
Prestashop 1.6.1.23
Php 7.0

Modulo: aliexpress-v1.0.14-php.7.x.zip

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 11/09/2019 12:03 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Yongwei.

Revisa si con la versión 5.6 de PHP carga bien el módulo:
Puedes modificar la versión de PHP desde tu cuenta de cPanel:

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

El cambio de versión de PHP no afecta a los archivos de tu web y es a nivel servidor, un avez modificada revisa si la web carga bien, si vieras que hay algún problema en la carga de alguna sección puedes volver a la version que tenias anteriormente.

Tienes plugins alternativos, pero prestashop ya sabes que es todo de pago:
-> https://addons.prestashop.com/es/dropshipping/29854-aliexpress-dropshipping-product-importer.html
-> https://addons.prestashop.com/es/dropshipping/45060-dropshipping-aliexpress.html

Un saludo

ResponderCitar
Respondido : 11/09/2019 12:42 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Yongwei
 Yongwei
Usuario experto

Hola.
No puedo poner el PHP a la version 5.6 porque tengo actualizado mucha cosas para la version 7.0.

Con respecto a los otros módulos que me has pasado es para hacer dropshipping.
Lo que yo quiero hacer es publicar los productos que yo ya tengo en mi web en Aliexpress.
¿Esos modulos tambien sirven para eso?
Un saludo.

ResponderCitar
Respondido : 11/09/2019 1:03 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Los módulos que te indique lo que hacen es importar los productos que tengas en aliexpress, una vez importados si que puedes modificar el producto y se sincroniza con los que tienes en aliexpress.

hay un módulo que puede que haga lo que comentas, según lo que comentan en sus funcionalidades:

Subir tu catálogo de productos de tu tienda Prestashop a tu tienda en Aliexpress, incluso con aumento o disminución de precio por cada familia.

No lo probe y no te puedo decir si su funcionamiento es el que indican, pero por lo que veo es gratuito.

-> Contenido solo visible a usuarios registrados

Un saludo

ResponderCitar
Respondido : 11/09/2019 2:10 pm

Cursos Gratuitos WordPress

Yongwei
 Yongwei
Usuario experto

Muchas gracias.
Voy a marcar el tema como stick verde porque creo que ese podrá servir.
Un saludo :laugh:

ResponderCitar
Respondido : 11/09/2019 2:40 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Nada un placer 😉
Dejo la entrada en espera por si necesitas retomarlo.

Si no es mucho pedir, me gustaría que una vez lo pruebes si su funcionamiento es el indicado que lo indiques para que otros usuarios lo puedan tener presente. 😉

Un saludo

ResponderCitar
Respondido : 11/09/2019 2:54 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Yongwei
 Yongwei
Usuario experto

Buenas tardes.
Te comento un poco, porque he descubierto algo mas.

He puesto la web en modo prueba de error y me saltaba un "Http error 500".
He probado con lo que me dijistes de poner PHP 5.6 y 7.0 y nada.
Tras varias pruebas he conseguido sacar el error siguiente.
=======================================
"...Fatal error:
The file /home2/gblaes/public_html/modules/aliexpress/classes/apiv2/TopSdk.php was encoded with the Encoder for PHP 7.1 and can only run on PHP 7.1 or later.
If you are the administrator of this site then please upgrade to PHP 7.1 or later and install the corresponding ionCube Loader. in Unknown on line 0..."
=======================================

En otras palabras necesito aumentar mi PHP a 7.1 o superior. El problema se resolveria facil si no fuera porque al intentar actualizar el PHP me salta el siguiente error.
=======================================
"...Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance..."
=======================================

He revisado tambien otras configuraciones y he leido en foros que para la version PHP 7.1 o superiro se necesita un prestashop 1.7....
Yo actualmente tengo 1.6.1.23 imposible actualizar actualmente a la versión 1.7 por problemas de actualizacion de modulos como la plantilla entre otros.

¿Alguna solucion o parche para poder instalar la version PHP 7.1?

¿Seria mas facil o aconsejable intentar conseguir una version del modulo de Aliexpress mas pequeño que funcionara con alguna version inferior del PHP 7.0? (en caso de que la hubiera)

Nota: El módulo lo descargue del enlace que me pasasteis que era compatible con version 1.6 de linea grafica, por eso perfecto. Gracias. Si alguien tiene un PHP superiro a 7.1 lo puede usar.

Nota 2: Segun la pagina de linea grafica tienen version de 1.6 que funciona con php 7.0 que es el que deacargue pero me saltan esos errores no se porque. Por tanto, aunque alguien tenga 1.6 necesita de PHP superior.

¿Alguna idea?

Gracias.

ResponderCitar
Respondido : 11/09/2019 6:14 pm
Yongwei
 Yongwei
Usuario experto

SOLUCIONADO

Una vez identificado el fallo del PHP.

Linea Grafica dispone de soporte.
Puedes pedir a traves de ticket un modulo para 1.6-1.7 con la version del PHP 5.X

Ahora toca ver si el módulo es lo que necesito, pero al menos, ahora puedo configurarlo.

Suerte y gracias ^^

ResponderCitar
Respondido : 11/09/2019 6:19 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Yongwei.

Jejeje, que grande !!!!! :woohoo:
me alegra que lo solucionaras.

Gracias por informarnos.

Dejo la entrada en espera por si quieres realizar alguna consulta sobre lo que estamos tratando

Un saludo y como tu dices Suerte.....

ResponderCitar
Respondido : 11/09/2019 6:24 pm