Avisos
Vaciar todo

Error Revolution Slider  

 
Joana
 Joana
Usuario experto

Hola!

Con la nueva plantilla que he adquirido para Prestashop viene el módulo Revolution Slider. El caso es que me da el siguiente error:

Revolution Slider Error: You have some jquery.js library include that comes after the revolution files js include.
This includes make eliminates the revolution slider libraries, and make it not work.

To fix it you can:
1. In the Slider Settings -> Troubleshooting set option: Put JS Includes To Body option to true.
2. Find the double jquery.js include and remove it.

El punto 1 creo que lo he solucionado (adjunto captura de pantalla), pero el punto 2 no sé como solucionarlo.

He encontrado el mismo problema en este foro pero se da el caso que el configurador del módulo es distinto al mío.

Muchas gracias por la atención.

Un saludo.

Aunque en el punto 1 pone "true", supongo que quiere decir "on"

Esta imagen corresponde al mismo problema que yo que se trató aquí y que se pudo solucionar. Se ve que no es el mismo que el mio.

Esta es una captura de alguien que también tuvo el mismo problema que yo y observo que tampoco se parece a la configuración que tengo yo en mi módulo. Falta lo de "JQuery no conflict Mode"

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/07/2017 9:27 pm
Jordi
 Jordi
Usuario experto

Hola amiga,

Antes de proceder a lo que te comenta crea un backup de tu web y luego sigue las instrucciones que te comento:

Mira por FTP o por el explorador de ficheros del Cpanel si encuentras el fichero llamado

jquery.themepunch.revolution.min.js

en el template CENTUM está aquí : themes/Centum/revslider/js/rs-plugin/js/jquery.themepunch.revolution.min.js

Sobre las línias 2827 y 2833 verás dos variables que terminan con una coma "," quita las comas de las 2 variables y guarda el archivo.

Te enseño el posible código:

ar variableName =
    {
    function1:      function()
        {
        //  Do something
        },
    function2:      function()
        {
        //  Do something else
        },
    variable1:      'Primera variable',
    variable2:      'Segunda variable',
    };
ResponderCitar
Respondido : 19/07/2017 10:18 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Joana
 Joana
Usuario experto

Hola Jordi!

He localizado el archivo que me comentas en mi plantilla pero el código aparece de esta manera:

Es un poco complicado encontrar lo que me dices, más teniendo en cuenta que mi nivel es básico :whistle:

Saludos.

ResponderCitar
Respondido : 19/07/2017 10:40 pm
Jordi
 Jordi
Usuario experto

Ok, me puedas dar la dirección para poder acceder directamente desde mi navegador a este fichero?

por ejemplo:
http://www.www.sanissima.com/toda_la dirección_del-fichero_ycarpetas/jquery.themepunch.revolution.min.js

ResponderCitar
Respondido : 19/07/2017 10:44 pm

Cursos Gratuitos WordPress

Joana
 Joana
Usuario experto

Imagino que con este enlace te irá bien.

file:///Users/txemiyjoana/Downloads/jquery.themepunch.revolution.min.js

ResponderCitar
Respondido : 19/07/2017 11:09 pm
Jordi
 Jordi
Usuario experto

No Joana, esta es la dirección física de tu ordenador, de la carpeta que has bajado el fichero.... y me refiero a la URL a través de la web:

http://www.sanissima.com/carpeta/carpeta/carpeta/jquery.themepunch.revolution.min.js

Gracias

ResponderCitar
Respondido : 19/07/2017 11:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Joana
 Joana
Usuario experto

Jordi, creo que no te comprendo del todo bien. Esa carpeta está dentro de mi CPanel y para acceder se necesita contraseña.

De todas formas no sé que dirección poner, ¿esto?:

www.sanissima.com/home2/sanissim/public_html/modules/revsliderprestashop/rs-plugin/js/jquery.themepunch.revolution.min.js

Esta dirección no lleva a ningún lado. Ya te he dicho que soy muy limitada para estas cosas.

Ya me dirás :blink:

ResponderCitar
Respondido : 19/07/2017 11:49 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifico que algunos usuarios reportan este error, puedes verificar si el siguiente enlace te es de ayuda: https://theme-fusion.com/forums/topic/revolution-slider-error-8/ ,lo más recomendable es que contactes con el desarrollador de la plantilla o del plugin para que te ayuden a detectar el problema rapidamente.

ResponderCitar
Respondido : 20/07/2017 2:43 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi
 Jordi
Usuario experto

Ok Joana,

LA url tuta es la : https://sanissima.com/modules/revsliderprestashop/rs-plugin/js/jquery.themepunch.revolution.min.js

me bajo el fichero y te digo las comas que tienes que quitar.

Recuerda antes de modificar nada hacer backup.

SAludos

ResponderCitar
Respondido : 20/07/2017 9:35 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola joana.

El problema viene por la carga de JS,

En versiones de la extensión para joomla y para wordpress se puede modificar con la opción que muestras en la captura de la primera entrada pero en prestashop según estado revisando no tiene esa opción.

Lo mejor como te comenta jhon es que te pongas en contacto con el desarrollador de la plantilla, es posible que con una actualización de la plantilla o la extensión, se soluciona el problema y estoy seguro que les pasa a otros clientes con la misma plantilla con lo que el error lo tienen que tener localizado y te pueden dar una solución rapida.

Sobre Revolution Slider, creo que puede ser la extensión que menos me gusta de todo el repertorio de extensiones existentes ( Igual es personal y otros te dicen lo contrario ), vulnerabilidades por todos los sitios y una carga de recursos bestial que hace que la web se ralentiza mucho.

Un saludo

ResponderCitar
Respondido : 20/07/2017 3:52 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi
 Jordi
Usuario experto

Como te dicen todos...ponte en contacto con el desarrollador y te va ha decir lo mismo que te digo yo.... ya que me ha pasado varias veces......van a sacr una nueva versión con el tema de las "comas "resuelto.

Pero como te dije antes si lo modificas tu te irà bien.... el problema es saber las 2 variables que afectan.....y como me lo bajo con UTF no puedo ver exactamente las 2 que son.

Saludos

ResponderCitar
Respondido : 20/07/2017 10:41 pm
Joana
 Joana
Usuario experto

Hola a todos!

Pepe: justo estaba pensando en que igual no es tan buena idea lo de tener ese módulo (por los recursos que pueda consumir). En la plantilla viene otro más sencillito y que no parece tan malo, al menos funciona bien.

Jordi: gracias por haberte tomado la molestia de mirar el archivo ese.

Creo que ni voy a contactar con el desarrollador, lo desinstalo y listos.

Muchísimas gracias por la ayuda.

Saludos.

ResponderCitar
Respondido : 21/07/2017 12:17 pm

Cursos Gratuitos WordPress