Avisos
Vaciar todo

No ha sido autorizado a modificar ciertos ficheros. Asegúrese de haber configurado las autorizaciones necesarias en su servidor.  

Página 2 / 2
 
Ivan
 Ivan
Reputable Member

Buenas,
He entrado en configuracion en un modulo me indica algo de permisos del ftp.

Por si me podeis ayudar.

gracias y un saludo

🙁 No ha sido autorizado a modificar ciertos ficheros. Asegúrese de haber configurado las autorizaciones necesarias en su servidor.

In order to change file rights on your server, using your FTP details, go to modules/ and then, check that rights are set to 0777 or 777 for the directory "popnewsletter/views/img/" (right click > properties > Permissions > select recursive permissions).

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/01/2017 7:11 pm
Ivan
 Ivan
Reputable Member

Buenas Jhon,

Tengo el mismo problema en la tienda clon, con el mismo modulo y en esa tienda hace mucho que no se modifica nada, en esa tienda he reistalado el modulo y se ha solucionado.

Pero en la de producion si hago eso pierdo datos del modulo.

El problema que da es de imagenes estoy confencido que va ser ese el problema.

Un saludo

ResponderCitar
Respondido : 30/01/2017 11:54 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola ivan.

Revisando tu cuenta veo que sigue dando problemas de permisos:

Contenido solo visible a usuarios registrados

Prueba a regenerar el archivo .htaccess

.- Accede a preferencias -> SEO + URLs
.- En la sección Configuración de los enlaces el apartado ' URL amigable ' deja seleccionado en NO y Guarda.

.- Vuelve a activar las URL amigables y guarda de nuevo.

Comprueba si después de eso se soluciona el problema de los permisos.

Un saludo

ResponderCitar
Respondido : 31/01/2017 9:57 am
Ivan
 Ivan
Reputable Member

Buenas dias Pepe,

He realizado la modificacion que me has comentado pero sigue el modulo dando el mismo problema.

Gracias y un saludo

ResponderCitar
Respondido : 31/01/2017 10:26 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ivan.

Cada vez que se pasa un stephan, por defecto revisa los permisos y los corrige automaticamente.
Los permisos correctos serian 755 para las carpetas y 644 para los archivos.

He activado la opción para que stephan no cambie los permisos y los deje como están, también le pedí a un compañero de soporte que cambie los permisos de las carpetas del modulo y los dejara en 777 como te indica el aviso que muestras en la captura de pantalla.

Revisa si se corrigió el problema, si no se corrige veremos de instalar otro modulo con características parecidas.

Un saludo

ResponderCitar
Respondido : 31/01/2017 1:58 pm
Ivan
 Ivan
Reputable Member

Buenas Pepe,

Sigue dando el mismo aviso, tambien lo tengo instalado en la tienda clon por si quereis mirar alli.

He hablado con Luis Cambra porque le solicite una modificacion de dicho modulo, me comenta esto

Respecto al módulo no es cuestión de PrestaShop si no del módulo que puede necesitar esos permisos. Eso si, son permisos demasiado abiertos. La cuestión sería que hablases con el desarrollador del módulo para comentarle este hecho ya que no es seguro que pida permisos a 777 completamente abiertos. Eso es un agujero directo de seguridad.

La ultima respuesta de Prestasho fue esta.

If the module works properly with your current configuration, you do not need to give more permission, if it doesn't, please give permissions to everything in the folder mentioned above.

Regards,

Alexis

He revisado la cuenta ahora con Stephan pero no ha cambiado los permisos siguen en 777 se deben de modificar por seguridad?

Un saludo

ResponderCitar
Respondido : 31/01/2017 2:10 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ivan.

Te acabamos de dar permisos a la carpeta img que parece que faltaba.
prueba si se soluciono.

Si ves que sigues con el mismo problema instala el modulo que te adjunto, las funciones son las mismas que el anterior.

Un saludo

ResponderCitar
Respondido : 31/01/2017 2:42 pm
Ivan
 Ivan
Reputable Member

Buenas Pepe,

Sigue igual, he instalado ese modulo en la tienda clon y puedo entrar sin problema en configuracion.

Probe en el clon a reiniciarlo y luego funciona el modulo, el problema es que en al tienda en producion si hago eso pierdo las modificaciones que realizo Luis en el modulo.

Un saludo

ResponderCitar
Respondido : 31/01/2017 2:53 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ivan.

¿ que modificaciones realizo, Fueron de css ? si fueron solo de css no habría problema en reiniciarlo ya que seria copiar la carpeta de los estilos.

Un saludo

ResponderCitar
Respondido : 31/01/2017 3:00 pm
Ivan
 Ivan
Reputable Member

Buenas Pepe,

Hizo varias imagenes, incluir checkbox cambiar tablas.

El modulo tambien lo tengo instalado en la tienda clon sin modificarlo y tambien sale el mismo aviso.

Al poco de instalarlo salio una actualizacion y me comento que si lo actualizaba se perdian los cambios.

Si quieres acceso a la web clon y verificais el modulo desde alli y haceis pruebas.

En la tienda real si quieres configurar cambiar para que stephan cambia los permisos y tenerlo seguro.
Un saludo

P:D he probado dar permiso a todas las images del modulo 777 en el clon y tampoco funciona.

ResponderCitar
Respondido : 31/01/2017 3:12 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Deberías documentar las modificaciones que se hizo, igual en algun momento necesitarás actualizar el modulo
O como es el caso actual necesitas reinstalarlo ya que es posible que con un una reinstalación se solucione el problema.

Lo de permisos 777 sería lo último que deberías tener en cuenta ya que esto es un agujero de seguridad.

En conclusión, reinstala el módulo y verifica si con esto te funciona, si va bien entonces realiza las modificaciones nuevamente que se han realizado en tu módulo.

Saludos.

ResponderCitar
Respondido : 31/01/2017 6:10 pm
Ivan
 Ivan
Reputable Member

Buenas Jhon,

En la tienda clonada he reistalado el modulo y funciona.

Hablare con Luis sobre esto.

Podeis dar permiso para que Stephan corrija los permisos 777 para evitar el agujero de seguridad.

Un saludo

ResponderCitar
Respondido : 31/01/2017 6:15 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Solicita esto a través de tickets de soporte, desde foro no tenemos acceso a tu cuenta.

Saludos.

ResponderCitar
Respondido : 31/01/2017 8:40 pm
Ivan
 Ivan
Reputable Member

Buenas,

Estado hablando con el soporte de Prestashop, sobre el permiso 777 le indique que no es seguro.

Su respuesta fue esta.

Setting 777 permission on an image folder is not a security issue since no PHP code is executed, all websites have some folders with 777 permission. We need this to be able to create image.

Regards,

Alexis
Customer Service - PrestaShop Addons

Dice que no hay problema de seguridad haciendo los cambios.

Le he dado acceso a la tienda clon y ha cambiado todos los archivos de esta imagen que os adjunto con permiso 777 y el modulo ya no pide ese permiso.

Veis correcto que se haga este camion en la tienda en producion? sin correr riesgos de seguridad?

Gracias y un saludo

ResponderCitar
Respondido : 02/02/2017 3:40 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No es del todo correcto que te digan que no hay riesgo, puedes leer en varios foros al respecto de los permisos 777, sin embargo también depende de la configuración del servidor.

Te sugiero consultar esto mejor a traves de tickets, de ser necesario te pueden excluir algunas carpetas para que tengas permisos 777

Saludos.

ResponderCitar
Respondido : 02/02/2017 6:07 pm
Página 2 / 2