Activar certificado de seguridad  

 
Moises
 Moises
Reputable Member

Buenas tardes, hoy he activado los certificados de seguridad SSL en mis dominios para que la url sea https y ahora me aparecen como sitios no seguros, activé los certificados y cambié http por https en ajustes, generales de mi panel de control. Qué debo hacer ahora?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 20/04/2017 11:38 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Es posible que hayas instalado el certificado pero no lo has configurado.

Los pasos para la configuración de tu WordPress con SSL están especificados en los siguientes artículos de blog:

https://www.webempresa.com/blog/activar-ssl-https-en-wordpress.html
https://www.webempresa.com/blog/activar-ssl-https-en-wordpress.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/04/2017 1:23 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Moises
 Moises
Reputable Member

Buenas tardes, al instalar el certificado de seguridad, me han surgido varios problemas en mis páginas web, paso a detallarlos a ver si son por motivo de la instlación:
+ En www.fcsnoticias.com, la imagen del logo que va debajo de la fecha y sobre el menú no se ve, es un Gantry Logo.
+ En www.norbertochavez.com, no he podido activarlo porque en mi cpanel abro la carpeta y no veo ese dominio, los demás ya los modifiqué, pero ese dominio no está en el listado y me sigue dando error de privacidad, cuando pinchas en alguna página del menú.
+ En www.hacemostussueños.com tengo el mismo problema, me da alerta de seguridad.
+ En www.formulariosonline.es, tengo problemas de seguridad actualmente, pero esta tarde tuve que volver a poner http y quitar los cambios de cpanel de la respuesta de Johnny, pues tengo activo un sorteo en esa página y me daba error al cargarla.
+ En el resto de dominios se me hizo el cambio a https correctamente.
Espero solucionar esto lo antes posible.Saludos

ResponderCitar
Respondido : 21/04/2017 11:57 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

En cuanto al primer dominio te recomiendo que pruebes a subir el logo nuevamente, por el momento no lo visualizo.

En cuanto a los demás dominios debes realizar la consulta en hilos separados, puedes revisar las reglas del foro en el siguiente enlace: https://www.webempresa.com/foro/reglas.html

De forma general si te da error de privacidad o te carga no se muestra el candado verde es porque esta cargando contenido mixto.

El problema que tienes en la web cuando se carga con el protocolo https está provocado porque se están cargando elementos adicionales con el protocolo no seguro http, como archivos css, js (javascript) o imágenes. Esto provoca, por un lado, que en lugar de salir el icono del candado a la izquierda de la barra de direcciones del navegador se muestre en su lugar una advertencia y, por otro lado, puede provocar que la web no se vea correctamente, debido a que el navegador bloquea los contenidos no seguros.

Para corregir este problema es necesario localizar los elementos no seguros que se están cargando. Puedes utilizar el inspector de elementos que incluyen la mayor parte de los navegadores o utilizar alguna extensión adicional para el navegador como Firebug. Pulsando en la pestaña "Consola" y recargando la página se tendrían que mostrar aquí los elementos no seguros que se están cargando.

Otra forma de detectar los contenidos no seguros sería utilizando la página https://www.whynopadlock.com/ . Aquí deberás poner la url de tu web y esperar al resultado del análisis. Te indicará los elementos no seguros que ha encontrado y desde dónde se cargan.

Normalmente este contenido no seguro se suele cargar desde algún widget, si se trata de imágenes. Editando el widget podrías corregir la ruta de carga de la imagen, para que en lugar de cargarse con http:// lo haga con https:// o, mejor aun, poniendo simplemente // (por ejemplo, //www.nombreweb.com/images/nombreimagen.jpg).

Otros elementos, como archivos css o js, se suelen cargar desde el propio tema que estés utilizando en tu WordPress, por lo que sería necesario aplicar cambios en el código del tema, localizando los archivos desde donde se hacen estas llamadas, y cambiando las mismas para empiecen por https:// o por //

Otro tema que debes comprobar es el siguiente: en la administración de WordPress vete a Ajustes->Generales. En los campos "Dirección de WordPress (URL)" y "Dirección del sitio (URL)" pon la url de la web con https (puede que esté puesta con http). De esta forma se le indicará a WordPress que la url de la web carga con protocolo https.

Existe un plugin que te puede ayudar en esta tarea de arreglar los problemas con la carga de contenidos no seguros, llamado SSL Insecure Content Fixer, y que se puede descargar desde el enlace https://es.wordpress.org/plugins/ssl-insecure-content-fixer/ o instalar directamente desde la administración de WordPress. Está pensado para detectar la carga de contenido vía http y aplicar el cambio en el enlace de carga a https.

Una vez instalado y activado el plugin deberás ir a Ajustes->SSL Insecure Content. En el parámetro "Fix insecure content" selecciona el nivel de revisión que aplicará el plugin, de menos a más estricto. Puedes ir probando los diversos niveles de arriba a abajo, recargando el frontal después de cada cambio, hasta encontrar el que te corrija el problema, aunque lo recomendable será la opción "Widgets" o, si esta sigue sin solucionar el problema, la opción "Capture". El parámetro "HTTPS detection" se puede dejar con la opción "standard WordPress function".

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/04/2017 1:25 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro