Corregir error 500 en pack wordpress  

 
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose Manuel,

Dices que te apareció, el error, cuando pasaste de la url temporal a la del dominio con el script searchreplacedb2.php ¿correcto?

¿Recuerdas la url "exacta" que pusiste en la última pantalla de searchreplacedb2.php antes del cambio?

- URL origen:
- URL destino:

Importante ¿hiciste copia de seguridad, como recomendamos siempre, antes de hacer ese cambio?.

Un error 500 en WordPress se puede solucionar en minutos, si recuerdas el último proceso realizado y se deshace, o días si hay que mirar aquí y allá hasta dar con el minúsculo cambio que provoca el error 500.

Saludos

Citar
Respondido : 04/02/2014 11:05 pm
JOSE MANUEL
 JOSE MANUEL
Usuario activo

Consultando al servivio de soporte, me sale error a corregir:
hay logs de errores que podrian generar un error 500 en el servidor
PHP Fatal error: require() [function.require]: Failed opening required '/home/jmarquit/public_htmlwordpress/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/jmarquit/public_html/index.php on line 17

No puedo acceder a la adminstración de mi web: jmarquitecnic.es/wp-admin
Me sale error 404, cómo puedo arreglar problema desde Cpanel?

URL del sitio: Contenido solo visible a usuarios registrados

ResponderCitar
Respondido : 02/02/2014 8:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

JOSE MANUEL
 JOSE MANUEL
Usuario activo

Consultando al servivio de soporte, me sale error a corregir:
hay logs de errores que podrian generar un error 500 en el servidor
PHP Fatal error: require() [function.require]: Failed opening required '/home/jmarquit/public_htmlwordpress/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/jmarquit/public_html/index.php on line 17

No puedo acceder a la adminstración de mi web: jmarquitecnic.es/wp-admin
Me sale error 404, cómo puedo arreglar problema desde Cpanel?

URL del sitio: Contenido solo visible a usuarios registrados

ResponderCitar
Respondido : 02/02/2014 8:31 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose Manuel,

¿Has mirado que dice la línea 17 del archivo wp-blog-header.php? Puedes hacerlo desde tu cPanel, Administrador de Archivos, Editor de Código.

¿Recuerdas haber instalado algún plugin antes de este error o haber realizado algún cambio de código?.

Saludos

ResponderCitar
Respondido : 03/02/2014 4:27 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

JOSE MANUEL
 JOSE MANUEL
Usuario activo

En las lineas 16 y 17 del archivo index.php me aparece:

/** Loads the WordPress Environment and Template */
require( dirname( __FILE__ ) . '/wp-blog-header.php' );

No sé qué debo substituir o añadir. Antes del error, instalé el Qtranslate para añadir idiomas, entre ellos el Español, Catalán, Inglés y ruso. La web funciona perfecto, puedo entrar y cambiar idiomas, pero en cambio al administrador no puedo entrar, el servidor me dice fallo 404, y enmensaje de Stephan me dice corregir error 500 según indiqué antes.

Espero respuesta.

ResponderCitar
Respondido : 03/02/2014 1:58 pm
JOSE MANUEL
 JOSE MANUEL
Usuario activo

En el archivo wp-blog-header.php lo que me aparece en la linea 17 es nada, la 16 tiene texto y la 18 un corchete:

16 require_once( ABSPATH . WPINC . '/template-loader.php' );
17
18 }

Pero los cambios deben realizarse en éste archivo o en el index.php?

ResponderCitar
Respondido : 03/02/2014 2:03 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Algo raro está pasando. Comentas que te está saliendo el siguiente error:

PHP Fatal error: require() [function.require]: Failed opening required '/home/jmarquit/public_htmlwordpress/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/jmarquit/public_html/index.php on line 17

Y en la línea 17 del archivo index.php tienes el siguiente código:

require( dirname( __FILE__ ) . '/wp-blog-header.php' );

Esto indica que dirname( __FILE__ ) tiene el valor /home/jmarquit/public_htmlwordpress, lo que no tiene mucho sentido, ya que tendría que ser /home/jmarquit/public_html que sería la ruta donde está el archivo.

Verifica que este error sea reciente y no tenga una fecha antigua. Dinos además si has movido tu WordPress de directorio o has instalado algún plugin de seguridad.

ResponderCitar
Respondido : 03/02/2014 5:14 pm
JOSE MANUEL
 JOSE MANUEL
Usuario activo

Hola, buenas, Lo que expones, es todo correcto. Esto es un error reciente, yo diría que me surgió después de pasar mi web de la URL temporal (jmarquit-cp92.wordpresstemporal.com) a la definitiva (jmarquitecnic.es) usando el archivo searchreplacedb2.php (El cual borré al finalizar) y además después añadí el Plugin de idiomas. La web se ve bien pero en el administrador no consigo entrar.

ResponderCitar
Respondido : 03/02/2014 10:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si existe un problema en la administración también debería existir información en el fichero error_log de la siguiente ruta: /home/jmarquit/public_html/wp-admin/error_log

Saludos.

ResponderCitar
Respondido : 04/02/2014 3:21 am
JOSE MANUEL
 JOSE MANUEL
Usuario activo

Lo que leo en el archivo error_log tiene muchas filas de dias atrás, pero de 1 de febrero que es cuando me sucedió el error, hay 6 filas largísimas, intento pegarlas:

[01-Feb-2014 10:00:41 UTC] PHP Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/jmarquit:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/jmarquit/public_html/wp-admin/includes/misc.php on line 166
[01-Feb-2014 10:06:25 UTC] PHP Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/jmarquit:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/jmarquit/public_html/wp-admin/options-permalink.php on line 132
[01-Feb-2014 10:06:25 UTC] PHP Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/jmarquit:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/jmarquit/public_html/wp-admin/includes/misc.php on line 166
[01-Feb-2014 15:53:46 UTC] Error Table 'jmarquit_pg1.snjbou_translations' doesn't exist de la base de datos de WordPress para la consulta ALTER TABLE snjbou_translations DROP PRIMARY KEY realizada por activate_plugin, do_action('activate_transposh-translation-filter-for-wordpress/transposh.php'), call_user_func_array, transposh_plugin->plugin_activate, transposh_database->setup_db
[01-Feb-2014 15:53:46 UTC] Error Table 'jmarquit_pg1.snjbou_translations_log' doesn't exist de la base de datos de WordPress para la consulta ALTER TABLE snjbou_translations_log DROP PRIMARY KEY realizada por activate_plugin, do_action('activate_transposh-translation-filter-for-wordpress/transposh.php'), call_user_func_array, transposh_plugin->plugin_activate, transposh_database->setup_db
[01-Feb-2014 16:54:21 UTC] Error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY timestamp ASC LIMIT 100' at line 1 de la base de datos de WordPress para la consulta SELECT original, lang, translated, translated_by, UNIX_TIMESTAMP(timestamp) as timestamp FROM snjbou_translations_log WHERE source= 0 and UNIX_TIMESTAMP(timestamp) > ORDER BY timestamp ASC LIMIT 100 realiza

ResponderCitar
Respondido : 04/02/2014 10:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

JOSE MANUEL
 JOSE MANUEL
Usuario activo

URL anterior: jmarquit-cp92.wordpresstemporal.com
URL nueva: jmarquitecnic.es

Efectivamente, tengo alguna copia de seguridad anterior (Si es que la hice bien!) pero yo diria que el error viene después de instalar el plugin de idiomas Qtranslate,que fué posterior al cambio de URL.

ResponderCitar
Respondido : 04/02/2014 11:15 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Prueba desactivando los plugins para verificar si permite el acceso:

Desactivar todos los plugins de Wordpress mediante phpMyAdmin
https://www.webempresa.com/blog/item/1222-desactivar-todos-los-plugins-de-wordpress-mediante-phpmyadmin.html

Saludos.

ResponderCitar
Respondido : 05/02/2014 12:28 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

JOSE MANUEL
 JOSE MANUEL
Usuario activo

Buenas, no he probado lo de desconectar plugins, pero he descubierto toqueteando, que si pongo: jmarquitecnic.es/admin, puedo entrar al administrador, y no con jmarquitecnic.es/wp-admin.

Puesto que cambié del temporal al URL definitivo: jmarquitecnic.es , puede ser correcto?

ResponderCitar
Respondido : 06/02/2014 12:18 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

No es lo habitual pero es probable que se utilice algún plugin para poder realizar este cambio.

Saludos.

ResponderCitar
Respondido : 06/02/2014 12:42 am

Cursos Gratuitos WordPress