iconos redes sociales en copyright  

 
Jon
 Jon
Usuario eminente

Buenos días:

Tanto con los iconos de las redes sociales originales como con los que he puesto hoy, me ocurre que se ven bien en la página de inicio, pero no cargan en ninguna otra página de la web.
Cuando empecé a trabajar con la plantilla se veían todos correctamente, pero de repente empezó a pasar esto sin que yo haya tocado nada de la configuración del "copyright". No lo he variado en ningún override, sino que sólo está en "default settings".

Gracias, un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 21/12/2014 12:50 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Jon.
Comprueba las direcciones de las imágenes:

Utiliza lo siguiente:
/wp-content/uploads/twitter32.png

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/12/2014 6:03 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jon
 Jon
Usuario eminente

Buenas tardes, Pepe:

Discúlpame, pero ni sé llegar a esos cuadros de comandos, ni entiendo el cambio que has hecho.
Además ya te he comentado que también dejaron de verse los iconos de las redes sociales que venían por defecto en la plantilla, el problema no está motivado por los iconos que he subido hoy.
Gracias, un saludo.

ResponderCitar
Respondido : 21/12/2014 6:22 pm
Jon
 Jon
Usuario eminente

Buenas tardes de nuevo, Pepe:
He seguido investigando (te adjunto pantallazo) y ya he visto el error en la parte inferior derecha.

En todas las páginas, al cargar los iconos de las redes sociales, usa la ruta ..../wp-content/uploads/twitter32.png y similares a partir de la propia dirección de la página en cuestión.
Como la página de inicio es www.goitorre.com pues la ruta coincide efectivamente con la del icono, en este caso
Cuando en el resto de páginas usa por ejemplo la ruta pues no encuentra el icono.

Lo que hay que hacer es que se encuentre en la página que se encuentre, al cargar los iconos, no intercale en la ruta ninguna palabra entre goitorre.com y /wp-content
Te pido por favor que la solución me la describas muy pormenorizadamente porque mis conocimientos de programación son nulos.
Gracias, un saludo.

ResponderCitar
Respondido : 21/12/2014 6:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jon,

¿Te has planteado otra alternativa?

- https://www.webempresa.com/blog/item/1645-iconos-de-redes-sociales-siempre-visibles-en-wordpress.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/12/2014 8:56 pm
Jon
 Jon
Usuario eminente

Buenas noches, Luis:

Te agradezco la alternativa, pero por ahora preferiría dejar los iconos en el copyright.
Confío en que haya alguna forma sencilla de modificar las rutas de los iconos, para que no tenga que subir cada uno repetido 15 veces, con una ruta por cada página.
Gracias, un saludo.

ResponderCitar
Respondido : 21/12/2014 10:06 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jon,

Ok, era solo una sugerencia 🙂

Veo que las imágenes de los iconos no parecen existir en la carpeta donde las busca el tema en uso:

Contenido solo visible a usuarios registrados

¿Puedes facilitar una captura desde el Administrador de Archivos de la carpeta /wp-content/uploads/ para revisarlo?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/12/2014 10:17 pm
Jon
 Jon
Usuario eminente

Así lo he entendido, no te preocupes.
Retomo lo que le decía a tu compañero. Los iconos están bien cargados en la ruta:

y similares para el resto de los iconos.

El problema es que cualquier página distinta a la de inicio está incluyendo su nombre de página en la ruta del icono, como por ejemplo:

Por esta razón no se cargan, mientras que en la página de inicio sí se ven correctamente.
Gracias, un saludo.

ResponderCitar
Respondido : 21/12/2014 10:27 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jon,

Quiero pensar que eso pasa porque estas usando la ruta absoluta hasta la imagen del icono en lugar de usar la url relativa /wp-content/uploads/twitter32.png de forma que sea visible independientemente desde donde se navegue por la web.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/12/2014 12:38 am
Jon
 Jon
Usuario eminente

Hola Luis:
Ya lo he solucionado. Adjunto pantallazo por si le ayuda a otro usuario.

En cada uno de los cuatro iconos, tras la expresión <img src=" y antes de wp-content.... he añadido /
Con eso ya funcionan.
Gracias, un saludo.

ResponderCitar
Respondido : 22/12/2014 12:25 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Gracias por el aporte. Hay que tener en cuenta que esta solución es válida cuando la web no carga desde un directorio. Es decir, sirve cuando la url es del tipo

www.nombredemiweb.com

pero no si es del tipo

www.nombredemiweb.com/prueba

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/12/2014 2:40 pm

Por favor Iniciar Sesión o Registro