Palene Theme Problemas  

 
Ángel
 Ángel
Usuario activo

Buenos días

Uso el tema palene theme desde hace 4 años o así cuando empecé el hosting con vosotros.
Estoy ahora mismo intentando introducir algunas mejoras. Me he encontrado con varios problemas.
A la hora de establecer una imagen de fondo para una página e intentar subir o buscar una imagen de la galería,
No encuentra ninguna imagen. Y al subir imagen desde wordpress da error no importa imagen o tamaño.
La única manera que he podido ha sido a través del cpanel vía administrador de archivos/ftp.
Otro problema que me pone en el admin es actualizar el php ha detectado que tu sitio está funcionando con una versión insegura de PHP...). Creo que probé hará un año actualizar el php pero se caía la página web. No se si este theme está preparado para las últimas versiones php (o no tan útlimas al menos).

El tema plantilla palene theme esta bastante obsoleto y si bien cuando empecé con él lo ofrecíais y vi que bueno se podía adaptar a lo que quería al principio. Ahora tengo más conocimientos de frontend html CSS y JS, y me gustaría migrar este tema a otro que se adapte más a lo que quiero y poder darle estilos y personalizar sin problemas. He probado en apariencia el cambio a los temas base de wordpress, vista previa, pero da error también (no se si es debido a la versión de php).

No se si seré el primero en preguntaros, a que theme migrar (teniendo palene theme) que se adapte más o se parezca en cuanto a widgets etc para que no diese demasiados problemas al cambiar de tema, mantener las mismas rutas url etc para que no repercuta en el posicionamiento SEO logrado en estos años.

Al estar hecho en Gantry 4, he estado investigando si Gantry 5 (algún tema en este framework) sería la mejor opción, no obstante, por lo que he leído cambia bastante. No se, si me podéis recomendar algún tema en concreto de wordpress y a qué se deben los problemas comentados.

Muchas gracias

Citar
Respondido : 03/11/2020 11:37 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Ángel, 

¿Podrías indicarnos la url del sitio web al que haces referencia? Para revisar tu caso es necesario que nos proporciones dirección web el sitio, por favor.

Saludos

ResponderCitar
Respondido : 03/11/2020 1:04 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ángel
 Ángel
Usuario activo

Buenas tardes,

https://strippersdeluxe.es/

Perdona, pensaba que os salía al introducir la url al principio.

Gracias.

ResponderCitar
Respondido : 03/11/2020 3:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Efectivamente Palene es un theme que usa Gantry 4, el cual esta obsoleto.

Revisa si al menos tienes la versión más reciente del plugin Gantry 4 que es la 4.1.21 para WordPress

Sino tienes esa versión puedes descargarla desde el final de esta página de descargas: http://gantry.org/downloads

Si queires cambiar de theme, adicional a cambiar el theme tendrías que desactivar también el plugin Gantry 4. También sería recomendable actualizar tu versión de PHP

Has evaluado usar algún theme con constructor incluído como Divi?, sin embargo si buscas algo más liviano, aunque con menos opciones de personalización puedes evaluar algún theme que use el framework Gantry.

Saludos.

 

ResponderCitar
Respondido : 03/11/2020 4:29 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ángel
 Ángel
Usuario activo

Hola,

Sí, tengo la versión más reciente de Gantry 4.

Cuando me recomiendas actualizar a la versión más reciente de php, ¿es ahora actualmente con este tema?

 

En cuanto a los problemas comentados, a qué se deben? El no poder cargar la imagen. O al intentar cambiar de tema, en vista previa aparece el siguiente error: Ha habido un error crítico en tu web. Por favor, revisa el buzón del correo electrónico de administración de tu sitio para instrucciones.

 

image
image
ResponderCitar
Respondido : 03/11/2020 4:58 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No, aún no actualices PHP si estas usando Gantry 4, ya que tendrás problemas.

Es posible que esos problemas los tengas debido a la versión de WordPress y la versión de PHP que tienes ya que es funcionalidad del core de WordPress.

En resumen:

  • busca un theme actual que se adapte a tus necesidades
  • Instala y activa el theme
  • Desactiva el plugin Gantry 4
  • Cambia la versión de PHP

Con esto verifica si todo funciona.

Saludos.

ResponderCitar
Respondido : 03/11/2020 5:05 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ángel
 Ángel
Usuario activo

Buenos días

1. Buscar un tema que se adapte a mis necesidades. Ok. Pero vosotros como proveedores en un inicio de este tema Palene Theme con Gantry 4 no me podéis recomendar ningún tema en la línea de este para no dañar el Seo a la hora de cambiar (A parte de divi, que ofrecéis actualmente)

2. Entiendo que el orden sería desactivar primero Gantry 4. Y luego activar el theme que quiera, ya que actualmente, la vista previa da error en apariencia al seleccionar otro tema, excepto con un tema de gantry 4 que he subido.

3. alguna recomendación para cambiar de plantilla, guía o algo, desde palene theme.

Muchas dudas todavía y la operación de cambiar de plantilla no va a ser fácil por lo que veo sin dañar el SEO conseguido.

Gracias

 

 

ResponderCitar
Respondido : 04/11/2020 10:26 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola angel.

Para el tema del seo no tendréis problemas ya que al ser la misma plataforma " WordPress ) las URL se respetan.

Lo que si te recomendaría es instalar WordPress en una carpeta independiente del dominio por ejemplo creas una carpeta con el nombre nueva e instalas wordPress en esa carpeta.

Una vez tengas instalado wordpress sería trabajar en esa instancia hasta tenerla como tu quieres, cuando este terminada se mueve a la raiz del dominio.

 

con eso consigues no arrastrar todo lo que tenías en anterior instancia y empezar con una instalación nueva y al mismo tiempo no tienes la web en producción parada mientras terminas de ajustar la nueva instalación.

 

Sobre los error veo algunos avisos que realmente no son error son avisos y no tendrías que tener problemas pero bueno, puede afectar.

[03-Nov-2020 18:57:50 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home/stripper/public_html/wp-content/plugins/nextgen-gallery/vendor/imagely/pope-framework/lib/class.component_registry.php on line 60

[03-Nov-2020 17:53:07 UTC] PHP Warning: Attempt to modify property of non-object in /home/stripper/public_html/wp-content/plugins/wp_rokcommon/RokCommon/Registry.php on line 369

Estos aviso hacen referencia a los plugin's nextgen-gallery y wp_rokcommon posiblemente por problemas con la versión de PHP pero no podrás cambiarla utilizando Gantry 4.

 

En tu caso lo mejor es empezar con una instalación nuevo y luego sería exportar el contenido que tienes de una a otra.

 

Sobre plantilla, bueno si quieres algo free en el repertorio de wordPress tienes muchas plantillas que puedes probar, por ejemplo para noticias:

-> https://es.wordpress.org/themes/tags/news/

 

Espero haber aportado un poco de Luz a tu consulta, si no es asi por favor indicalo par poder seguir ayudandote.

 

Un saludo

ResponderCitar
Respondido : 04/11/2020 10:56 am

Cursos Gratuitos WordPress

Ángel
 Ángel
Usuario activo

Hola Pepe,

Instalé wordpress en el dominio principal en una carpeta nueva llamada "pruebas" que está en public.html/pruebas/.

Entiendo que ahora tendría que copiar y pegar dentro de pruebas, lo que tengo en public.html para ir haciendo las pruebas oportunas o cambio de tema, en pruebas. Y una vez terminado y que el sitio funcione correctamente con nueva plantilla/theme, mover todo lo de pruebas a public.html.

¿Es correcto?

Muchas gracias.

ResponderCitar
Respondido : 04/11/2020 12:09 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angel.

Exacto, ahora es encontrar una plantilla que se adapte a lo que buscas y exportar el contenido qu etienes en la web en producción.

Para exportar el contenido puedes utilizar el siguiente plugin:

-> https://wordpress.org/plugins/export-media-with-selected-content/

 

Este plugin te permite exportar el contenido con las imagenes.

 

Un saludo

 

ResponderCitar
Respondido : 04/11/2020 12:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ángel
 Ángel
Usuario activo

Hola de nuevo,

Estoy en la principal para exportar todo a la de pruebas y al instalar el plugin me da error de Php.

"Este plugin no funciona con tu versión de PHP"

image

No se si hay otra manera de hacer? (descargar el public.html y subirlo a /pruebas) u otro plugin. A la vuelta es decir de pruebas (ya hecha) a la principal (html.public) con el php corregido imagino que ya podría hacerlo a través de este plugin.

Ángel.

ResponderCitar
Respondido : 04/11/2020 1:11 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@matamoroslopezgmail-com

Hola Ángel,

¿Realmente es necesario este plugin? Para realizar la exportación de contenido basta con las herramientas de Wordpress, disponibles en Herramientas -> Exportación. 

Saludos

ResponderCitar
Respondido : 04/11/2020 1:21 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación