No aparece en verde certificado ssl en la web  

 
Monica
 Monica
Reputable Member

Buenos días,
Lo primero de todo desear un Feliz año, solamente pido salud para poder hacer de todo.

Mi consulta es la siguiente, he seguido las indicaciones para el certificado SSL:

Desde mi cuenta en Hosting he instalado el certificado SSL, con www para que me tome www.serviflorfuneral.com y serviflorfuneral.com

He añadido en public.html/.htacess los siguientes datos

RewriteEngine On
RewriteCond %{ENV:HTTPS} !on [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://serviflorfuneral.com/$1 [R=301,L,NE]

Luego dentro de mis "Dashboard" he modificado en Ajustes/Generales los http por https.

Obteniendo como resultado que en en el acceso a mi wordpress me aparece en verde y el candado, pero a la hora de acceder a una pagina o entrada de mi tienda aparece el http pero no en verde y sin candado.

(Aporto captura de pantalla).

¿Que tendría que corregir o que estoy haciendo mal?

Un cordial saludo
Monica

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/01/2017 10:10 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Monica.

Si que te esta cargando el certificado, el problema viene por contenido como pueden ser imagenes o si tienes contenido procedente de otra web que no este cifrada.

Por ejemplo en la Home tienes el mensaje de Uso de Cookies con el enlace a hacia política de Cookies con una URL no cifrada:

<a href=" http://serviflorfuneral.com/politica-de-cookies/ " style="font-size:12px !important;line-height:12px !important">política de cookies

Como veras en ese enlace la URL es http://.
En la misma extensión de el Uso de Cookies veo otro enlace que tampoco esta cifrado:

plugin cookies

.

Esto puede pasar con imágenes o cualquier otro enlace hacia otra web que no este cifrada y es lo que tendrías que ir comprobando.

Por ejemplo las imágenes de las formas de pago:

<img class="wp-image-8633 aligncenter" src="http://serviflorfuneral.com/wp-content/uploads/2016/10/pago_seguro-300x46.png" 

Un saludo

ResponderCitar
Respondido : 03/01/2017 10:43 am

Cursos Gratuitos WordPress

Monica
 Monica
Reputable Member

Es decir, tengo que ir cambiándolos manualmente, ¿no?, pero ya me quedo mas tranquila sabiendo que está cargado y funcionando.

Muchas gracias
Un cordial saludo
Monica

ResponderCitar
Respondido : 03/01/2017 6:21 pm
Monica
 Monica
Reputable Member

Entonces, ¿como sería el proceso para modificarlo y me aparezca en verde?
Saludos
Monica

ResponderCitar
Respondido : 03/01/2017 6:23 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

La advertencia que te reporta el navegador y no te muestra el candado verde es por contenido mixto.
Es decir algunas urls de tu mismo dominio en tu sitio aún estan cargando con http en lugar de https

Si ves el código fuente verás varias url de tu dominio con http

Lo más rápido es realizar un reemplazo de estas urls

Buscar y reemplazar
Contenido solo visible a usuarios registrados

Puedes revisar el siguiente artículo para reemplazar urls en tu base de datos:
https://www.webempresa.com/blog/cambiar-wordpress-de-un-dominio-a-otro.html

Saludos.

ResponderCitar
Respondido : 03/01/2017 8:37 pm
Monica
 Monica
Reputable Member

Muchas gracias por la ayuda, me pongo en ello
Un cordial saludo
Monica

ResponderCitar
Respondido : 04/01/2017 10:49 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Monica, Buenos Días.

Si tienes problemas de contenido mixto en WordPress (cosas que cargan con HTTPS y otras no):
Una opción es utilizar el plugin SSL Insecure Content Fixer: https://es.wordpress.org/plugins/ssl-insecure-content-fixer/ . Este plugin está pensado para detectar la carga de contenido vía http y aplicar el cambio en el enlace de carga a https.

Una vez instalado y activado el plugin vete a Ajustes->SSL Insecure Content.
En el parámetro Fix insecure content selecciona el nivel de revisión que aplicará el plugin, de menos a más estricto. Puedes ir probando los diversos niveles de arriba a abajo, recargando el frontal después de cada cambio, hasta encontrar el que corrige el problema, aunque lo recomendable será la opción Widgets o, si esta sigue sin corregir el problema, Capture. El parámetro HTTPS detection se puede dejar con la opción standard WordPress function.

Otra alternativa sería el plugin Really Simple SSL: https://es.wordpress.org/plugins/really-simple-ssl/

Un saludo

ResponderCitar
Respondido : 04/01/2017 11:37 am