Problema con Ninja table  

 
Salvador
 Salvador
Nuevo usuario

Hola a todos, me permito preguntaros aquí porque no sé cómo resolver el problema.

ya he preguntado al Servicio de webempresa (soporte servidor) y me han dicho de preguntar en el foro.

El problemas es el siguiente:

actualmente tengo instalado el plugin Ninja table en la web para los productos de woocomerce.

Lo que pasa es que en algunos productos cuando pincho para verlo me sale : “error database no encontrado” o “error 503”.

el servicio técnico del servido ha podido comprobar que el error es el siguiente :

Por lo que veo en el error_log de PHP de tu WordPress, están quedando logueadas las siguientes líneas:
[19-Feb-2021 10:18:38 UTC] Error Table 'clicligh_xPikxLmA.wp_posts' doesn't exist de la base de datos de WordPress para la consulta SELECT ID FROM wp_posts WHERE post_name LIKE '60119%' AND post_type = 'product' AND post_status = 'publish' realizada por require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, redirect_canonical, redirect_guess_404_permalink

he hablado con el servicio técnico del plugin y me han dicho que puede ser un problema di caché.

Pero me parece raro .. yo creo que es más un problema de compatibilidad entre el plugin y el témplate.

por ejemplo si entráis en :

https://www.cliclight.com/flexos-led-integrado/

y probáis a pincha el primer “flexo wolly 3,5w “

Os saldrá el error

me podéis ayudar 

Contenido solo visible a usuarios registrados

Citar
Respondido : 20/02/2021 6:50 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Salvador,

Veo que el producto de Flexo Wolly 3,5w sí carga.  

¿Podrías proporcionarnos algún otro enlace de producto donde se produzca el problema? ¿Has probado si se repite el problema desactivando el plugin de Ninja Table y/o el de Varnish Caché? 

 

Saludos

ResponderCitar
Respondido : 20/02/2021 8:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Salvador
 Salvador
Nuevo usuario

@bulmaro-webempresa hola 🙋🏻‍♂️.. perdona pero no entiendo el porque si lo hago yo (borro toda la caché ) entrando en flexos led y luego wolly me salen muchos errores ???.

os envío un enlace del video que he hecho del error:

https://we.tl/t-F1ymEsz6Wk

He probado ha desactivar el cache pero nada sigue igual.

 

si yo pero (sin desactivar nada) entro en woocomerce directamente y voy en la categoría flexos y luego voy en el flexo Wally funciona perfectamente... 

El problemas es con el plugin 

ResponderCitar
Respondido : 21/02/2021 6:45 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Salvador.

No consigo reproducir el problema:

 

Lo único que veo es que tienes problemas de recursos, algún plugin esta sobre cargando el servidor:

[Sun Feb 21 13:40:16.772882 2021] [hostinglimits:error] [pid 3792216] 
mod_hostinglimits: Error on LVE enter: LVE(1198) HANDLER(application/x-lsphp73)
HOSTNAME(www.cliclight.com) URL(/index.php) TID(3792216) errno (7)


Esto es lo que esta provocando la caída y los errores que estas teniendo.

 

Si reviso un poco mas veo que tienes tablas en la base de datos con muchos registros que pueden estar provocando ese consumo:

ps_connections... tiene 626939 registros en la Base de Datos: clicligh_db
ps_guest... tiene 668854 registros en la Base de Datos: clicligh_db
ps_search_index... tiene 134725 registros en la Base de Datos: clicligh_db
wp_postmeta... tiene 274497 registros en la Base de Datos: clicligh_dev
ps_connections... tiene 162642 registros en la Base de Datos: clicligh_siYtSz
ps_guest... tiene 189531 registros en la Base de Datos: clicligh_siYtSz
ps_search_index... tiene 134853 registros en la Base de Datos: clicligh_siYtSz
wp_postmeta... tiene 450477 registros en la Base de Datos: clicligh_xPikxLmA
wp_relevanssi... tiene 128913 registros en la Base de Datos: clicligh_xPikxLmA
wp_yoast_seo_links... tiene 162173 registros en la Base de Datos: clicligh_xPikxLmA

 

Esto hace que la carga de la web sea lenta e incluso que en momentos pueda caer como nos estas comentando.

 

Personalmente empezaría por aplicar algunas optimizaciones en la web:

  • Instalar y activar wp-optimize:  https://www.webempresa.com/wordpress/como-mejorar-velocidad-wordpress.html#optimizaddbb  para ver que te indica a nivel de optimización bb.dd.
  • La aplicación tiene 38 plugins activos. Si bien no tiene por qué ser un problema en este caso cada plugin activo añade tiempos de carga y puntos de fallo a una web. Desactiva aquellos plugins que no sean imprescindibles para las funcionalidades de la web.
  • La tabla yoast_indexable ocupa más de 10mb. Puedes optimizarla instalando el plugin Yoast Test Helper, y luego en 'Herramientas -> Yoast Test' pinchar en el botón 'Reset indexables & migrations' Finalmente, en el menú de Yoast, hay que darle al botón 'Empieza el procesamiento y acelera tu sitio ahora'. Puedes mantener desactivado el plugin Yoast Test Helper cuando no necesites realizar la optimización.

Si que es verdad que el tema que estas utilizando no esta optimizado para WooCommerce y puede causar problemas de rendimiento.

 

Empieza por las recomendaciones que te indico y vamos viendo si mejora el rendimiento de la web.

 

Un saludo

 

 

 

ResponderCitar
Respondido : 21/02/2021 1:09 pm

Cursos Gratuitos WordPress