WP - Mimas: incorrecta visualización del menú en el carrito  

Página 1 / 2
 
Rafa
 Rafa
Usuario eminente

Hola de nuevo,
Continúo con el proceso de creación de mi tienda online. Comentaros que empecé con la plantilla Epimeteo, pero la he cambiado por la plantilla Mimas, ya que algo raro pasaba (problemas para modificar los widges que venían por defecto, tiempos de carga de la página de alrededor de 11 segundos :ohmy: ...)
Con el Theme Mimas no estoy teniendo ninguno de los problemas que tuve con Epimeteo.

Dicho esto, me está pasando algo curioso que espero me podáis ayudar a resolver. La visualización de la página en el carrito de compra no es correcta, ya que no mantiene los mismos parámetros que el resto de páginas por defecto. El menú se extiende por todo el ancho de la pantalla en lugar de 'quedarse dentro' del espacio definido para la página, y bajo el menú no respeta el color de fondo.
Adjunto dos pantallazos, de la página 'como comprar' que respeta la configuración correcta y la página del carrito, que no respeta las mismas reglas de diseño.

¿Qué debo hacer para que la página del carro de compra se visualice cómo el resto?
Gracias de antemano por la ayuda.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/04/2015 1:50 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Mª Carmen!

Para poder analizar el caso que nos comentas, tendrás que deshabilitar el modo mantenimiento.

Una vez deshabilitado, por favor avísanos para revisarlo.

Quedamos a la espera de tu colaboración.

Saludos

ResponderCitar
Respondido : 05/04/2015 2:00 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Rafa
 Rafa
Usuario eminente

Hola Rafael,
¡Pues esto es el colmo! Tengo instalado el plugging WP Maintenance, que hasta ahora ha funcionado correctamente , deshabilitándolo cuando lo necesitaba.
Pues bien, he entrado en la configuración deshabilitándolo primero en su configuración, y luego deshabilitando el pluging, pero ahora NO me funciona!!!
Aunque quite la opción del parking, ésta sigue saliendo. ¿Alguna idea?

ResponderCitar
Respondido : 05/04/2015 2:17 pm
Rafa
 Rafa
Usuario eminente

Creo que directamente voy a recuperar la copia de seguridad que tengo del XCloner, y que sé que no presenta este problema.
Os aviso en cuanto la web esté aoperativa.

ResponderCitar
Respondido : 05/04/2015 2:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rafael
 Rafael
Miembro Moderator

¡Hola Mª Carmen!

Por lo que nos comentas parece que tienes problemas de conflictos entre plugins y/o librerías.

Lo más práctico es que restaures una copia de tu sitio web como bien nos has indicado.

Si por lo que fuera, la copia del XCloner no funciona o no fuera suficiente, recuerda que puedes restaurar con la aplicación CPRemote desde tu cPanel.

Para mayor información, visita:

https://www.webempresa.com/blog/item/1718-restaura-tu-hosting-completo-con-cpremote-backup-management-en-cpanel.html

Quedamos a la espera de tu respuesta.

Saludos

ResponderCitar
Respondido : 05/04/2015 2:41 pm
Rafa
 Rafa
Usuario eminente

Bueno, pues ya está arreglado. Aunque comparto con vosotros lo que me ha pasado: la copia de seguridad que he recuperado presentaba el mismo problema. El parking no se desactivaba y me he dado cuenta de que el problema era que esta mañana había instalado WP Super Caché y después he hecho nueva copia con XCloner (cargándome la anterior). Así que he desactivado y desistalado el WP Super Caché y de esa forma el WP Maintenance funciona correctamente.

Bueno, ya puedes ver la página sin parking. Como verás, el problema sobre el que os hacía la pregunta sigue ahí: la página del carrito es diferente.

Gracias.

ResponderCitar
Respondido : 05/04/2015 2:49 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafael
 Rafael
Miembro Moderator

¡Hola Mª Carmen!

Para solucionar el problema que nos comentas accede al administrador de archivos de cPanel (midominio.com/cpanel)

> Bloque Archivos > administrador de archivos

A continuación navega hasta la ruta:

wp-content/themes/mimas_wp

Y renombra la carpeta woocommerce por woocommerce_old

Guarda los cambios y visualiza la página.

No te olvides de limpiar la caché en el caso de que sigas viendo lo mismo.

Saludos

ResponderCitar
Respondido : 05/04/2015 4:06 pm
Rafa
 Rafa
Usuario eminente

Hola Rafael, perdona mi ignorancia, pero ¿qué tengo que hacer para limpiar la caché?.

ResponderCitar
Respondido : 05/04/2015 6:42 pm

Cursos Gratuitos WordPress

Rafa
 Rafa
Usuario eminente

Hola,
He procedido a cambiar el nombre de la carpeta Woocommerce como me indicas. Además he limpiado la memoria caché de mi ordenador, y en el theme le he dado a Clear Caché también (en el botón general de la esquina superior derecha, y en el apartado de CSS). No sé si es a esto a lo que te referías con limpiar la caché.

El problema de visualización del menú sigue apareciendo, y además tengo un problema añadido con el carrito, ya que en lugar de aparecer el dibujo del mismo con la indicación del nº de productos y el enlace para ver el contenido, lo que se visualiza ahora es el contenido del mismo.
Así que he vuelto a dejarlo todo como estaba.

¿Alguna idea más sobre cómo solucionar el problema?
Gracias de antemano.

ResponderCitar
Respondido : 05/04/2015 8:28 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Vuelve a dejar el directorio woocommerce con el nombre que tenía.

Veo que vuelves a tener la tienda en mantenimiento. Tendrías que volver a quitar ese estado de mantenimiento para que podamos ver la web y analizar el código que se carga.

Dinos también si has añadido nuevos widgets por tu cuenta o eliminado alguno en la configuración de WordPress o sigues con los que venían por defecto con el pack.

ResponderCitar
Respondido : 06/04/2015 3:23 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Rafa
 Rafa
Usuario eminente

Hola Pablo,
Ya he dejado todo como estaba y quitado el parking. Con respecto a los plugins, he instalado los siguientes:
- Favicon by RealFaviconGenerator
- P3 (Plugin Performance Profiler)
-qTranslate-X, con su extensión WooCommerce & qTranslate-X
- Widget Visibility, para colocar un widget que sólo se vea en el blog (sus categorías)
- WP Maintenance, que ahora tengo desactivado
- XCloner. Este creo recordar que ya venía, pero sinceramente no lo recuerdo.
El CodeStyling Localization que viene por defecto lo tengo desahibilado.
Seguramente sean demasiados, no se si hay algún plugin capaz de agrupar algunos de ellos. Y tampoco sé si alguno de ellos crea incompatibilidades con el tema.
Gracias de antemano.
Mª Carmen.

ResponderCitar
Respondido : 06/04/2015 4:07 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Según veo el problema esta en :
Contenido solo visible a usuarios registrados

Tendrías que probar desactivando los plugins que has instalado, empezando por el de Widget Visbility y el de qTranslate-x para verifica si estos te estan dando problemas.

Si instalas un nuevo pack en una carpeta tienes el mismo problema en la pantalla de carrito?, con esto descartaríamos problemas del propio pack

Saludos

ResponderCitar
Respondido : 06/04/2015 6:26 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rafa
 Rafa
Usuario eminente

Hola Jhon,
He probado a desactivar los plugins. Primero el Visibility y el resultado seguía siendo el mismo.
Luego he desactivado sólo el WooCommerce & qTranslate-X y sin cambios.
Y luego he desactivado el paquete completo de qTranslate-X (qTranslate-X + WooCommerce & qTranslate-X) y no había cambios.
En todos los casos salía mal el carrito, totalmente desconfigurado.

Lo que no he probado es a cargar el pack en una nueva carpeta.
Sin embargo, se me ha ocurrido borrar la página del carrito y volver a hacer una nueva. Y entonces el problema se ha solucionado.
Tengo activos todos los plugins y el comportamiento de la web en todas sus páginas es el correcto. He dejado abierta la web para que podáis comprobarlo.

El problema que tengo ahora es que he marcado en qTranslate-X que el idioma principal sea el español, pero al cargarse la página se muestra en inglés.
¿Tengo que abrir un nuevo hilo para este tema o me podéis dar alguna solución en el actual?
Gracias.

ResponderCitar
Respondido : 06/04/2015 8:03 pm
Rafa
 Rafa
Usuario eminente

Hola otra vez,
El problema que tengo ahora es que no me funcionan el resto de enlaces que parten del carrito: actualizar carrito, aplicar cupón, ...etc

ResponderCitar
Respondido : 06/04/2015 8:11 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafa
 Rafa
Usuario eminente

Me rindo!!
Así es como está el asunto:
- Instalando el tema original en otra carpeta, se respeta el diseño en todas las páginas, incluido el carrito. Luego queda descartado un problema en la plantilla.
- Mi idea de borrar la página del carro y luego crear la página de nuevo está siendo un fracaso, ya que en modo edición entré por primera vez al carro de menara correcta; pero si salgo y vuelvo a entrar, no puedo. La nueva página de carro respeta todos los parámetros de la original, incluido el enlace permanente. ¿Por qué pasa? Ni idea. He probado a borrar el widget del carro y volverlo a poner y nada. No puedo acceder al contenido del carro.
- He vuelto a probar desactivando uno a uno los plugins que tengo instalados, y de nuevo sin resultados...

Si se os ocurre alguna cosa...
No me gustaría que tener que volver a empezar de cero ¡otra vez!
Os agradezco la ayuda.
Un saludo.

ResponderCitar
Respondido : 06/04/2015 10:24 pm
Página 1 / 2