Kallyas Wordpress, no deja subir imágenes a la librería multimedia: Error HTTP  

 
JUAN JOSE
 JUAN JOSE
Usuario activo

Al intentar subir cualquier imagen a la "Librería multimedia", durante la carga, aparece "Error HTTP". Si refresco la página veo que aparece un icono gris de documento, en lugar de la miniatura de la imagen, con el nombre de la imagen que dio error y con un peso inferior al de la imagen original.

Otra cosa que ha dejado de funcionar bien es la visualización de la mayoría de "Portfolio Items". De los 32 que tenía incluidos solo se ven bien los cuatro primeros. En el resto no se visualiza la imagen a no ser que la sustituya por una de las cuatro que utilizo en los portfolios que se ven.

He probado a actualizar el tema, he revisado los permisos de la carpeta "uploads" y de las carpetas que contiene, todas con permisos 755 y las imágenes que contienen tienen todas permisos 644. También he probado a desactivar todos los plugings. Nada ha resultado. Incluso ahora, al volver a activar los plugins me aparece en la parte de arriba siempre el mensaje "Add this site to IWP Admin panel" con la URL, Usuario y Key. También me ha cambiado el color principal del tema y al acceder a "Kallyas Options" para volver a poner el color correcto aparece solo el menú de opciones a la izquierda pero al clicar en cualquiera de las opciones todo aparece en blanco.

Estoy bastante desesperado porque la web es para un cliente muy importante para mi.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 11/10/2014 12:29 pm
Lorena
 Lorena
Miembro Moderator

Hola Juan José,

Realiza una revisión automática con nuestro asistente Stephan y revisa si te devuelve algún error. También puedes revisar si hay errores en el fichero Contenido solo visible a usuarios registrados

Respecto al mensaje de IWP Admin panel es del plugin, para que añadas esta web al administrador. Si no quieres utilizar este plugin, puedes desactivarlo y desinstalarlo.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/10/2014 2:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

JUAN JOSE
 JUAN JOSE
Usuario activo

Hola Lorena,

lo primero muchas gracias por la rápida respuesta. Lo segundo es que soy diseñador gráfico y de informática solo sé un poco de HTML, lo justo para defenderme haciendo páginas en WordPress.

He hecho una revisión como decías y aparece esto respecto a conservasemilia.com en "Revisión Error fatal:"

[11-Oct-2014 07:16:03 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486
[11-Oct-2014 07:22:12 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486
[11-Oct-2014 07:43:53 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486
[11-Oct-2014 07:54:03 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486
[11-Oct-2014 07:54:13 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486

Y en "Revisión Wordpress Instalados:"

Revise la directiva RewriteBase del fichero .htaccess de esta instalación de Wordpress, si la instalación de Wordpress está situada en la raíz de un dominio, ya sea adicional, subdominio, apuntado o dominio principal de la cuenta, lo correcto es que el RewriteBase sea /
Si no tiene problemas puede ignorar este aviso.
Directiva:
RewriteBase /conservasemilia.com/

He abierto el archivo error_log y hay un montón de errores, te copio los primeros, el resto se repiten:

[09-Oct-2014 23:37:18 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/load.php on line 287
[10-Oct-2014 09:55:07 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/load.php on line 287
[10-Oct-2014 12:00:02 UTC] PHP Warning: explode() expects parameter 2 to be string, array given in /home2/xznzjalj/public_html/conservasemilia.com/wp-content/themes/kallyas/admin/framework/function-vt-resize.php on line 44
[10-Oct-2014 14:24:29 UTC] PHP Warning: require_once(/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php): failed to open stream: No such file or directory in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486
[10-Oct-2014 14:24:29 UTC] PHP Fatal error: require_once(): Failed opening required '/home2/xznzjalj/public_html/conservasemilia.com/wp-includes/class-wp-image-editor-imagick.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/xznzjalj/public_html/conservasemilia.com/wp-includes/media.php on line 2486

No entiendo nada de estas tres cosas ya que, como te decía, no soy programador. Si me puedes decir qué es lo que tengo que hacer te lo agradecería.

Sobre el Plugin, lo tenía instalado, lo desactivé y al activarlo de nuevo es cuando aparece el mensaje que no se va. He intentado averiguar cómo añadir la web al administrador y no he sabido cómo hacerlo.

Estoy bastante desesperado porque al no entender nada de programación estoy hecho un lío.

ResponderCitar
Respondido : 11/10/2014 3:16 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan José,

Veo que el dominio Contenido solo visible a usuarios registrados

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/10/2014 4:15 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

JUAN JOSE
 JUAN JOSE
Usuario activo

Hola Luis,

sí, el dominio está como adicional. Es lo que me indicaron en Soporte para poder hacer una web en una ruta temporal. Ya existe una web (muy antigua) en conservasemilia.com, pero el cliente quiere mantenerla mientas no esté lista la nueva, por eso conservasemilia.com todavía no apunta a Webempresa.

He cambiado los valores que me dices en .htaccess pero al volver a acceder me aparece "404" con la pantalla en blanco. Los valores por defecto eran:

RewriteBase /conservasemilia.com/
RewriteRule ^index.php$ - [L]

Un saludo.

ResponderCitar
Respondido : 12/10/2014 1:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Los errores que se reportan son a nivel de wordpress , tienes actualizaciones de wp pendientes?

Revisa tambien si la ruta de imagenes es correcta, revisa :
https://www.webempresa.com/blog/corrige-la-ruta-upload-path-en-wordpress.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/10/2014 7:15 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

JUAN JOSE
 JUAN JOSE
Usuario activo

Hola,

leí el post que me indicas antes de reportar el error en el foro. Pensé que ese problema no me afectaría porque comencé a construir la web con la versión 4.0 de Wordpress. Tampoco lo probé antes porque vi que dentro de la carpeta "uploads" las imágenes están organizadas en carpetas por año y mes.

Aun así he instalado el pluggin que recomienda y el problema continua, no ha cambiado nada.

He optado por hacer de nuevo la web en otro subdominio temporal por si no puedo solucionar a tiempo el problema.

Un saludo.

ResponderCitar
Respondido : 12/10/2014 9:35 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan Jose,

Me comenta un Técnico de Soporte que te han corregido el archivo Contenido solo visible a usuarios registrados

Revisa si persiste el problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/10/2014 6:10 am

Cursos Gratuitos WordPress

JUAN JOSE
 JUAN JOSE
Usuario activo

Hola Luis,

el problema persiste. Anoche me curré de nuevo la web en otro subdominio temporal porque necesitaba tenerla lista hoy para que la viera el cliente. Me gustaría saber qué ha pasado por si me volviera a suceder, pero tampoco os quiero robar más tiempo.

Os seguiré preguntando más cosas sobre algún problema que sigo teniendo tras hacer el traslado de hosting.

Muchas gracias.

ResponderCitar
Respondido : 13/10/2014 9:28 am
David Noguera
 David Noguera
Miembro Admin

Hola Juan Jose, si el error sucede a raíz del traslado, te recomiendo que lo comentes vía ticket para que lo revisen los técnicos, les facilites datos de acceso a Wordpress y te dejen la web funcionando correctamente ya que forma parte del traslado gratuito que se realiza con la contratación.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/10/2014 1:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro