Avisos
Vaciar todo

[Resuelto] Al enviar formulario no aparece mensaje de enviado  

 
Ana
 Ana
Estimable Member

Hola, buenas tardes,

Tengo un problema con los envíos de los formularios (pasa con todos los formularios de la web) y con algo de desespero ya.

Los usuarios rellenan el formulario y al pulsar enviar aparece el círculo gris con una bolita blanca dando vueltas que da a entender de que está procesando el envio de ese formulario, pero el problema es que no sale de ahí, se queda enrocado y venga dar vueltas y vueltas, pero no aparece el mensaje de ha sido enviado correctamente, y los usuarios creen que no se envía y le dan múltiples veces.

Pero por que lo cierto es que todos los formularios se reciben correctamente y al acto, tanto el administrador como el cliente, lo he comprobado. 

Claro, está siendo un problema porque los usuarios al creer que no funciona bien y que no se ha recibido, vuelven a pulsar una y otra vez el boton enviar y se reciben muchos formularios de la misma persona seguidos (hoy de un usuario 18 formularios).. de locura...  😓

Que puede estar pasando?  Como lo puedo solucionar?

Quedo a la espera de vuestra ayuda y gracias por adelantado!

Ana

 

 

 

Contenido solo visible a usuarios registrados

Respondido : 16/03/2021 3:39 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana,

Haz realizado algún cambio reciente en tu sitio web o instalado algún complemento adicional? es posible que algún plugin este ocasionando el conflicto. Prueba desactivar todos los plugins y deja solo los requeridos por tu tema luego comprueba si al hacerlo el formulario se envía de forma correcta, si es así, ve activando uno por uno mientras vas probando hasta lograr cual esta causando el conflicto.

Verifica esto y nos comentas como ha ido todo

Un Saludo

 

Respondido : 16/03/2021 3:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ana
 Ana
Estimable Member

@karen

Hola Karen, como estas? 

Espero que muy bien. 🙂  Gracias por contestar tán pronto.

He desactivado todos los plugin menos los imprescindibles del theme y el contact form7 que es el que se utiliza para los formularios, y lo sigue haciendo.

Eso va a ser que no es.  🙁

Que puedo hacer o comprobar ahora?

 

Gracias 🙂

Ana

 

Respondido : 16/03/2021 3:57 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo que se generan errores javascript en esta url cuando se envía el formulario:

Contenido solo visible a usuarios registrados

Esta relacionado con el plugin de optimización autoptimize

Captura de Pantalla 2021 03 16 a la(s) 11.14.43

Prueba desactivando completamente ese plugin y verifica.

Saludos.

Respondido : 16/03/2021 4:15 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana
 Ana
Estimable Member

@jmarreros

Hola Jhon,

Tienes toda la razón es ese plugin, (Karen también decia que era un plugin) por lo visto no me fije al desactivar y activar todos en el autoptimize, porque efectivamente al desactibarlo solo él se ha visto que el que crea ese error.

Muchas gracias Jhon y karen.

Ahora que no lo activaré¿Como puedo suplir ese plugin?, es que existe un problema, que se llena la cache y cada cierto tiempo he de vaciarla y el autoptimize me avisaba de vaciar la cache cuando ocurre eso.

Gracias

Ana

Respondido : 16/03/2021 4:23 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana,

Si lo que deseas es limpiar la cache puedes probar usar el siguiente complemento -> https://es.wordpress.org/plugins/clear-cache-for-widgets/ tienes información sobre su uso en el siguiente articulo -> Contenido solo visible a usuarios registrados

Verifica si con este plugin el formulario no te genera error, ten en cuenta que tal vez no sea todo el plugin de Autoptimize el que cause el error si no algunas de sus configuraciones, prueba si configurando el plugin como se muestra en el siguiente articulo te sigue generando problemas -> https://www.webempresa.com/blog/autoptimize-wordpress.html

Un Saludo

Respondido : 16/03/2021 4:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ana
 Ana
Estimable Member

Hola Karen, 

Muchas gracias por tu rapidez y por tus consejos.

Me lo miro todo y a ver que le va mejor a la web.

Un abrazo y gracias de nuevo por ayudarme.

Cuidate mucho! 😀 

Ana

 

Respondido : 16/03/2021 4:49 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana,

Gracias a ti,  estamos muy felices en poder ayudarte 🤗 

Coméntanos si con esto podemos dar como solucionado el tema

Un Saludo 😊 

Respondido : 16/03/2021 4:52 pm

Cursos Gratuitos WordPress

Ana
 Ana
Estimable Member

@karen

Hola Karen,  si lo damos por solucionado. Gracias!!! 😀 👍 

Respondido : 16/03/2021 5:07 pm