Avisos
Vaciar todo

Error Yoast - Optimizar datos de SEO  

 
José Miguel
 José Miguel
Usuario activo

Al intentar realizar la acción Optimizar datos de SEO con Yoast para mi Wordpress, me salta el error "Failed to Fetch".

Ya he probado a resetear todo con Yoast Test Helper y volver a intentarlo sin éxito. Y revisando los errores en la consola Javascript, no consigo dar con la solución. Estos son los errores:

- Failed to load resource: the server responded with a status of 404 ()

- Mixed Content: The page at 'https://www.mejoress.com/wp-admin/admin.php?page=wpseo_tools' was loaded over HTTPS, but requested an insecure resource 'http://www.mejoress.com/wp-json/yoast/v1/indexing/prepare/'. This request has been blocked; the content must be served over HTTPS.

El error 404 no está entre los que Yoast explica cómo solucionar. Y el servicio técnico de Webempresa no encuentra explicación.

Para error de Mixed content...revisé todos los campos de esta guía: https://guias.webempresa.com/preguntas-frecuentes/contenido-mixto-tras-activar-ssl-web/&source=gmail&ust=1695573348972000&usg=AOvVaw1iFdVSdAeOOeyU4uBLEXD p"> https://guias.webempresa.com/preguntas-frecuentes/contenido-mixto-tras-activar-ssl-web/ , y en todos sitios parece estar bien puesto el HTTPS, así que ni yo ni el servicio técnico de Webempresa encontramos solución

Agradecería mucho cualquier ayuda!

Contenido solo visible a usuarios registrados

Citar
Respondido : 23/09/2023 8:19 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose Miguel, 

Una vez instalaste el plugin de Yoast SEO Helper seguiste el procedimiento de:

• Ve a tu panel de administración de WordPress > Herramientas (barra lateral) > Yoast Test
• Localiza la sección Yoast SEO y haz clic en los botones "Restablecer tablas indexables y migraciones", "Restablecer cálculo de palabras destacadas" y "Restablecer contador de enlaces internos".

Después de cada clic, la página se recargará para confirmar que cada reinicio fue exitoso.

Revisa algunas de las recomendaciones que mencionan en este enlace y nos comentan como va todo → Contenido solo visible a usuarios registrados

Verifícalo y nos comentas como va todo

Un Saludo 

ResponderCitar
Respondido : 23/09/2023 9:07 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

José Miguel
 José Miguel
Usuario activo

@karen

Hola, gracias por la respuesta. Pero sí, ya había hecho todo eso y me siguen saliendo los errores javascript que comento en la consola del explorador

ResponderCitar
Respondido : 23/09/2023 11:26 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola José Miguel,

Por curiosidad lo has vuelto a hacer? y has visto el enlace que te comparte Karen, la solución que proporciono el usuario:

We changed the URL to https under Settings > General and that resolved it.

Puedes compartirnos una captura de como tienes las url configuradas en Ajustes > general, también puedes verificar instalando y activando este plugin:

https://es.wordpress.org/plugins/really-simple-ssl/

Una vez lo hagas activas el forzar el ssl.

Un saludo 🖐️ 

ResponderCitar
Respondido : 24/09/2023 2:01 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

José Miguel
 José Miguel
Usuario activo

@argenis

Lo he vuelto a hacer ahora, y sin cambios

Pantallazo:

image

Instalé el plugin really simple ssl y parece que está el SSL pero saltan muchos warnings. De todas formas en Webempresa > Hosting > Certificados, estaban ya instalados

También adjunto pantallazo de los errores

image

 

ResponderCitar
Respondido : 24/09/2023 3:15 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Jose Miguel,

En algunos post de soporte mencionan que puedes verificar agregando esto en tu archivo htaccess:

Header add Content-Security-Policy "upgrade-insecure-requests"

Este lo encuentras en tu wepanel administrador de archivos > public_html > dominio > archivo .htaccess, verifica agregar en este esta línea de código al principio del archivo.

Verifica y nos comentas, un saludo 🖐️ 

ResponderCitar
Respondido : 24/09/2023 3:52 am

Cursos Gratuitos WordPress

José Miguel
 José Miguel
Usuario activo

@argenis

 

Después de agregar esa línea al HTAccess, parece que ha desaparecido el error de Mixed Content. Aunque ahora saltan 2 errores 404, pongo pantallazo

image
ResponderCitar
Respondido : 24/09/2023 6:32 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Miguel,

Comprueba si algún otro plugin no genera el error, para ello desactiva todos los plugins y deja activo solo los de yoast SEO, luego comprueba si no se muestra el error si es así ve activando uno por uno mientras compruebas cuál causa el conflicto.

Verifícalo  y nos comentas cómo va todo 

Un saludo

ResponderCitar
Respondido : 24/09/2023 10:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

José Miguel
 José Miguel
Usuario activo

@karen

Hola, no parece que sea un conflicto de plugins, desactive todos y se siguen produciendo los errores 404.

Según he podído leer en los foros de yoast, los errores 404 se deben a bloqueos:

"These status code 404 deals with requests that are blocked or unauthorized. This means that something in or in front of your website is blocking our requests to the WordPress API.

The Yoast plugin uses the WordPress REST API for several features, including the SEO data optimization process. Therefore, the pathway wp-json/yoast/v1/indexing/prepare/ is a request that our plugin makes to the REST API for scanning posts and index"

 

ResponderCitar
Respondido : 25/09/2023 2:29 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola José Miguel, 

No veo nada adicional que pueda generar el conflicto; sin embargo, prueba lo siguiente. Accede a tu cuenta de hosting → public_html → carpeta donde tienes los archivos de tu sitio web. 

Dentro de este ubica el archivo .htaccess y renómbralo a .htaccess_OLD

Una vez realizado accede a Ajustes → Enlaces permanentes y sin realizar ningún cambio pulsa el botón de guardar cambio. 

Luego de ello comprueba si puedes optimizar de forma correcta las opciones de Yoast SEO

Un saludo 

ResponderCitar
Respondido : 25/09/2023 4:14 pm

José Miguel
 José Miguel
Usuario activo

Hola, ya sí, muchas gracias!

Aunque después de hacer eso me desactualizó el PHP y no podía acceder a la página, tuve que actualizarlo a la versión actual desde la 5.6. Debo revisar si se ha desconfigurado algo mas?

 

ResponderCitar
Respondido : 25/09/2023 5:21 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose Miguel, 

Es correcto, revisa todo este funcionando de forma correcta en tu sitio web es posible que algún plugin se desactivara si no era compatible la versión PHP. 

Revisalo y nos comentas como va todo

Un Saludo 

ResponderCitar
Respondido : 25/09/2023 5:43 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress