Pagina My Account Woocommerce  

 
Artlex78
 Artlex78
Usuario eminente

Hola chicos os escribo, porque me surge el problema que en la página de woocommerce My_Account por defecto solo aparece en el registro los campos de email y contraseña, yo necesito que los usuarios al registrarse me den su nombre completo/DNI/Dirección/agregar archivo/Contraseña, etc... se que lo pueden luego agregar en su cuenta de usuario pero esa info es importante para mi desde el registro.

La pregunta es ¿como editar o agregar mas campos en el registro de usuario?
Adjunto pantallazo

Muchísimas gracias y quedo a la espera de sus comentarios

Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/08/2017 12:47 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola alexander.

Por defecto WP solo pide el correo y la contraseña, para añadir mas campos hay que modificar el core de WP, cosa que no te aconsejo o con un plugin.

Prueba la siguiente extensión ->Contenido solo visible a usuarios registrados

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 03/08/2017 1:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Artlex78
 Artlex78
Usuario eminente

Vale Pepe, muchas gracias lo pruebo!
Espero que no me de mucho la lata y te comento...
Sois unos crack 😉

ResponderCitar
Respondido : 03/08/2017 4:05 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola alexander.

Nada un placer Amigo, Gracias por tus palabras, hacemos lo que buena mente podemos y esta en nuestras manos.

Dejo el hilo en espero por si necesitas retomarlo.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 03/08/2017 4:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Artlex78
 Artlex78
Usuario eminente

🙁 Hola Pepe, buenos días,
Ya utilice el plugin que me pasaste"Users Ultra", y esta muy bien para el registro con las redes sociales pero a la hora de editar el perfil de los usuarios no me deja eliminar los campos como avatar, mensajes, videos, etc... a demás solo me deja integrar los registros para el newsletters con Mailchimp yo uso Mailrelay, leyendo vi que eras es mas para una comunidad de usuarios registrados y poca documentación de custumización. te voy adjuntar un pantallazo de los campos que quiero conseguir en la pagina de registro para que tengas una idea, y como te dije antes que también puedan registrarse con instagram, facebook & Google plus ademas de poder subir un archivo adjunto. Estoy hecho un lio, ya que todo esto como lo configuro luego con woocommerce? .

Muchas gracias y espero que puedas echarme una mano

Saludos
Alexander

ResponderCitar
Respondido : 08/08/2017 3:00 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola alexander.

Ok, puedes crear un registro con el plugin contact form7, despues seria modificar un poco el codigo para que se muestre el formulario creado en vez de el de woocommerce.

Te dejo informacion, si ves que tienes problemas en alguno de los pasos lo indicas y te ayudamos donde te quedaste.

http://seoaldia.com/personaliza-formulario-registro-woocommerce/

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 08/08/2017 4:04 pm

Cursos Gratuitos WordPress

Artlex78
 Artlex78
Usuario eminente

Buenos días Pepe,
Y perdona por ser tan pesado lo probaré y cualquier duda o problema te lo haré saber.
Otra cosita encontré indagando este plugin http://pieregister.com/ podrías echarle un vistazo a ver que te parece a ti como profesional? y darme tu respuesta objetiva ya que coo estoy iniciándome en esto como ya te haz podido dar cuenta, me da un poco de yuyu cualquier vulnerabilidad de seguridad

Muchas Gracias
Saludos

ResponderCitar
Respondido : 09/08/2017 9:51 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alexander.

Lo que veo es que se actualiza habitualmente, es mas la ultima es de hace 6 días, no creo que tengas problemas en utilizarlo.

https://wordpress.org/plugins/pie-register/

Revisando la lista de vulnerabilidades de este mes, no veo que se mencione:

Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en WordPress Gallery 4.2.1
Vulnerabilidad de Inyección SQL y Falsificación de petición en Sitios Cruzados (CSRF) en Photo Gallery
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Google Captcha 1.05
Vulnerabilidad de Inyección SQL en Better Search
Vulnerabilidad de Falsificación de Petición en Sitios Cruzados (CSRF) en Email Queue 1.0.0
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en BestWebSoft Google Maps 1.2.1
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Google +1 1.1.6
Vulnerabilidad de Almacenamiento de Secuencias de Comandos entre Sitios Reflejada (XSS) en WP Statistics < = 12.0.8.1
Vulnerabilidad de Inyección SQL Autenticada en WP Statistics < = 12.0.7
Vulnerabilidad XSS Autenticada en WP Statistics < = 12.0.9
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Responsive Lightbox Plugin
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en WordPress Download Manager < = 2.9.49
Vulnerabilidad de Navegación no Autenticada a una URL sin Validación previa en WordPress Download Manager < = 2.9.50
Vulnerabilidad de Falsificación de Petición en Sitios Cruzados (CSRF) y de Cambio de Configuración en YouTube Embed < = 11.8.1
Vulnerabilidad XSS Autenticada en WP-Members Membership Framework < = 3.1.7
Vulnerabilidad de secuencias de comandos de sitios cruzados (XSS) en y de Falsificación de Petición en Sitios Cruzados (CSRF) Paid Memberships Pro
Vulnerabilidad de Traversalización de Directorio Autenticada en Shortcodes Ultimate < = 4.9.9
Vulnerabilidad de Inyección SQL Autenticada en DSubscribers < = 1.2
Vulnerabilidad XSS Autenticada y de Falsificación de Petición en Sitios Cruzados (CSRF) en Responsive Lightbox by dFactory < = 1.7.1
Vulnerabilidad de Subida Arbitraria de Archivos en WP Hide & Security Enhancer < = 1.3.9.2
Vulnerabilidad de Falsificación de Petición en Sitios Cruzados (CSRF) y de Almacenamiento de secuencias de comandos entre sitios (XSS) en Arabic Webfonts
Vulnerabilidad XSS Reflejada en Vospari Forms < = 1.3
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Contact Form To DB 1.4.0
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en WP Donate 2.0.1
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Facebook Like Button 2.32
Vulnerabilidad de Falsificación de petición en sitios cruzados (CSRF) en Sender by BestWebSoft
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en PDF And Print 1.7.4
Vulnerabilidad XSS (Reflejada) en Simple Custom CSS and JS
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Portfolio 2.27
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Quotes And Tips 1.19
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Relevant Related Posts 1.0.7
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Social Essentials Social Stats And Sharing Buttons 1.3.1
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) y de Falsificación de Petición en Sitios Cruzados (CSRF) en CevherShare
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en Popup Maker Reflected
Vulnerabilidad XSS Reflejada en WP Live Chat Support < = 7.1.05
Vulnerabilidad XSS (Reflejada) en WP Mail Reflected
Vulnerabilidad de secuencias de comandos de Sitios Cruzados (XSS) en OptiMonk
Vulnerabilidad de Inclusión de Archivos Locales Autenticados (LFI) en WP Rocket < = 2.10.3
Vulnerabilidad XSS Autenticada en Task Manager Pro < = 1.3.1
Vulnerabilidad XSS Autenticada y de Inyección SQL en IBPS Online Exam < = 1.0
Vulnerabilidad XSS Autenticada en AffiliateWP < = 2.0.9
Vulnerabilidad de Subida Arbitraria de Archivos en WP Hide & Security Enhancer < = 1.3.9.2
Vulnerabilidad de Subida Arbitraria de Archivos en WooCommerce Catalog Enquiry
Vulnerabilidad XSS Autenticada en Event Calendar WD < = 1.0.93

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 09/08/2017 11:45 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro