Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

Problema al traducir página web  

 
María José
 María José
Nuevo usuario

Buenos dias,

 

Estoy tratando de traducir mi web al ingles usando TranslatePress (lo uso en otra de mis webs y me funciona perfectamente) sin embargo al instalarlo y hacer clic en "traducir sitio" la página a la que me dirige se me queda en blanco (la url que veo es la de editar la traducción). He realizado la consulta a soporte y me han informado que ha nivel servidor el plugin si que consume los recursos correctamente pero a mi se me queda en blanco la página. Imagino que debe de existir alguna incompatibilidad con algun otro plugin o con mi Wordpress.

 

He tratado de usar otros plugins (Polylang genera muchos errores con mi tema y no me dejaba guardar los cambios al ingles) y WeGlot no me encuentra en su listado de idioma el idioma ingles...

 

Actualmente tengo instalado Loco Translate para las cadenas más básicas pero quiero traducir la web al completo.

 

Me podéis ayudar? No se que puede ser el problema ya que aparentemente todo funciona correctamente.

 

Muchas gracias

Contenido solo visible a usuarios registrados

Citar
Respondido : 29/01/2023 10:40 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Maria José, 

En este caso entiendo que lo que deseas es traducir algunos textos que han quedado sin modificarse, en este caso puedes probar realizar estas modificaciones con un codigo en lugar de realizarlo con algun plugin, para realizar esto puedes seguir la siguiente guía que tenemos disponibles → https://www.webempresa.com/blog/traducir-o-reemplazar-textos-en-wordpress-a-traves-de-tu-function-php.html

Por otro lado, si utilizar Loco translate debe permitirte poder traducir los textos, ten en cuenta que plugins como Translatepress o Polyang funcionan para añadir diferentes idiomas en un sitio web, coméntanos si es esto últimos lo que necesitas añadir para revisarlo con mayor detalle. 

Un Saludo 

ResponderCitar
Respondido : 29/01/2023 2:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

María José
 María José
Nuevo usuario

@karen es esto ultimo lo que necesito, traducir el sitio web al completo.

 

Me podéis ayudar para saber que puede estar ocurriendo y porque se me queda la pantalla en blanco al tratar de iniciar la traducción? Gracias

ResponderCitar
Respondido : 29/01/2023 5:34 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Maria José, 

En este caso lo que veo es que tienes instalada la versión PHP 8.1 y puede ser que esté causando un conflicto con el plugin, prueba bajar la versión PHP a 7.4 y comprueba si con ello funciona de forma correcta. 

De igual forma verífica aumentar los parámetros PHP a lo máximo que permita tu cuenta y revisa si con ello carga la página de forma correcta, te comparto la siguiente guía donde explican como puedes modificar los parámetros de PHP → https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Verifica esto y nos comentas como va todo

Un Saludo 

ResponderCitar
Respondido : 29/01/2023 7:55 pm