Avisos
Vaciar todo

[Resuelto] Problema con integración de Printful con Wordpress + Woocommerce  

 
Rubèn
 Rubèn
Nuevo usuario

Hola, estoy creando una tienda de dropshipping con Woocommerce, Para ello tengo que integrar Printful con mi Wordpress ( https://materlingua.cat). Después de realizar todas las acciones, en el report del status que muestra el plugin de Printful me da el siguiente error:

WordPress Site URL >> If your currently setup WordPress site URL is redirected to another URL the integration might not work correctly. Typically this happens with incorrect http to https redirects. Go to Settings > General to fix this.

Espero que me ayuden a dar con el error.

Gracias.

Contenido solo visible a usuarios registrados

Respondido : 20/09/2022 11:44 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ruben.

.- Accede Ajustes -> Generales

.- Revisa las opciones Dirección de WordPress y Dirección del sitio (URL)

Las dos url tiene que ser https://tu_dominio.xxx

screenshot mary52.webempresa.eu 2022.09.20 13 26 51

 

Un Saludo

Respondido : 20/09/2022 12:27 pm

Cursos Gratuitos WordPress

Rubèn
 Rubèn
Nuevo usuario

@pepesoler

Hola Pepe, esta configuración la tengo bien desde el principio.

https://materlingua.cat en las dos casillas. He probado añadiendo las www, pero el fallo persiste.

Respondido : 20/09/2022 3:23 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ruben, 

Entiendo que estás utilizando el siguiente plugin para realizar la integración https://es.wordpress.org/plugins/printful-shipping-for-woocommerce/, si es así puedes probar configurar la siguiente opción y revisar que sucede cuando intentas guardar los cambios

image

De igual forma revisa lo que muestra la pestaña de status, si es posible envíanos algunas capturas de pantalla de esta forma podemos revisar con mayor detalle que sucede.

Un saludo 

Respondido : 20/09/2022 3:37 pm

Rubèn
 Rubèn
Nuevo usuario

@karen

Hola de nuevo. Pues sí, tengo instalado el plugin que comentas. Respecto a la casilla Disable SSL, la tenía sin seleccionar. Luego he probado de seleccionarla (dando luego a guardar) y sin cambios. También he cambiado en las casillas de Dirección de WordPress y Dirección del sitio (URL) el https por http, mientras la casilla Disable SSL estaba seleccionada.

Aquí te dejo pantallazo del Status del plugin Printashop

Printful Status

Por si sirve de algo, te dejo el report de salud del sitio de mi wordpress:

Lo corregible

mejoras recomendadas

 Lo correcto

NO problems

 

 

Respondido : 20/09/2022 4:21 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ruben, 

Entiendo, en este caso prueba forzar que tus URL carguen con https para ello puedes añadir los siguientes códigos en el archivo wp-config de tu sitio web 

define('FORCE_SSL_LOGIN', true); 

define('FORCE_SSL_ADMIN', true);

Antes de hacer cualquier cambio realiza una copia de seguridad del sito web o el archivo, de esta forma si se genera algún error puedes restaurarlo.

Si con ello no funciona envía un ticket a soporte para que verifiquen no se esté mostrando algún bloqueo del sitio web con el sistema de Printful

Revisa esto y nos comentas como ha ido todo

Un Saludo 

 
Respondido : 20/09/2022 5:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Rubèn
 Rubèn
Nuevo usuario

Abrí un ticket, tal como Karen me recomendó, y desde soporte me lo han solucionado desactivando una medida en el servidor que podría estar afectando.

Muchas gracias a tod@s!

Respondido : 21/09/2022 8:47 am