Avisos
Vaciar todo

[Cerrado] Problema configuración servidor para funcionamiento plugin Webp converter  

Página 2 / 2
 
Israel
 Israel
Usuario experto

Buenos días,

he instalado el plugin "Webp converter" en una web y me devuelve un problema de configuración del servidor para funcionar correctamente. Es este:

"Las solicitudes a las imágenes son procesadas por tu servidor pasando por alto a Apache. Cuando se cargan imágenes, las reglas del archivo «.htaccess» no se ejecutan. Ocasionalmente, esto solo se aplica a las extensiones de archivo conocidas: .jpg, .png, etc., y cuando, por ejemplo, se carga la extensión .png2, entonces las redirecciones desde el archivo «.htaccess» funcionan, porque el servidor no entiende este formato y no lo trata como archivos de imagen. Comprueba las redirecciones para los archivos .png (para los que la redirección no funciona) y para los archivos .png2 (para los que la redirección funciona correctamente). Cambia los ajustes del servidor para dejar de ignorar las reglas del archivo «.htaccess».

En este caso, por favor, contacta con el administrador de tu servidor.

También, intenta cambiar la opción «Modo de carga de la imagen» a otra diferente. Los problemas sobre la reescritura a menudo pueden ser resueltos ajustando esta opción en «Pass Thru». Puedes hacerlo en los siguientes ajustes del plugin. Después de cambiar los ajustes, recuerda vaciar la caché si usas un plugin de almacenamiento en la caché o la caché es a través del alojamiento.

---

Códigos de error: bypassing_apache"

La verdad que no tengo ni idea de lo que hay que hacer. Agradezco la ayuda.

Un saludo,

Israel

Contenido solo visible a usuarios registrados

Respondido : 15/06/2021 11:50 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Israel, 

Entiendo, en este caso para descartar has probado con el otro complemento que te mencione -> https://es.wordpress.org/plugins/webp-express/ puedes ver las opciones de su configuración en el siguiente artículo -> https://www.webempresa.com/blog/usar-imagenes-webp-wordpress.html

Verifica esto y nos comentas como ha ido todo

Un Saludo 

Respondido : 08/07/2021 12:42 pm

Israel
 Israel
Usuario experto

@karen Buenos días. Sí el plugin que me da el problema es Webp Express. La configuración del mismo está hecha basándome en la guía que me aportas pero aún así no funciona correctamente. Necesito solución para que la web muestre las imágenes en webp y no en jpg.

 

Un saludo,

 

Israel

Respondido : 09/07/2021 8:31 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Israel.

Habilitaste la opción de CDN ?

screenshot mary52.webempresa.eu 2021.07.09 15 48 47

Una vez habilitada regenera de nuevo las imagenes

screenshot mary52.webempresa.eu 2021.07.09 15 50 07

 

Una vez lo tengas selecciona la opción " Alter HTML "

screenshot mary52.webempresa.eu 2021.07.09 15 51 24

 

Otra opción podría ser con el plugin Sort Pixel, el problema de este plugin es que en su version free esta limitado a 100 imagenes

https://es.wordpress.org/plugins/shortpixel-image-optimiser/

 

De todas formas si no tienes prisa en las próximas version de WordPress 5.8 ya incorpora soporte paar imagenes WebP

-> https://make.wordpress.org/core/2021/06/07/wordpress-5-8-adds-webp-support/

 

Un saludo

Respondido : 09/07/2021 3:03 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Israel
 Israel
Usuario experto

@pepesoler Acabo de probar y me siguen saliendo errores en el test:

 

Testing "WebP Realizer" functionality

UPLOADS

Copying JPEG to uploads folder (webp-express-test-images/3PpAdW.JPEG). ok
We now have a jpeg stored here:
/home2/aparta33/public_html/grupolymant.es/wp-content/uploads/webp-express-test-images/3PpAdW.JPEG

Lets check that browsers supporting webp gets a freshly converted WEBP when a non-existing WEBP is requested, which has a corresponding source

Making a HTTP request for the test image (pretending to be a client that supports webp, by setting the "Accept" header to "image/webp")
Request URL: .webp
Response: 403 Forbidden

Response headers:

- server: nginx
- date: Fri, 09 Jul 2021 15:24:15 GMT
- content-type: text/html
- content-length: 199
- vary: Accept-Encoding
 
Body:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>403 Forbidden</title> </head><body> <h1>Forbidden</h1> <p>You don't have permission to access this resource.</p> </body></html>
The test FAILED
 
diagnosing
Examining where the .htaccess rules in the uploads folder points to.
*There are no redirect rule to webp-on-demand.php in the .htaccess!*{: .warn}
Here is the rules:

WebP rules in uploads:

File: /home2/aparta33/public_html/grupolymant.es/wp-content/uploads/.htaccess
NONE!
Requesting simple test script "wod2/ping.php". Result: FAILED
Requesting simple test file "wod2/ping.txt". Result: ok
Deleting test images

THEMES

Copying JPEG to themes folder (webp-express-test-images/sT7ktN.JPEG). ok
We now have a jpeg stored here:
/home2/aparta33/public_html/grupolymant.es/wp-content/themes/webp-express-test-images/sT7ktN.JPEG

Lets check that browsers supporting webp gets a freshly converted WEBP when a non-existing WEBP is requested, which has a corresponding source

Making a HTTP request for the test image (pretending to be a client that supports webp, by setting the "Accept" header to "image/webp")
Request URL: .webp
The remote request errored
cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received
The test FAILED
Why did it fail? It could either be that the redirection rule did not trigger or it could be that the PHP script could not locate a source image corresponding to the destination URL. Currently, this analysis cannot dertermine which was the case and it cannot be helpful if the latter is the case (sorry!). However, if the redirection rules are the problem, here is some info:

Diagnosing redirection problems (presuming it is the redirection to the script that is failing)

Running a special designed capability test to test if rewriting works with .htaccess files
Result: No, rewriting does not seem to work within .htaccess rules.
However, "mod_write" is enabled on your server. This seems to indicate that .htaccess files has been disabled for configuration on your server. In that case, you need to copy the WebP Express rules from the .htaccess files into your virtual host configuration files. (WebP Express generates multiple .htaccess files. Look in the upload folder, the wp-content folder, etc).
It could however alse simply be that your server simply needs some time. Some servers caches the .htaccess rules for a bit. In that case, simply give it a few minutes and try again.
Note that if you cannot get redirection to work, you can switch to "CDN friendly" mode and rely on the "Alter HTML" functionality to point to the webp images. If you do a bulk conversion and make sure that "Convert upon upload" is activated, you should be all set. Alter HTML even handles inline css (unless you select "picture tag" syntax). It does however not handle images in external css or which is added dynamically with javascript.

INFO FOR MANUALLY DIAGNOSING

System info:

- PHP version: 7.4.20
- OS: Linux
- Server software: Apache
- Document Root status: Available and its "realpath" is available too. Can be used for structuring cache dir.
- Document Root: /home2/aparta33/public_html/grupolymant.es
- Document Root: Available and its "realpath" is available too. Can be used for structuring cache dir.
- Apache module "mod_rewrite" enabled?: yes
- Apache module "mod_headers" enabled?: yes

Wordpress info:

- Version: 5.7.2
- Multisite?: no
- Is wp-content moved?: no
- Is uploads moved out of wp-content?: no
- Is plugins moved out of wp-content?: no
 

Image roots (absolute paths)

uploads: /home2/aparta33/public_html/grupolymant.es/wp-content/uploads
themes: /home2/aparta33/public_html/grupolymant.es/wp-content/themes
plugins: /home2/aparta33/public_html/grupolymant.es/wp-content/plugins
wp-content: /home2/aparta33/public_html/grupolymant.es/wp-content
index: /home2/aparta33/public_html/grupolymant.es

Image roots (relative to document root)

uploads: wp-content/uploads
themes: wp-content/themes
plugins: wp-content/plugins
wp-content: wp-content
index: .

Image roots (URLs)

WebP Express configuration info:

- Destination folder: separate
- Destination extension: append
- Destination structure: image-roots
(To view all configuration, take a look at the config file, which is stored in /home2/aparta33/public_html/grupolymant.es/wp-content/webp-express/config/config.json)

Live tests of .htaccess capabilities / system configuration:

Unless noted otherwise, the tests are run in wp-content/webp-express/htaccess-capability-tester.
WebPExpress currently treats the results as they neccessarily applies to all scopes (upload, themes, etc),
but note that a server might be configured to have mod_rewrite disallowed in some folders and allowed in others.
- .htaccess files enabled?: yes
- mod_rewrite working?: no
- mod_headers loaded?: yes
- mod_headers working (header set): no
- passing variables from .htaccess to PHP script through environment variable working?: yes
- Can run php test file in plugins/webp-express/wod/ ?: no
- Can run php test file in plugins/webp-express/wod2/ ?: no
- Directives for granting access like its done in wod/.htaccess allowed?: yes

.htaccess files that WebP Express have placed rules in the following files:

- /home2/aparta33/public_html/grupolymant.es/wp-content/webp-express/webp-images/.htaccess

WebP rules in webp image cache:

File: /home2/aparta33/public_html/grupolymant.es/wp-content/webp-express/webp-images/.htaccess
# Rules for handling requests for webp images
# ---------------------------------------------

# WebP Realizer: Redirect non-existing webp images to webp-realizer.php, which will locate corresponding jpg/png, 
# convert it, and deliver the freshly converted webp
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule (?i).*(\.jpe?g|\.png)\.webp$ /wp-content/plugins/webp-express/wod2/webp-realizer.php?xwp-content-rel-to-plugin-dir=x../&xdestination-rel-htaccess=x$0&htaccess-id=cache [E=WE_WP_CONTENT_REL_TO_PLUGIN_DIR:../,E=WE_DESTINATION_REL_HTACCESS:$0,E=WE_HTACCESS_ID:cache,NC,L]
</IfModule>


# Register webp mime type 
<IfModule mod_mime.c>
  AddType image/webp .webp
</IfModule>

Deleting test images
 
 
La verdad que no quiero probar con un tercer plugin para esto. Me gustaría que me ayudarais a solucionar la configuración de este.
 
Gracias y un saludo,
 
Israel
 
 
Respondido : 09/07/2021 4:29 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

WordPress 5.8 que saldrá a fin de este mes : https://make.wordpress.org/core/5-8/

Ya incluye nativamente soporte para webp, por lo que, puedes evitarte problemas de configuraciones varias y evaluar esperar a esta actualización.

Aquí hay detalles de webp en WordPress 5.8: https://make.wordpress.org/core/2021/06/07/wordpress-5-8-adds-webp-support/

Saludos.

Respondido : 09/07/2021 5:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis
 Luis
Nuevo usuario

Converter for Media

Este problema es por estar bloqueado algo en el servidor,..... lo que me han dito los del plugin y de assistencia,... mas es muy

raro pos hace una semana me trabajava bien,... ha hecho la migración de otro servidor y ahora esto.

Cuando estava en OVH se ha passado lo mismo, mas los del servidor han desbloqueado algo,.... aqui no lo hacen porquê?

Yo tengo la versión Pro. Me interessa lo del AVIF

Esta publicación ha sido modificada el hace 2 años por Luis
Respondido : 04/12/2022 6:07 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Luis,

Este tipo de ajuste es por temas de seguridad en el servidor, si tienes alguna duda sobre este tema te invitamos a consultar por ticket, recuerda que los temas de foro son individuales, si quieres asesoría sobre este tema puedes hacerlo en el que tienes abierto actualmente has verificado el complemento de webp express?

un saludo 🖐️ 

Respondido : 04/12/2022 8:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 2