Avisos
Vaciar todo

Problemas con la biblioteca de plantillas y bloques de ELEMENTOR PRO  

 
Carmen
 Carmen
Usuario experto

Buenos días,

Tengo un problema con las plantillas/bloques de Elementor Pro, cuando voy a añadir una en una página se queda colgado pensando y no carga.

He hablado con el soporte de Elementor pero no hay forma de solucionarlo. Me dijeron que fuera a Herramientas del pluguin y regenerara los archivos CSS y datos y actualizara biblioteca pero sigue sin funcionar...no se que pasa. 

El tema que estoy utilizando es el HUB de Liquid Themes. Ellos también tienen una biblioteca de plantillas y bloques, cuando los cargo, no me da problema. He hablado con ellos por si fuera un conflicto con el Theme pero me han dicho que seguro que es cosa de Elementor. Total, que estoy en bucle. No consigo solucionarlo.

Captura de pantalla 2022 03 02 a las 13.37.51

 

Contenido solo visible a usuarios registrados

Citar
Respondido : 02/03/2022 12:49 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Carmen, 

Al realizar un análisis en tu sitio web puedo ver que se está generando este error

[02-Mar-2022 13:23:25 UTC] PHP Fatal error: Uncaught TypeError: Argument 2 passed to Elementor\TemplateLibrary\Source_Local::on_save_post() must be an instance of WP_Post, null given, called in /home2/uniqueyo/public_html/instalacionesderiego.com/wp-includes/class-wp-hook.php on line 309 and defined in /home2/uniqueyo/public_html/instalacionesderiego.com/wp-content/plugins/elementor/includes/template-library/sources/local.php:1042

Este error parece estar relacionado con la base de datos, recientemente realizaste algún cambio en tu sitio web?, para verificarlo vamos a probar lo siguiente, ingresa a tu cPanel -> Administrado de archivos -> public_html dentro de este ingresa a la carpeta donde tienes los archivos de tu sitio web y editar el archivo wp-config.php

En este archivo debajo de la opción /*That's all, stop editing! Happy blogging. */ pega la siguiente línea de código 

define('WP_ALLOW_REPAIR', true);
image

Luego de guardar los cambios ingresa a la siguiente URL http://tudominio.com/wp-admin/maint/repair.php

Dentro de las opciones que se muestran puedes pulsar en Repair Database o Repair and Optomize Database, verás una cantidad de código vez hasta abajo y comprobar el mensaje que indique que se ha reparado. 

Screenshot   2022 03 02T101616.718
Screenshot   2022 03 02T101647.012

Accede nuevamente a tu cPanel, edita el archivo wp-config.php y elimina la línea que añadiste, revisa luego si con ello el sitio web funciona de forma correcta

image

Antes de hacer este procedimiento realiza una copia de seguridad de tu sitio web, de esta forma si se genera algún error puedes restaurarla

-> https://www.webempresa.com/blog/backups-wordpress-en-2-minutos-con-all-in-one-migration.html

Revisa esto y nos comentas como ha ido todo

Un Saludo 

 

ResponderCitar
Respondido : 02/03/2022 2:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carmen
 Carmen
Usuario experto

@karen hola!!

He seguido todo el proceso, la web funciona correctamente pero sigue pasando lo mismo con la biblioteca de elementor 😩 

 

No se si me puedes dar alguna otra indicación.

 

Gracias!!

ResponderCitar
Respondido : 02/03/2022 6:51 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Carmen, 

Una vez realizado este procedimiento verífica aumentar los parámetros de tu PHP al máximo permitido y comprueba si con ello te carga la opción de la plantilla de forma correcta. Puedes verificar como aumentar los parámetros de tu PHP en el siguiente enlace https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/#Parametros-PHP

Revisa esto y nos comentas como ha ido todo

Un Saludo 

ResponderCitar
Respondido : 02/03/2022 6:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Carmen
 Carmen
Usuario experto

@karen

He activado la última versión PHP (8.0) y he cambiado todos los parámetros, tampoco funciona..... 😥 

ResponderCitar
Respondido : 02/03/2022 7:14 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Carmen,

Disculpa si ya lo has hecho, pero no cambies la versión php, lo que comenta Karen es que aumentes los parámetros, pero no subas la versión PHP, trabaja con la 7.4 por ahora para verificar, ya que mientras más alta puede dar problemas de compatibilidad.

Un saludo 🖐️ 

ResponderCitar
Respondido : 02/03/2022 7:26 pm

Cursos Gratuitos WordPress

Carmen
 Carmen
Usuario experto

@argenis

Cambiado a la 7.4 y sigue pasando igual 😪 

ResponderCitar
Respondido : 02/03/2022 7:30 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Carmen, 

En este caso todo parece indicar un error directamente con Elementor Pro, una opción que puedes verificar es si algún plugin está ocasionado el conflicto para ello desactiva todos los plugins y deja solo activo el de elementor pro, luego verifica si las plantillas cargan si es así, debes ir activando uno por uno mientras pruebas cuál causa el conflicto

También puedes comprobar si el error se genera por el tema, para ello prueba activar uno predeterminado de WordPress y comprobar si con ello cargan las plantillas 

Otra opción que puedes probar es bajar la versión de elementor, para ello debes acceder a Elementor -> Herramientas -> Control de versiones y revertir a una versión anterio

Screenshot   2022 03 02T160711.985

Si con ello no funciona te sugiero contactes nuevamente con Elementor Pro, ya que este plugin es de pago no podemos comprobar que puede estar sucediendo

Un Saludo 

 

ResponderCitar
Respondido : 02/03/2022 8:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Carmen
 Carmen
Usuario experto

Y una pregunta, si instalo un tema de wordpress no se me desconfigurará todo lo que he hecho no?

ResponderCitar
Respondido : 03/03/2022 9:20 am
Carmen
 Carmen
Usuario experto

Ya lo he resuelto!!! 😊 

Era el plugin de HUB Portfolio, lo desactivé y funcionó, lo volví a activar y también funciona, misterios......

 

ResponderCitar
Respondido : 03/03/2022 9:35 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Carmen.

 si instalo un tema de wordpress no se me desconfigurará todo lo que he hecho no?

Solo es para probar si el problema viene de tu plantilla, una vez comprobado vuelves a activar la plantilla que tenias.

Prueba a reinstalar los dos plugins, descargas elementor y elementor pro y los reinstalas.

.- Accedes a tu cuenta de cPanel -> Administrador de archivos.

.- Accedes a la carpeta wp-content -> plugins y renombra los plugins de elementor y elementor pro.

.- Descargas el plugin de elementor y el de Elementor pro y los vuelves a instalar.

 

Un saludo

 

 

 

 

 
ResponderCitar
Respondido : 03/03/2022 9:44 am