Problemas en elección de URL con WPML con hosting WebEmpresa  

 
Ana
 Ana
Usuario experto

Hola,

Tengo problemas al querer escoger el modo de URL: www.midominio.com/en con el plugin de traducción WPML. Me da el error que adjunto en la imagen.
He consultado a dos bandas, al soporte WPML y al soporte WebEmpresa, que es el que finalmente me ha derivado y aconsejado a hacer la consulta a vosotros.

Según el soporte del hosting, todo esta correcto, después de corregir varias cosas que según iba haciendo tickets, se iban corrigiendo, como son;
-Revisión de reglas de seguridad
-Revisión de la memoria
-Limitaciones de petición por parte del plugin WPML
y creo que algunas mas...

Total, que como todo estaba correcto,consulté de nuevo al soporte de WPML con el problema ( fue al primero que consulte ) y después de varias acciones que me propusieron y no solucionarse, WPML me propuso incluso clonar (migrar) la web en un servidor de pruebas de ellos, para hacer pruebas de comportamiento y compatibilidad, mas al detalle y descartar 'falsos errores' que a veces da.
El resultado me lo han dado esta mañana y me dicen que en el hosting de pruebas, todo va normal y me lo han mostrado en dos link que han traducido y donde que se ve la terminación correctamente de la traducción también una captura de pantalla con el modo de URL escogido sin error.
Informándome de que el error, está relacionado al entorno/servidor y no a alguna configuración de wordpress o de WPML.
¿Que es lo que puede estar pasando, si en el hosting de prueba va con normalidad y cuando se hace en el hosting que tengo de webempresa da el error y me dicen que todo esta bien?

Agradecería mucho que me ayudarais, ya que llevo muchos días con esto.
Y ya parece que es mi ultima esperanza, la verdad.
Os doy las gracias por anticipado.

Ana

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/11/2018 11:23 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes adjuntarnos una captura de como tienes configurado los enlaces permanentes?

El error parece ser muy común: https://wpml.org/es/forums/topic/mensaje-parece-que-los-idiomas-por-directorios-no-funcionaran-2/

ResponderCitar
Respondido : 14/11/2018 2:50 am

Cursos Gratuitos WordPress

Ana
 Ana
Usuario experto

Por el mensaje del WPML entiendo que precisamente es la simple plain, la que no hay que usar, no? Nosotros lo tenemos montado con los nombres de las entradas.
Aquí te adjunto una captura de pantalla con los permalinks.
A ver que te parece.
Gracias, un saludo, Ana.

ResponderCitar
Respondido : 15/11/2018 11:13 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

La captura no se adjunto, puedes enviarla en formato .jpg para poderla verificar.

ResponderCitar
Respondido : 16/11/2018 2:44 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana
 Ana
Usuario experto

A ver ahora si puedes verlo 🙂

ResponderCitar
Respondido : 16/11/2018 7:13 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ana.

Veo que la configuración de los enlaces permanentes los tienes bien y que no tienes problemas de permisos en los archivos y carpetas.

Por lo que veo es un problema que les pasa a mas usuarios de WPML
-> https://wpml.org/es/forums/topic/error-parece-que-los-idiomas-por-directorios-no-funcionaran/

En esta entrada de la documentación de WPML dan posibles soluciones:
-> https://wpml.org/es/documentation-2/guia-de-inicio/configuracion-del-idioma/no-se-puede-activar-los-directorios-de-idioma/

Revisa y si después de realizar los pasos que se indican sigues con los problemas, indícalo para que podamos seguir ayudándote.

Un saludo

ResponderCitar
Respondido : 16/11/2018 1:11 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación