WPML problemas LINKS  

 
Ivan
 Ivan
Usuario activo

Hola chicos

Trabajo con WPML y DIVI instalados.

He solucionado la llamada de WPML al servidor, ahora el problema que tengo es que el buscador e muestra:

-La version /es/ cuando supuestamente, según pone en los settings del plugin, debería quedarse en la raíz.
-GRAVE. el buscador me muestra links que son 404 y parte los reescribe mal.

Expongo adjuntos.

Me gustaría saber si alguien tuvo ese problema y si me puede echar un mano.
Un saludo y gracias de antemano

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 18/12/2018 5:32 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Según la documentación de WPML puedes desactivar el directorio que se crea "/es" para el idioma por defecto, revisa: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Ten en cuenta que el cambio no es automático y podría tardar unos días en verse en Google.

Saludos.

ResponderCitar
Respondido : 18/12/2018 5:53 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ivan
 Ivan
Usuario activo

Hola Jhon.

Gracias por tu rápida respuesta.

Voy a probar eso, sin duda es acertado, y estuve a punto de hacerlo pero me surgieron dudas.

El articulo da dos opciones:

1-Archivo HTML. Que no se donde encontrar ese archivo en Cpanel. Buscado y rebuscado, incluos en WPContent/language y no puedo encontrarlo.

2-Una página pero esta opción me da que marque algo que no entiendo y no quería arriesgar. Dice así:

Ocultar intercambiadores de idioma en la página raíz

Significa que no va a mostrar las extensión /es/ ni los demás? Por que esta escrito en plural. Entiendo que NO va a mostrar ninguna de esas combinaciones:

thalassatour.com/es/
thalassatour.com/en/
thalassatour.com/fr/

Pues bien, esa opción tampoco interesa. Lo correcto seria:

thalassatour.com/ (para alojar el español
thalassatour.com/en/ (para alojar el ingles)
thalassatour.com/fr/ (para alojar el frances)

Que opinas tu Jhon?

Quedo atento.

Cordial saludo

ResponderCitar
Respondido : 18/12/2018 6:23 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Simplemente desmarca esta opción que se ve en la imagen adjunta.
"Usar directorio para idioma predeterminado"

Saludos.

ResponderCitar
Respondido : 18/12/2018 8:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ivan
 Ivan
Usuario activo

Hola Jhon

Bueno es que esa opción la activé esperando tu respuesta para ver que sucedía.

AHORA VUELVE A ESTAR DESACTIVADA pero persiste el mismo problema

La realidad es que los problemas que describía en el primer post SON los que tengo igual si desactivo la opción.

ES decir el buscador me esta mezclando INGLES/ ESPAÑOL y sobretodo y mas GRAVE me muestra el dominio raiz con /es/ y me redirige a un 404 ..

Que hago? cual es la solución activando y desactivando trabaja igual.

Expongo adjuntos.

Quedo atento a tu ayuda

ResponderCitar
Respondido : 19/12/2018 10:41 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ivan.

Tienes que dejar marcada esa opcion, eso lo que realiza es que el dominio principal, en este caso en español, se mostrara con la URL del dominio " tu_dominio.xxx " los demás idiomas se mostraran con su código de idioma " tu_dominio.xxx/en "

Las resultados en el buscador no son automáticos, es decir, tienes que esperar a que Google vuelva a rastrear la web para poder ver los resultado en el buscador, esto puede durar incluso meses, de pende ya de Google.

Para que no te de error si se accede desde tu_dominio.xxx/es una vez tengas seleccionada la opción de mostrar solo el dominio para el idioma principal, lo que puedes hacer es crear una redirección, es decir, si se accede a " tu_dominio.xxx/es " que redirija a " tu_dominio.xxx "

Redirect 301 /es  https://www.tu_dominio.xxx 

Un saludo

ResponderCitar
Respondido : 19/12/2018 11:44 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Ivan
 Ivan
Usuario activo

Hola Pepe.

Gracias por responder pero me estoy liando.

Jhon me dice que la desmarque

Tu me dices que la marque

WPML me dice que la desmarque.

Expongo foto de settings actuales y con la que tengo los resultados que explico a continuación

Ahora está desmarcada y bajo incognito la url que me muestra Chrome al buscar Thalassa tour es :

https://thalassatour.com/es (PORQUE ME TIENE QUE MOSTAR /ES/ si esta desactivada como dice plugin?)

AL clickar en el link a veces me redirige a dos opciones:

1- https://thalassatour.com
2- 404 error.

No se chicos estoy confundido la verdad.

ResponderCitar
Respondido : 19/12/2018 11:54 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ivan.

Jhon me dice que la desmarque
Perdona desmarcada, al marcarla lo que realiza es que muestra el idioma como una carpeta.

la url que me muestra Chrome al buscar Thalassa tour es : Contenido solo visible a usuarios registrados

Como te comente se solucionara la próxima vez que Gogole rastree tu web y puede pasar tiempo.
Si accedo la web veo que el Idioma español lo muestra bien sin el código del idioma por lo que esta funcionando sin problemas.

Para solucionar el tema del idioma puedes crear una redirección añadiendo lo siguiente al principio del archivo htaccess:

Redirect 301 /es  https://thalassatour.com 

Con esta redirección todo el que acceda a tu dominio con tu_dominio.xxx/es sera redirigido a tu_dominio.xxx

Un saludo

ResponderCitar
Respondido : 19/12/2018 12:38 pm

Cursos Gratuitos WordPress

Ivan
 Ivan
Usuario activo

Hola Pepe

Pongo de nuevo el 301 y me aseguro (aunque ya lo tenia puesto para que no diese 404)

La verdad es que es algo raro por que el navegador me está mostrando con 301 o SIN 301extensiones en ingles y en español y que te dirigen a 404.

Se te ocurre alguna explicación a eso Pepe?

ResponderCitar
Respondido : 19/12/2018 12:52 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ivan.

Lo que te muestra el buscador son los datos que tiene la ultima vez rastreo tu web.
Si lo reviso veo que Ultima vez que rastreo tu web fue el 9 de diciembre.

Los cambios en el buscador no son inmediatos, se actualizan cada vez que el robot de Google vuelve a rastrear tu web e incluso pueden pasar meses en poder ver los nuevos resultados.

Un saludo

ResponderCitar
Respondido : 19/12/2018 1:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ivan
 Ivan
Usuario activo

Ok Pepe

Entendido, cuestion de tiempo y pacienia

GRacias

ResponderCitar
Respondido : 19/12/2018 2:05 pm