Error en el logout  

 
Yolanda
 Yolanda
Usuario activo

Al hacer logout recibo el siguiente error:

SOME_ERROR_CODE - JFolder::create: A ruta non está nas rutas de 'open_basedir'

He leído los mensajes del foro y revisado el fichero configuration.php, limpiado la cache con los dos botones de CleanCache (por cierto, ¿qué diferencia hay entre estos dos botones?), he limpiado la cache expirada y la cache del navegador, etc y sigo igual. He probado en distintos navegadores.

Sin embargo, funciona bien cuando hago el logout desde una página con permisos restringidos. En ese caso me manda a la página de login con el mensaje de "Identifíquese primero".

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 20/11/2014 4:48 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes alguna actualización pendiente de Joomla?

Entiendo que has comprobado las rutas en tu archivo configuration.php

Revisa si tienes errores recientes en el archivo error_log de tu sitio

Tendrías que enviarnos algún usuario para probar

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/11/2014 5:29 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Yolanda
 Yolanda
Usuario activo

Puedes crear un usuario firmando el manifiesto y luego hacer logout desde el enlace Inicio, Manifesto, Contacto o Firmantes para que te de el error.
Si haces logout desde Mi perfil no da el error.
Una vez que hayas creado el usuario le daré privilegios de administrador para que puedas acceder al backend.

ResponderCitar
Respondido : 21/11/2014 2:36 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Entiendo que el problema es en el formulario de acceso, puedes crearnos un usuario con privilegios de registrado y adjuntarlo para realizar una prueba, no de administrador ya que nosotros no ingresamos a la administración de los clientes.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/11/2014 2:51 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Yolanda
 Yolanda
Usuario activo

Puedes usar el Contenido solo visible a usuarios registrados

El formulario de acceso es el módulo normal que genera joomla automáticamente sin tocarle nada, ya que lo he vuelto a hacer por si el problema era ese.

Tengo como unas 10 webs con vosotros y no es la primera vez que tengo este problema (juraría que en todas) ¿Cómo lo resolví las otras veces? no lo sé, lo he intentado buscando información en internet y al final lo he dejado por imposible y simplemente he quitado la opción de login de las pantallas donde me daba el problema.

Tengo la vaga idea de que la primera vez que me pasó encontré en alguna web la respuesta de que había que cambiar algo en un plugin o desactivarlo. Desde entonces sigo buscando la página para ver que es lo que tenía que cambiar y nunca más la he vuelto a encontrar ni he encontrado otra información por el estilo.

ResponderCitar
Respondido : 21/11/2014 9:42 am
Yolanda
 Yolanda
Usuario activo

Lo que tengo en el configuration.php es lo siguiente:

public $log_path = '/home/clinicaq/public_html/pemm/logs';
public $tmp_path = '/home/clinicaq/public_html/pemm/tmp';

Si voy a actualizar Joomla me dice:
Sin actualizaciones disponibles
Ya dispone de la última versión de Joomla!, 2.5.27.

En el log sólo tengo errores de usuario o contraseña incorrectos

ResponderCitar
Respondido : 21/11/2014 11:34 am

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que se tratase de un problema con los permisos de algún directorio de tu Joomla. He ejecutado un Stephan en tu cuenta y parece que el problema ha quedado solucionado.

Realiza pruebas para comprobar si a ti te funciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/11/2014 11:51 am
Yolanda
 Yolanda
Usuario activo

Gracias Pablo, Jhonny y Jhon, pero ninguno encontrasteis la solución. :laugh:

Yo ya había ejecutado el Stephan y nada que ver. Es algo increíblemente sencillo, tan sencillo que siempre se me olvida y prácticamente me pasa en todos los Joomlas que instalo con vosotros.

Siempre busco en los foros y sólo encuentro lo de los paths.

Siempre creo recordar que es algo de un plugin y me vuelvo loca buscando que plugin desactivar o cambiar. Busco por login, por logout, por log, por user... y nada. Al final acabo leyendo uno a uno todos los plugins y por fin lo encuentro.

Así que ahora lo voy a dejar aquí anotado para que ni yo ni nadie vuelva a perder varios días en esta chorrada:

Hay que desactivar el plugin: SISTEMA - DESCONECTAR

Tengo que mirarme el alzheimer 😉

ResponderCitar
Respondido : 21/11/2014 12:18 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Entiendo que te refieres al plugin Sistema - Cerrar sesión. Es extraño, porque en otros Joomla donde he realizado pruebas no se produce el error aunque el plugin esté activado.

En todo caso, gracias por el aporte. Puede servir de utilidad a otros usuarios.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/11/2014 1:05 pm
Yolanda
 Yolanda
Usuario activo

En mi joomla (2.5) se llama Sistema - Desconectar. Te copio/pego del propio plugin:

Sistema - Desconectar
Estado Deshabilitado
Acceso Público
Orden
Tipo de plugin System
Archivo del plugin Logout

Descripción
El plugin de desconexión habilita la redirección del usuario a la página de inicio, si se desconecta de una página de acceso protegida.

Está claro porque SÍ me funcioinaba bien el logout desde las páginas de acceso restringido. El problema es que no funcionaba en las otras. Es posible que empezara a fallar al añadir una página no pública en el menú. ¿En las que tú probaste todas las páginas eran públicas?

ResponderCitar
Respondido : 21/11/2014 9:41 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En las pruebas que había hecho tenía páginas tanto de acceso público como privado, y me funcionaba cerrando sesión desde cualquiera de las 2.

Me extraña que esto sea un problema global de Joomla con un cierre de sesión desde una página determinada (acceso público o privado) ya que, de ser así, tendría que haber encontrado mucha información al respecto, o tendría que ser un bug que ya tendría que haber sido parcheado.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/11/2014 12:15 pm
Yolanda
 Yolanda
Usuario activo

Estoy de acuerdo contigo en que es raro que a mi me pasara tantas veces y a pocas personas más (ya que no hay muchos mensajes con este problema). La primera vez fue en Dic/2013 (Joomla! 2.5.14 según el cPanel) y desde entonces en casi todas las webs que he hecho con Joomla! 2.5. Siempre con el Pack Joomla Webempresa, 2.5.
Te avisaré cuando me vuelva a pasar, aunque estaba pensando en pasarme al 3.
Un saludo,
Yolanda

ResponderCitar
Respondido : 24/11/2014 1:10 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Sí que será buena opción que en breve te plantees cambiar a Joomla 3. Ten en cuenta que Joomla va a dejar de dar soporte oficial para Joomla 2.5.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/11/2014 3:01 pm

Por favor Iniciar Sesión o Registro