Aplicar Tema en multitienda  

 
Jose
 Jose
Usuario experto

Hola

En mi caso tenemos una multitienda, dentro dos tiendas cobres.es para mayoristas y sabela.es para minoristas. Como estoy cambiando la versión, por ahora trabajo en un subdominio: nuevo.cobres.es.

Después de subir una nueva plantilla (es gratuita, no del catálogo) y de asignarla a una de las tiendas, a cobres.es, al ir a la web se veía bien, pero en cuanto me puse a trabajar un poco con módulos, la web perdió el formato, intenté volver a la plantilla original, pero no cambiaba. Después de unos días, he vuelto a ponerme y ahora directamente nuevo.cobres.es me pone: Esta página no funciona. La página nuevo.cobres.es no puede procesar esta solicitud ahora. HTTP ERROR 500

No tengo ni idea de que he hecho mal, algo será, pero no consigo saber qué es, renombre el archivo .htaccess y comprobé si iba bien, pero nada, lo volví a dejar como estaba. Desactivé el módulo que recordaba haber instalado Prestashop Migrator, pero tampoco. Desactivé varios módulos más, y nada.

Al probar a cambiar el tema al predeterminado, no me dejó dar a sí y al cancelar el backoffice me dio ERROR 500 y tuve que restaurar a una copia de seguridad. Al acceder otra vez, el tema predeterminado era el activo. la web sigue dando ERROR 500.

A ver si me podéis ayudar, porque no sé qué hacer.

Gracias

Citar
Respondido : 13/09/2020 2:02 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola José,

Veo ahora que tu sitio web no se muestra, puedes indicarnos cuales módulos estas usando y como se llama la plantilla que usas en tu sitio web?

De manera general puedes probar desactivar los últimos módulos que instalaste y configuraste, para ello puedes ingresar en tu cPanel -> Administrador de Archivo, una vez dentro puedes ingresar a tu public_html y luego la carpeta del subdominio donde tienes los archivos de tu web, ubica la carpeta modules y renombrar los módulos por ejemplo nombremodulo_OLD

Luego comprueba si con esto el sitio web carga nuevamente, nos comentas como ha ido todo

Un Saludo  

ResponderCitar
Respondido : 13/09/2020 2:59 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario experto

Hola

Probé a ir desactivando los módulos uno a uno y comprobando si funcionaba la web, pero nada, cuando ya tenía desactivados la mayoría, empezaron a darme error al desactivar y después de varios errores, el backoffice volvió a darme ERROR 500, tuve que volver a restaurar, seguí desactivando y comprobando los que me habían quedado y no conseguí que la web funcionara.

Supongo que la web dejaría de funcionar por otro motivo. 

Te informo del tema: Diana - http://www.prestabrain.com/product/pts-diana/

Lista de Módulos: Llevaba tiempo con esta web algo aparcada, recordar ahora los módulos instalados es complicado. Además de los ya instalados con el Prestashop recuerdo haber añadido:

Prestashop Migrator - Free version v.1.0.1 de ETS-Soft

Aunque no me acuerdo, puede ser que los módulos de PrestaBrain los haya añadido yo, o se añadieran con el tema (que no sé si esto es posible), serían:

Panel de control temático PTS v1.6.0 de PrestaBrain

Ps Megamenu v2.5.0 de PrestaBrain

Productos en la misma categoría v1.0.1 de PrestaBrain

Ps Blog Management v3.0.0 de PsTheme

Ps page Builder v5-0-0 de PrestaBrain

Ps Slider Layer para su página de inicio v1.0.0 de PrestaBrain

 

Espero que esto os pueda ayudar. Gracias.

Un saludo

ResponderCitar
Respondido : 14/09/2020 12:28 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Comprueba si los permisos de tu carpeta var esta correctos por ejemplo 755, para ello ingresa a tu cPanel -> Administrador de archivos y luego en public_html

Una vez dentro de el ubica la carpeta donde tienes los archivos de la web y comprueba los permisos de tus carpeta, también es posible que el error este directamente relacionado con la plantilla ya que su ultima actualización fue en 2018.

También verifica el archivo error_log usualmente dentro de este se muestras los errores que esta ejecutando la web y cual modulo pude estar ocasionando este error, si ves los errores puedes adjuntarnos el archivo, de esta forma podremos comprobar que puede estar sucediendo.

Quedamos muy atentos como ha ido todo

Un Saludo

ResponderCitar
Respondido : 14/09/2020 6:35 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario experto

Hola

Los permisos de las carpetas dentro de Nuevo, son todos 755 y los archivos 644.

Hay un error500.html: 

Error500

Y error_log:

 

También pensé que podía ser el tema, por eso volví al predeterminado:

Pantalla tema Cobres Nuevo

 

Gracias

ResponderCitar
Respondido : 14/09/2020 11:09 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose, 

Veo que algunos de los errores son por la plantilla, verifica la versión de tu php y prueba colocandola a 7.0 luego comprueba si te carga.

También puedes evaluar restaurar una copia del sitio antes de instalar esta plantilla, es este articulo te comentas como puedes realizarlo -> https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/#restaurar-web

Un Saludo

 

ResponderCitar
Respondido : 14/09/2020 1:23 pm

Cursos Gratuitos WordPress

Jose
 Jose
Usuario experto

Hola

He cambiado la versión de PHP a la 7.0 y nada.

Entré en Superbackup para restaurar a la fecha en que subí la plantilla, 18 de agosto, pero he parado, nunca hice una restauración que no fuese de la web completa, pero ahora no puedo hacer una restauración completa, ya que afectaría a las webs principales que está en funcionamiento. Sólo tengo que restaurar la web de la carpeta public_html/nuevo.

Seguí el enlace que me mandaste, pero algunas pantallas son distintas y tengo dudas, así que opté por parar. Cambié a la pestaña "Restauración parcial" pero de los ficheros que carga no veo public_html/nuevo. 

¿Me podrías decir cómo restaurar solo esa carpeta?

En caso de que esto no se pueda hacer ¿Puedo eliminar la carpeta nuevo y volver a empezar con la instalación de Prestashop 1.7 desde 0?

Gracias

ResponderCitar
Respondido : 14/09/2020 7:17 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola José,

En este caso te comparto una guía mas actualizada: https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html , es de este mismo año con algunas opciones modificadas, también tienes una sección dentro del contenido que habla de como restaurar un fichero en especifico.

Un saludo 🖐️ 

ResponderCitar
Respondido : 14/09/2020 7:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose
 Jose
Usuario experto

Hola Argenis

Gracias por el enlace, ya he podido restaurar la carpeta nuevo y por fin la web me funciona.

Gracias a todos por la ayuda.

ResponderCitar
Respondido : 15/09/2020 10:38 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola José,

Excelente, me alegra que nuestra ayuda te fuera de utilidad y pudieras corregir el problema.

Gracias a ti por consultarnos en el foro, nos leemos pronto.

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 15/09/2020 11:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario experto

Hola,

Simplemente quería comentar cuál fue el problema que provocaba el fallo en la web, se trataba de dos plugins de Prestabrain (siento no recordar los nombres) que son del tema que tengo instalado Diana. Tengo tres que parecen no dar problemas: panel de control temático PTS, Ps Megamenú y Productos en la misma categoría.

Espero que así pueda ayudar a alguien que se encuentre con este mismo problema.

Muchas gracias.

ResponderCitar
Respondido : 16/09/2020 11:55 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Muchas gracias por el aporte, estoy segura que le será de utilidad a alguien que presente el mismo problema.

Un Saludo 😊 

ResponderCitar
Respondido : 16/09/2020 11:56 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro