Avisos
Vaciar todo

corregir errores w3c  

 
FRANCISCO
 FRANCISCO
Reputable Member

Buenos días,
Realizando una inspección de mi web, encuentro los siguientes errores:

Error : tdetiqueta de inicio en el cuerpo de la tabla.
A partir de la línea 32 , columna 386 ; a la línea 32 , columna 469
th:100%;">

<div i

Podéis decirme como repararlo y que ficheros son los que están mal?
Donde he de colocarl el icono para apple ¿que archivo es el raiz de mi web?
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/12/2016 8:29 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que buena parte de estos problemas estén causados debido a que se está comprimiendo el código html.

Prueba a ir en la administración de PrestaShop a Parámetros Avanzados->Rendimiento y desactiva el parámetro Reducción del código HTML.

Una vez hecho esto, vuelve a pasar el validador y comprueba si los resultados han mejorado.

ResponderCitar
Respondido : 19/12/2016 12:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

FRANCISCO
 FRANCISCO
Reputable Member

He desactivado la opción Reducción del código HTML pero sigue igual, y ahora se ha desconfigurado una página (paso imagen)

ResponderCitar
Respondido : 21/12/2016 8:23 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No cuadra que desactivando el parámetro Reducción del código HTML se desconfiguren las páginas, en todo caso tendría que ser al revés.

Prueba a volver a ir a Parámetros Avanzados->Rendimiento y pulsa en Vaciar el caché. Si sigue fallando. De ser así, vuelve a activar el parámetro Reducción del código HTML, aunque con esto activado es más complicado depurar los errores de W3C.

Lo que veo ahora que el código está estructurado es que dentro de head se están cargando elementos que tendrían que estar en el body. En concreto parece que está causado por el módulo que estás utilizando para mostrar el aviso de uso de cookies. Prueba a desactivar el módulo y vuelve a pasar el validador.

ResponderCitar
Respondido : 21/12/2016 2:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

FRANCISCO
 FRANCISCO
Reputable Member

Limpiada cache y desactivado módulo coockies, sigue igual
adjunto imagen

ResponderCitar
Respondido : 21/12/2016 2:24 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando el código fuente de la web sigo viendo el código que te comentaba cargando en el head, y que tendría que cargar en el body. Es el siguiente:

PREX utiliza cookies propias y de terceros para analizar el tránsito a nuestro lugar para mejorarlo. Si continúas navegando, consideramos que aceptas el uso de cookies

Como ves, es un tema relativo a la info de las cookes. Tendrías que verificar si tienes otro módulo o has añadido algún código a mano.

Comprueba también que no tengas la página cacheada. Vete a Parámetros Avanzados->Rendimiento y pulsa en Vaciar el caché.

ResponderCitar
Respondido : 21/12/2016 3:48 pm

Cursos Gratuitos WordPress