[Resuelto] El módulo redsys no genera pedidos  

 
MARIA DOLORES
 MARIA DOLORES
Usuario experto

Buenas tardes,

En estos dos últimos días nos estamos encontrando con el siguiente problema:

Cuando los clientes pagan a través de tarjeta mediante el módulo de Redsys no se generan los pedidos automáticamente como se venía haciendo.

No hemos modificado nada ni hemos añadido ningún módulo nuevo... simplemente ha dejado de funcionar. Por este motivo tenemos que generar los pedidos de forma manual a partir del carrito una vez que comprobamos que se ha realizado el pago.

Este problema no lo teníamos y no sabemos a qué se debe... ¿qué podría ser?

Muchas gracias!!!

Un cordial saludo.

 

 

Respondido : 01/06/2020 2:42 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Maria,

¿Puedes indicarnos cual es el URL para tu consulta? de esta forma podremos verificar con mayor detalle.

De manera general verifica tienes activo el parámetro SSL para todas las paginas en tu tienda, para verificar esto ve al apartado Parámetros de la tienda -> Configuración

Screenshot(99)

Activa para que este marcado como si.

También es posible que necesites actualizar el modulo de redsys, compruébalo desde la pagina oficial -> http://www.redsys.es/

Verifica el modulo que sea compatible con tu versión de prestashop.

Un Saludo

Respondido : 01/06/2020 3:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

MARIA DOLORES
 MARIA DOLORES
Usuario experto

@karen

Hola Karen,

Si es el último módulo de Redsys y el certificado SSL está en todas las páginas. 

Llevamos años trabajando con este módulo y nunca antes nos había pasado esto. No logramos ver donde está el problema.

www.infantilandia.es

Muchas gracias.

 

Respondido : 01/06/2020 11:52 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola María, 

¿Esto sucede con todos los productos? ¿Redsys no está notificando el pago a tu Prestashop? 

Activa el modo debut accediendo a tu cuenta de cPanel -> Administración de archivos y luego dirígete al archivo defines.inc.php ubicado en /public_html/raiz_de_tu_web/config y modifica lo siguiente:

- define('_PS_MODE_DEV_', false); lo cambias por define('_PS_MODE_DEV_', true);

- @ini_set('display_errors', 'off'); por @ini_set('display_errors', 'on');

Guardas cambios y prueba realizando una compra o espera aq que un cliente te reporte el error que le aparece al momento de comprar y pagar, aunque lo indicado es lo primero. 

¿Has probado contactar con el equipo de soporte técnico de Redsys? Ellos deben saber a qué se genera este conflicto. 

Saludos. 

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

Respondido : 02/06/2020 1:08 am

Cursos Gratuitos WordPress

MARIA DOLORES
 MARIA DOLORES
Usuario experto

@bulmaro-webempresa

Buenos días! 

Parece que ya está solucionado... ha debido ser algún problema puntual de actualización de procesos por parte de Redsys.

Ya funciona desde esta mañana.

Muchísimas gracias!

Un cordial saludo.

Respondido : 02/06/2020 8:19 am
Bulmaro me gusta

Por favor Iniciar Sesión o Registro