Avisos
Vaciar todo

[Resuelto] Traducciones que no funcionan  

 
Yandros
 Yandros
Usuario eminente

Hola

Hay algunas traducciones que por más que cambio, no se llevan a cabo en el front office. Es el caso de "Otros productos en la misma categoría". 

Voy a Internacional>Traducciones, elijo el módulo, que en este caso es "ModulesCategoryproductsShop", donde efectivamente aparece esto:

 

image

Cambio: "%s otros productos en la misma categoría" por "Otros %s productos en la misma categoría", pero da igual, en el front, por más que borro caché, etc, no se cambia.

image

 

Me pasa con alguno más, como "Todas los productos en oferta", que por más que lo cambio por "Todos" no hace nada. Lo más curioso es que si pulso en reinicializar, vuelve a poner el texto mal, con lo que lo tiene guardado en algún lugar, de donde verdaderamente está tomando el texto mal traducido, ignorando el traducido desde Traducciones.

Mi versión de prestashop es 1.7.6.5 y uso el tema Classic que viene por defecto. Sólo tengo un idioma en la tienda, los demás que venían por defecto están desactivados/eliminados.

Citar
Respondido : 31/05/2020 4:50 pm
Yandros
 Yandros
Usuario eminente

Me contesto yo mismo.

Desconozco el motivo de tener dos lugares donde traducir el mismo texto, pero esto sólo induce a errores.

El lugar correcto donde cambiar la traducción no es en la traducción de módulos, sino en en apartado de Shop, donde hay que buscar los textos que se quieren modificar. Es algo rebuscado, bajo mi punto de vista. Adjunto pantallazo del lugar correcto (el arbol desplegado ya corresponde al lugar en concreto donde se quiera hacer la traducción.

image
ResponderCitar
Respondido : 31/05/2020 5:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@administracionwbz-es

Hola, 

Excelente aporte, muchísimas gracias, será de gran ayuda para nosotros y los usuarios del foro. 

Saludos 🙂

ResponderCitar
Respondido : 31/05/2020 8:21 pm