Error al entrar en ...
Avisos
Vaciar todo

Error al entrar en algunas secciones del panel de control de prestashop  

 
David
 David
Usuario activo

Buenos días

A ver si pudierais ayudarme...

Al acceder a algunas secciones del panel de control de Prestashop como module manager, configuración de la página de inicio o al intentar cambiar de tema me salta este error:

 

Type error: Argument 3 passed to LinkBlockRepository::__construct() must be an instance of PrestaShopBundle\Translation\TranslatorComponent, instance of PrestaShopBundle\Translation\DataCollectorTranslator given, called in /home2/vexeldot/public_html/mundomanila/modules/ps_linklist/ps_linklist.php on line 65

 
  • Exception
  • Logs 2
  • Stack Trace

Symfony\Component\Debug\Exception\FatalThrowableError

Contenido solo visible a usuarios registrados

Este debate ha sido modificado el hace 1 año por Gerard Martínez
Citar
Respondido : 26/08/2020 5:30 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola David,

Puedes indicarnos cual es la URL de tu consulta? de esta forma podemos verificar con mayor detalle lo que nos comentas.

De manera general prueba desactivar el modulo ps_linklist puede que este generando un conflicto, también indícanos si haz realizado algún cambio adicional en el sitio como por ejemplo actualizar algún modulo como este que te menciono.

Un Saludo

 

ResponderCitar
Respondido : 26/08/2020 5:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Usuario activo

Hola @karen el problema es que no puedo entrar al module manager...

la url es esta: https://vexeldot.es/mundomanila/  

y esta es la que sale cuando me aparece el error:

 

Contenido solo visible a usuarios registrados

Esta publicación ha sido modificada el hace 1 año por Gerard Martínez
ResponderCitar
Respondido : 27/08/2020 9:41 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola David.

Por el aviso veo que el problema está en el módulo ps_linklist

Revisa la versión de PHP que tienes en esa instalación, la versión recomendada es la 7.3, puedes modificarla versión de PHP facilmente desde tu cuenta de cPanel:

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

 

.- Actualiza tambien la version de prestashop, la última version estable es la 1.7.6.7

 

Un saludo

 

ResponderCitar
Respondido : 27/08/2020 10:10 am

Cursos Gratuitos WordPress

David
 David
Usuario activo

@pepesoler

buenas he actualizado la versión de php a la 7.3 y ahora me sale este error nada más loguearme:

 

Warning en línea 2636 en archivo /home2/vexeldot/public_html/mundomanila/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php
[2] "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

Warning en línea 2665 en archivo /home2/vexeldot/public_html/mundomanila/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php
[2] "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

 

y si intento entrar a cualquier sección me sale esto:

 

Whoops, looks like something went wrong.

 
Contenido solo visible a usuarios registrados

Esta publicación ha sido modificada el hace 1 año por Gerard Martínez
ResponderCitar
Respondido : 27/08/2020 11:44 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola David.

Ok, vuelve a dejar la versión de PHP como la tenias.

Una vez puedas acceder a la administración, actualiza la instalación de prestashop a la ultima estable quees la 1.7.6.7

 

Si ves que con eso se soluciona, perfecto, sino eliminaremos el módulo que causa el error y lo volveremos a instalar.

 

Un saludo

ResponderCitar
Respondido : 27/08/2020 1:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario activo

@pepesoler

Hecho el downgrade del PHP al que tenia antes.

El problema es que no puedo instalar el modulo "1 click...." desde el propio prestashop porque no me conecta al catalogo de módulos...

ResponderCitar
Respondido : 27/08/2020 5:30 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola David,

Que error te muestra al momento de instalar el módulo? actualmente esta funcionando sin este modulo?, nos puedes enviar una captura del error

Un saludo 🖐️ 

ResponderCitar
Respondido : 27/08/2020 5:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario activo

@argenis

Me sale al intentar conectar con la biblioteca de módulos un texto en rojo con la palabra error. No soy capaz ni de llegar a ver el modulo en el catálogo porque no se muestra el catálogo

ResponderCitar
Respondido : 27/08/2020 5:38 pm
David
 David
Usuario activo

@argenis

Me he descargado el 1click upgrade desde github ( https://github.com/PrestaShop/autoupgrade/releases) y al darle a subir modulo me da este error: