Avisos
Vaciar todo

Error combianciones e imagenes  

 
salvador
 salvador
Usuario activo

Hola a todos. A ver si alguien me puede ayudar. Estoy con prestashop 1.7.5.1 (última actualización) y tengo los siguientes problemas que no tenía con la versión 1.7.4.x (esta versión me daba un problema y es que al borrar el cache me saltaba un error 500 por lo que no puedo volver a ella):
Error 1
*No puedo generar combinaciones: Al generar cualquier combinación se queda a medias y no llega a cargar nunca, se queda en 0/1 y al no poder añadir cantidades, el producto no se puede añadir al carrito
Error 2
*El otro error tiene que ver con la imagen en el backoffice. Las imágenes de la ficha del producto no se corresponden con las que se muestra en la lista de productos del BO
Error 3
*Finalmente después de crear el producto no puedo actualizar los cambios. Me salta “no se puede actualizar la configuración
Os agradecería la ayuda para poder solucionarlo. Supongo que serán errores del propio prestashop (lo único que he hecho es regenerar las miniaturas de imágenes) que se corregirán en futuras versiones, pero hasta que no esté solucionado no podemos tener la tienda en producción,
gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 26/02/2019 10:15 am
salvador
 salvador
Usuario activo

No creo que tenga nada que ver, pero por si acaso adjunto lo que sale después de actualizar.
Mi versión de php es 7.0

ResponderCitar
Respondido : 26/02/2019 10:30 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Salvador.

El error que muestras es de copia de copia de seguridad y es por que falta una carpeta, pero por lo que veo termina de realizar la actualización sin problemas, no tienes que preocuparte por eso.

Me comentan desde hosting que tenias carpetas y archivos con los permisos mal los corrigieron.

A nivel hosting no veo ningún problema que pueda provocar lo que nos comentas, comprueba si con el cambio de permisos se soluciona, si no intenta desactivar los módulos de terceros que no sean originales de prestashop y revisa si es algun modulo el que este provocando ese error.

Un saludo

ResponderCitar
Respondido : 26/02/2019 11:38 am
salvador
 salvador
Usuario activo

He desactivado los módulos y la plantilla y no se corrige el error. Después he cargado un backup y ejecutado Stephan para corregir los permisos y nada.

También he probado a volver a la versión 1.7.4.x y no se producen estos errores, pero claro con el error 500 en el BackOffice cada vez que borraba el caché y que ya comenté en otro hilo es imposible tener la tienda en producción así..

Estoy buscando información porque parece que debe ser error de prestashop, pero no veo a nadie que le esté pasando lo mismo.

A ver si alguien puede dar con una solución para que podamos seguir trabajando,
gracias

ResponderCitar
Respondido : 26/02/2019 12:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Puede ser también que luego de la actualización no se hayan eliminado algunos archivo de cache, eso es lo que te reportó el mensaje anterior.

Ingres a la carpeta app/cache, verifica si hay archivos, puedes dejar limpia esta carpeta eliminando todos los archivos y probar, debería generarse nuevamente los archivos de cache, luego de esto verifica nuevamente.

Saludos.

ResponderCitar
Respondido : 26/02/2019 5:09 pm
salvador
 salvador
Usuario activo

Hola Jhon, en primer lugar gracias por aportar ideas.

He mirado en la carpeta app y lo único que me aparece es lo que ves en la imagen. Qué es exactamente lo que debería de borrar? A raíz de tu sugerencia he buscado información y parece que dentro de "app" debería haber otra carpeta "cache" pero no me aparece (tengo conocimiento limitados y puede que sea una tontería, pero te agradecería que me dijeses es qué estoy fallando..)

gracias

ResponderCitar
Respondido : 27/02/2019 9:52 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Salvador.

En la versión 1.7 no existe esa carpeta, la carpeta cache la tienes dentro test y es manejado por el archivo appcache.phph

Veo que ya tienes un valor de 300 para max_execution_time.

Prueba lo siguiente:
.- Manda un ticket a soporte para que aumenten los valores de tiempo de ejecución del servidor por ejemplo a 600
.- actualiza la versión de PHP e instala la versión 7.2:
-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Revisa si después de esos pasos mejoramos un poco.

Un saludo

ResponderCitar
Respondido : 27/02/2019 3:13 pm