Error en la sincron...
Avisos
Vaciar todo

[Resuelto] Error en la sincronización externa  

 
Jose
 Jose
Reputable Member

Hola,

AL querer sincronizar desde el ERP nos ha dado este error:

image

He consultado con un ticket este problema han hecho esto:

1º Faltaba por habilitar la conexión a nivel de cPanel, que acabo de hacerlo

Te he desbloqueado una regla de seguridad que te estaba afectando.

Por el error, veo que la conexión la realiza correctamente, pero se interrumpe debido a un problema en el fichero /home2/textilco/public_html/classes/webservice/WebserviceOutputBuilder.php

A partir de este último me dicen que lo debo consultar con vosotros por ser de CMS y no del servidor.

Os puedo decir que desde el ERP han accedido miles de veces, el problema no es en los datos de acceso, tampoco de la IP. Lo que me comentaron desde el ERP es si sería algo en la conexión de los API (que yo no tengo ni idea que es eso).

Espero que me podáis echar una mano.

Gracias

Contenido solo visible a usuarios registrados

Respondido : 10/01/2022 7:35 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Jose,

Discúlpanos pero creo que necesitamos un poco mas de contexto para poder ayudarte.

El error 500 plantea una conexión que no fue satisfactoria en este caso con tu sitio, ahora bien este problema es reciente? has podido sincronizar esta herramienta anteriormente sin problemas?

Lo sugerido desde la herramienta ERP sobre la conexión de la API es algo que ellos deben especificarte detalladamente.

Quedamos atentos, Saludos!

Respondido : 10/01/2022 8:02 pm

Cursos Gratuitos WordPress

Jose
 Jose
Reputable Member

Hola,

 

He buscado lo que hay en la línea que indica el error en ese archivo, pone esto:

$fields_assoc = [['id' => $value['id']]];

 

Gracias

Respondido : 10/01/2022 8:05 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Jose,

Gracias por lo que no has comentado sin embargo quedaron consultas sin responder

De momento puedo recomendarte intentar cambiando la version de PHP que tienes activa y si el problema persiste es necesario que notifiques detalladamente al soporte del ERP lo que esta sucediendo y si es el error de una configuración puedas tener contexto donde cambiarla.

Si es error de el archivo en particular no hemos podido hallar un caso similar por lo que podemos remitirte a nuestros colaboradores que con gusto podrán ver tu caso sin embargo se necesitan mas detalles https://www.webempresa.com/directorio-colaboradores.html

Saludos!

Respondido : 10/01/2022 9:06 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Reputable Member

Hola,

Se ha arreglado bajando la versión de PHP, buscando por internet algo sobre esto encontré este comentario a un problema similar:

La URL donde se comenta: https://stackoverflow-com.translate.goog/questions/59336951/message-trying-to-access-array-offset-on-value-of-type-null?_x_tr_sl=en&_x_tr_tl=es&_x_tr_hl=es&_x_tr_pto=sc

Esto sucede porque $cOTLdatano es nulo pero el índice 'char_data'no existe. Las versiones anteriores de PHP pueden haber sido menos estrictas con tales errores y se tragaron silenciosamente el error / aviso, mientras que 7.4 ya no hace esto.

 

Como digo no es exactamente lo mismo, pero es posible que esa versión del PHP sea más estricta, tenía la 7.4 y bajando a la 7.3 ha funcionado todo.

Me queda la duda de cuál es exactamente el problema, pero bueno, ahora teníamos urgencia por resolverlo para poder trabajar lo que no se pudo hacer en todo el día.

Muchas gracias por la ayuda.

Un saludo.

Respondido : 10/01/2022 9:49 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Jose,

Como te indico Bruno, existen ciertos ajustes y configuraciones que hacen que tu complemento funcione de forma correcta, en este caso este ajuste que mencionas

Respondido por: @bitebitgmail-com

Esto sucede porque $cOTLdatano es nulo pero el índice 'char_data'no existe. Las versiones anteriores de PHP pueden haber sido menos estrictas con tales errores y se tragaron silenciosamente el error / aviso, mientras que 7.4 ya no hace esto.

Te da la respuesta, el error igualmente aunque lo solventases bajando la versión php, es un error que debería ser solventado por los desarrolladores del modulo en una futura actualización por lo que respondiendo a tu pregunta

Respondido por: @bitebitgmail-com

Me queda la duda de cuál es exactamente el problema

Básicamente hay ciertos ajustes en el modulo que no están optimizados y tienen que mejorarlo los desarrolladores del mismo. Con esto entendemos que el tema esta resuelto, si tienes alguna otra duda recuerda que puedes crear un nuevo tema y con gusto lo atenderemos.

Un saludo 🖐️ 

Respondido : 10/01/2022 10:05 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación