Importación datos a 1.7 desde 1.6  

Página 2 / 4
 
Jose
 Jose
Usuario experto

Hola,

Vengo de otro tema en el que empecé por el traslado de una web en 1.6.1.20 a la 1.7.6.3 y se fue alargando, siento las molestias.

Se trata de una multitienda con cobres.es y sabela.es.

Ahora mismo tengo creado en un subdominio nuevo.cobres.es, una instalación de la versión 1.7 para ir migrando los datos, según enlaces que me ibais facilitando.

Los problemas que he encontrado son:

 

1. He conseguido pasar las categorías y los productos, pero detecté que en los productos en la 1.7 me faltan campos.

Pongo un ejemplo de un producto:

En la 1.6: EAN13 o código de barras JAN = 8458742154561   ->   En la 1.7: UPC, pero está vacío.

En la 1.6: Precios específicos = Mando captura   ->  En la 1.7: se llama igual pero está vacío.

En la 1.6: Meta título = la durbel-r media sin liga espuma 40 den la llave 0006 1055   ->  En la 1.7: se llama igual pero está vacío.

En la 1.6: Meta descripción = 006  ->  En la 1.7: se llama igual pero está vacío.

En la 1.6: Categorías asociadas = Dentro de una subcarpeta, dentro de otra que está en Inicio, solo está marcada "Medias con y sin liga"  -> En la 1.7: Mismo nombre, Marcada Inicio, y además está sola, no tiene subcarpetas.

En la 1.6: Combinaciones = Hay tres variaciones del producto   ->  En la 1.7: Aparece marcada la opción de producto simple.

Creo que es todo lo que falta, porque los demás campos vacíos ya estaban sin datos porque los cogen del ERP.

 

2. Por otro lado, con los atributos me encuentro con un problema, en la versión 1.6 no encuentro el botón de Exportar a CSV, encuentro las siguientes opciones:

Añadir nuevos atributos

Importar

Actualizar lista

Mostrar consulta SQL

Mostrar a SQL Manager

Qué debo hacer?

 

3. Para Marcas, Fabricantes en la 1.6, no me coinciden los campos a asignar (en importar tengo seleccionado Marcas), mando capturas de ámbas. Además al importar y abrirlo en Calc las imágenes de las marcas no las muestra, las celdas están vacías.

 

Marcas
Fabricantes

 

Gracias por la ayuda.

Citar
Respondido : 19/07/2020 11:38 pm
Jose
 Jose
Usuario experto

Hola,

Creo que ya entendí los pasos a hacer, debo ir añadiendo los datos desde el fichero exportado hacia el Archivo de ejemplo de productos descargado, y ponerlos en las columnas correspondientes para tenerlo listo antes de importar. Yo estaba asignando las columnas a los datos desordenados en la importación, por eso no lo hacía bien.

Ahora acabo de probar a hacerlo así, pero otra vez me da error en las URLs de las imágenes, y al acabar no me muestra los productos.

Se detectaron algunos errores. Por favor, revise los detalles:

  • Error al copiar la imagen:
  • Error al copiar la imagen:
  • Error al copiar la imagen:
  • Error al copiar la imagen:
  • Error al copiar la imagen:
  • Error al copiar la imagen:
  • Error al copiar la imagen:

Acabo de buscar la primera de las imágenes, desde cPanel, y la URL correcta sería:

?time=1596017005495

Y en la tabla exportada aparece dos veces (los siete artículos las tienen dos veces):

https://cobres.es/3975/la-durbel-media-sin-liga-espuma-40-den-la-llave-0006.jp g" target="_blank">https://cobres.es/3975/la-durbel-media-sin-liga-espuma-40-den-la-llave-0006.jp g"/>

Y además de dos veces, están mal, la URL está incompleta, faltan las carpetas intermedias.

Gracias

ResponderCitar
Respondido : 29/07/2020 11:10 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Disculpa no logramos ver las imágenes que nos compartes, puedes subirlas nuevamente para verificar lo que nos comentas.

De manera general verifica las imágenes las estas asignado en la ruta correcta, debes comprobar la ruta de tus imágenes, luego de comprobarlas añade la correcta al archivo y intenta realizar nuevamente la importación.

Un Saludo

ResponderCitar
Respondido : 29/07/2020 11:30 am
Jose
 Jose
Usuario experto

Veo que no aparecen los errores, pero es la misma imagen que ya había pegado antes, solo que aquí copié el texto:

Errores de imágenes

Y la URL de la imagen en la v. 1.6 guardada: ?time=1596017005495

Gracias

ResponderCitar
Respondido : 29/07/2020 11:31 am

Cursos Gratuitos WordPress

Jose
 Jose
Usuario experto

Pues nada, acabo de quitar el enlace a la imagen para que se vea la URL y ni así, quitaré el http

//cobres.es/img/p/3/9/7/5/3975-small_default.jpg?time=1596017005495

ResponderCitar
Respondido : 29/07/2020 11:32 am
Jose
 Jose
Usuario experto

Hola,

Acabo de ver tu mensaje. Como ves ya os añadí una imagen donde se ven los errores.

Me dices que compruebe la ruta de las imágenes, que es precisamente lo que hice, tal y como te comento en otra respuesta. Sé cuál es la URL correcta y podría cambiarla en estos siete productos de prueba, el problema sería tener que cambiar manualmente casi 1900 productos. Espero que haya alguna forma de solucionar esto.

Gracias

ResponderCitar
Respondido : 29/07/2020 11:53 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Estoy verificando una de tus rutas que se indicas y abre sin problemas.

Puedes probar crear un directorio para tus imágenes dentro de tu cPanel donde tienes los archivos del nuevo sitio web,  luego subirlas y desde esta ruta importarlas.

Por ejemplo la URL seria  https://tudominio.com/imagenes/nombre-imagen.jpg 

Comprueba con 5 imágenes y intenta importar los productos de esta forma

Verifica si con esto logras importas las imágenes

Un Saludo

This post was modified hace 3 meses 2 times por Karen Rios
ResponderCitar
Respondido : 29/07/2020 11:59 am
Jose
 Jose
Usuario experto

@karen

Hola, 

He probado a hacer lo que comentas, te pongo un ejemplo de lo que hice con una de ellas:

La ruta de la foto es:  cobres.es/img/p/2/4/6/5/2465-small_default.jpg?time=1596017344973

En la carpeta de la nueva instalación encontraba:  cobres.es/nuevo/img/p/2/4/6/

Es decir faltaba la última carpeta y sus archivos. Lo que hice fue copiar todo el contenido de esa última carpeta (cobres.es/img/p/2/4/6/) y pegarlo en la ubicación nueva (cobres.es/nuevo/img/p/2/4/6/).

Lo he realizado con los 7 productos anteriores, pero al importar me vuelve a dar los mismos errores y sigo sin productos.

Gracias por vuestra ayuda.

ResponderCitar
Respondido : 29/07/2020 6:08 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Cuando importas las imagénes, entiendo que lo haces desde un archivo en donde tienes las rutas, prueba quitar los parámetros finales, es decir estos : ?time=1596017005495

Sólo quédate con la ruta de la imagen que termina en la extensión de la misma (.jpg , .png, etc)

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/07/2020 8:48 pm
Jose
 Jose
Usuario experto

Hola

La dirección de la imagen con " ?time=1596017005495" al final esla dirección que obtengo al inspeccionar la imagen en el navegador. Pero en la tabla que exporto aparece así:

https://cobres.es/3975/la-durbel-media-sin-liga-espuma-40-den-la-llave-0006.jp g" target="_blank">https://cobres.es/3975/la-durbel-media-sin-liga-espuma-40-den-la-llave-0006.jp g"/>

No sé porqué aparece dos veces.

Lo corregí dejándo solo una dirección, tal y como aparece en la siguiente imagen:

URL corregidas

Pero me vuelve a dar los mismos errores en las imágenes.

Errores en importación

Espero haberme explicado bien.

Gracias

ResponderCitar
Respondido : 30/07/2020 12:02 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@bitebitgmail-com

Hola José,

Si, creo que logro entenderte, por favor, proporciónanos el fichero ultimo que estás utilizando para la importación, siempre que realices modificaciones en él y hagas nuevas pruebas igualmente compártelo para poder revisar.

Saludos

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 30/07/2020 3:09 am
Jose
 Jose
Usuario experto

@bulmaro-webempresa

 

Hola, 

Datos de prueba exportados desde la versión 1.6

Datos modificados en CALC e importados a la versión 1.7

 

Mucgas gracias

ResponderCitar
Respondido : 30/07/2020 8:12 pm

Cursos Gratuitos WordPress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola José, 

¿Qué procedimiento seguiste para exportar los productos? 

Tu procedimiento fue el de ir a catalogo -> Productos -> Opciones -> Exportar productos? ¿Podrías exportarlos nuevamente siguiendo este método y sin realizarle modificaciones con CALC si no con EXCEL de preferencia en la versión para Windows? Por favor, ya que no entiendo por qué te adjunta 2 imágenes por campo en algunos productos, ¿Tienes combinaciones de productos y será que a estas combinaciones pertenecen las imágenes? ¿Podrías validarlo? Por favor

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 31/07/2020 12:27 am
Jose
 Jose
Usuario experto

Hola,

Estaba segura de haber exportado los datos como dices, pero al volver a exportar y abrirlo con Excel (lo mismo con CALC) me muestra muy pocos datos, me faltan Marcas, Meta-título, Meta-descripción, entre otros):

Así los dejé con Excel:

Probé a importar, pero sigue habiendo errores, antes eran "Rerror al copiar la imagen", ahora son diferentes...

Errores importar desde Excel

No recuerdo exportar de otra forma, pero veo que la tabla cambia.

Gracias

ResponderCitar
Respondido : 31/07/2020 1:38 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@bitebitgmail-com

Hola José,

Entonces el problema está desde la exportación de datos, te sugiero revisar el siguiente hilo del foro -> exportar-productos-prestashop-16

He realizado una prueba con el fichero que nos compartes y sí que se importan, el problema con la imagen que te marca error es por que dicha url de la imagen devuelve un error 404, que quiere decir que dicho recurso no existe en esa dirección, es decir, la url de la imagen es incorrecta. Si notas te darás cuenta de que hacen falta muchos campos de datos en este nuevo .csv, por ello te digo que tenemos un problema desde la exportación de los mismos. 

Saludos 🙂

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 31/07/2020 3:05 am
Jose
 Jose
Usuario experto

Hola,

Me acabo de dar cuenta de que exportaba con un plugin, el que me habíais indicado anteriormente:

https://www.prestashop.com/forums/topic/37900-free-module-products-export-module-v271-updated-23072020/

En esta tabla están todos los campos, aunque el campo de la imagen duplica la URL, eliminé a mano una de ellas y queda así:

Y es cuando me da el error de las imágenes, pero sólo es ese error.

Errores en importación

Como ya había comentado con una compañera vuestra, copié las imágenes de la carpeta original y las pegué en la carpeta del nuevo dominio, y ahí es dónde imagino que está el problema, porque la URL es diferente, un ejemplo era:

La ruta de la foto es:  cobres.es/img/p/2/4/6/5/2465-small_default.jpg

En la carpeta de la nueva instalación encontraba:  cobres.es/nuevo/img/p/2/4/6/5/2465-small_default.jpg

Evidentemente al trabajar con un subdominio la URL cambia ¿será por esto?

Gracias

ResponderCitar
Respondido : 31/07/2020 11:25 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Página 2 / 4

Por favor Iniciar Sesión o Registro